liblexical-persistence-perl_1.022-1_all.deb


Advertisement

Description

liblexical-persistence-perl - module for accessing persistent data through lexical variables

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: liblexical-persistence-perl
Package version: 1.022
Package release: 1
Package architecture: all
Package type: deb
Installed size: 75 B
Download size: 17.49 KB
Official Mirror: ftp.br.debian.org
Lexical::Persistence is a Perl data persistence framework that enables code to access persistent data through what looks like lexical variables. So, instead of passing data around explicitly, you can call functions through the Lexical::Persistence object and just use ordinary variables.

    Download

    Source package: liblexical-persistence-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liblexical-persistence-perl deb package:
      # sudo apt-get install liblexical-persistence-perl

    Files

    • /usr/share/doc/liblexical-persistence-perl/changelog.Debian.gz
    • /usr/share/doc/liblexical-persistence-perl/changelog.gz
    • /usr/share/doc/liblexical-persistence-perl/copyright
    • /usr/share/doc/liblexical-persistence-perl/examples/persistence.perl
    • /usr/share/doc/liblexical-persistence-perl/examples/repl-mst.perl
    • /usr/share/man/man3/Lexical::Persistence.3pm.gz
    • /usr/share/perl5/Lexical/Persistence.pm

    Changelog

    2013-08-16 - Florian Schlichting <fsfs@debian.org> liblexical-persistence-perl (1.022-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Removed Alexis Sukrieh from Uploaders (Closes: #536162) * Drop unnecessary version dependencies satisfied by oldstable * Use new short debhelper rules format [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Florian Schlichting ] * Import Upstream version 1.022 * Bump Standards-Version to 3.9.4 (update to copyright-format 1.0, directly link GPL-1+) * Bump year of upstream copyright * Add copyright paragraph for copy of YAML::Tiny embedded in t/000-report-versions.t * Bump dh compatibility to level 8 (no changes necessary) * Switch to source format 3.0 (quilt) * Expand long description * Version dependencies on Devel::LexAlias and PadWalker * Add myself to uploaders and copyright

    2008-11-13 - Jose Luis Rivas <ghostbar38@gmail.com> liblexical-persistence-perl (0.98-1) unstable; urgency=low [ Jose Luis Rivas ] * New upstream release * Refreshed debian/copyright * Changed to debhelper v7, updated debian/{rules,compat,control}. * Bumped to 3.8.0 Standars-Version (no changes) * Updates Vcs-Browser URI to viewsvn instead of wsvn * Added me as uploader. [ gregor herrmann ] * debian/control: change my email address.

    2008-03-08 - gregor herrmann <gregor+debian@comodo.priv.at> liblexical-persistence-perl (0.97-2) unstable; urgency=low * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). Removed: XS- Vcs-Svn fields. Added: libtest-pod-perl, libtest-pod-coverage-perl to Build-Depends-Indep in order to enable additional tests. Added: /me to Uploaders. * debian/rules: - delete /usr/lib/perl5 only if it exists (closes: #467885) - let install-stamp target depend on build-stamp - move dh_clean before make realclean - don't install README any more (just a copy of the POD documentation) - install eg/* as examples * debian/watch: use dist-based URL. * Set Standards-Version to 3.7.3 (no changes). * debian/copyright: use generic download location.

    2007-08-17 - Alexis Sukrieh <sukria@debian.org> liblexical-persistence-perl (0.97-1) unstable; urgency=low * Initial Release (closes: #438487).

    Advertisement
    Advertisement