liblaf-widget-java_4.3-2_all.deb


Advertisement

Description

liblaf-widget-java - Java widget toolbox for other look-and-feel libraries

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: liblaf-widget-java
Package version: 4.3
Package release: 2
Package architecture: all
Package type: deb
Installed size: 480 B
Download size: 378.92 KB
Official Mirror: ftp.br.debian.org
Laf-Widget project provide support for and base set of additional behaviour and widgets in look-and-feels libraries. The list of currently provided widgets: * Auto-completion (model-based / free-text) on editable combo boxes. * Hover preview of minimized internal frames on desktop icons. * Menu search panel on menu bars. * Hover preview of tab in tabbed panes. * Overview dialog on tabbed panes with optional periodic refresh. * Tab paging on tabbed panes. * Password strength checker on password fields. * Lock border on non-editable text components and model editable combobox. * Select all text in text component on focus gain. * Context menu on text components with edit actions (copy / paste / cut ...). * Enhanced drag-and-drop support for trees. * Scroll pane selector. * Selecting / deselecting in text components on Escape key press. Laf-Widget is used by substance look-and-feel since 3.0

Alternatives

    Download

    Source package: liblaf-widget-java

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liblaf-widget-java deb package:
      # sudo apt-get install liblaf-widget-java

    Files

    • /usr/share/doc/liblaf-widget-java/changelog.Debian.gz
    • /usr/share/doc/liblaf-widget-java/copyright
    • /usr/share/java/laf-widget-4.3.jar
    • /usr/share/java/laf-widget.jar

    Changelog

    2011-08-15 - Torsten Werner <twerner@debian.org> liblaf-widget-java (4.3-2) unstable; urgency=low * Switch to source format 3.0. * Remove Java runtime from Depends. * Update Standards-Version: 3.9.1.

    2009-11-04 - Damien Raude-Morvan <drazzib@debian.org> liblaf-widget-java (4.3-1) unstable; urgency=low * New upstream release. - Minimal JDK version is now >= 6 * New "liblaf-widget-java-doc" package: - contains API javadoc documentation * Bump debhelper version to >= 7 * Remove unused Depends on ${shlibs:Depends} * Add myself to Uploaders * Bump Standards-Version to 3.8.3 - Rename debian/README.Debian-source to debian/README.source - Describe quilt patch system in debian/README.source * Default JDK: - Build-Depends on default-jdk - Use /usr/lib/jvm/default-java as JAVA_HOME in debian/rules - Depends on default-jre | java6-runtime * Use upstream build system: - Remove debian/build.xml - Define jdk.home in debian/ant.properties - Patch upstream build.xml to generate javadoc (build.diff) * Add debian/watch to indicate that upstream uses a distribution mechanism that cannot be meaningfully monitored by uscan * Improve synopsis and extended description

    2009-05-25 - Varun Hiremath <varun@debian.org> liblaf-widget-java (4.2-2) unstable; urgency=low * Add patches/Drop_EDT_checks.diff patch to disable EDT violations to enable Jajuk work properly

    2009-05-25 - Varun Hiremath <varun@debian.org> liblaf-widget-java (4.2-1) unstable; urgency=low * New upstream release

    2009-03-04 - Torsten Werner <twerner@debian.org> liblaf-widget-java (4.0-2) unstable; urgency=low * Change tango icons license to creative commons by sa 3.0 which is allowed by the former license. * Move package to main.

    2008-11-17 - Varun Hiremath <varun@debian.org> liblaf-widget-java (4.0-1) unstable; urgency=low * New upstream release * Switch to openjdk * Bump Standards-Version to 3.8.0

    2008-07-24 - Torsten Werner <twerner@debian.org> liblaf-widget-java (3.4-1) unstable; urgency=low * New upstream release * Do not quote the full Apache License in debian/copyright. * Switch to Sun Java 6.

    2007-12-16 - Torsten Werner <twerner@debian.org> liblaf-widget-java (3.2-1) unstable; urgency=low * New upstream release * Change Standards-Version: 3.7.3.

    2007-10-15 - Varun Hiremath <varunhiremath@gmail.com> liblaf-widget-java (3.2~dev-1) unstable; urgency=low * New upstream release * Move the package to pkg-java svn. * Set Maintainer to Debian Java Maintainers and add myself to Uploaders. * Move the build scripts to debian dir.

    2007-09-09 - Varun Hiremath <varunhiremath@gmail.com> liblaf-widget-java (3.1-1) unstable; urgency=low * New upstream release. * debian/control: move the package to non-free because of Tango icons' CC-by-sa-v2.5 license. * debian/copyright: Include the full text of CC-by-sa-v2.5 license. * debian/rules: fix the installed jar version and the dh_link.

    Advertisement
    Advertisement