libhashkit-dev_1.0.18-4_i386.deb


Advertisement

Description

libhashkit-dev - libmemcached hashing functions and algorithms (development files)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libhashkit-dev
Package version 1.0.18
Package release 4
Package architecture i386
Package type deb
Installed size 123 B
Download size 37.66 KB
Official Mirror ftp.br.debian.org
libhashkit is a small and thread-safe client library that provides a
collection of useful hashing algorithm. libhashkit is distributed with
libmemcached.
This package provides the development files.

Alternatives

Package Version Architecture Repository
libhashkit-dev_1.0.18-4_amd64.deb 1.0.18 amd64 Debian Main
libhashkit-dev - - -

Requires

Name Value
libhashkit2 = 1.0.18-4

Replaces

Name Value
libmemcached-dev << 1.0.3-1

Download

Type URL
Binary Package libhashkit-dev_1.0.18-4_i386.deb
Source Package libmemcached

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libhashkit-dev deb package:
    # sudo apt-get install libhashkit-dev

Files

Path
/usr/include/libhashkit/hashkit.h
/usr/include/libhashkit-1.0/algorithm.h
/usr/include/libhashkit-1.0/behavior.h
/usr/include/libhashkit-1.0/configure.h
/usr/include/libhashkit-1.0/digest.h
/usr/include/libhashkit-1.0/function.h
/usr/include/libhashkit-1.0/has.h
/usr/include/libhashkit-1.0/hashkit.h
/usr/include/libhashkit-1.0/hashkit.hpp
/usr/include/libhashkit-1.0/str_algorithm.h
/usr/include/libhashkit-1.0/strerror.h
/usr/include/libhashkit-1.0/string.h
/usr/include/libhashkit-1.0/types.h
/usr/include/libhashkit-1.0/visibility.h
/usr/lib/i386-linux-gnu/libhashkit.a
/usr/lib/i386-linux-gnu/libhashkit.so
/usr/share/doc/libhashkit-dev/changelog.Debian.gz
/usr/share/doc/libhashkit-dev/changelog.gz
/usr/share/doc/libhashkit-dev/copyright

Changelog

2014-11-12 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.18-4) unstable; urgency=medium
* Add move-ax_confix_aux_dir.patch to move AC_CONFIG_AUX_DIR up a few lines
so autofoo can find it (Closes: #768688).
* Bump Standards-Version to 3.9.6.
* Update Vcs-Browser field.
* Move main license entry to top in d/copyright.
2014-03-19 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.18-3) unstable; urgency=low
* Upload to unstable.
2014-03-17 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.18-2) experimental; urgency=low
* Include c++11.patch to prevent relying on C++11 features in
reverse-dependencies (Closes: #740940,#740941,#740935).
2014-02-28 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.18-1) experimental; urgency=medium
* Imported Upstream version 1.0.18 (Closes: #724729,#688089).
* Move git packaging repository to alioth.
Update Vcs-* fields accordingly.
* Bump Standards-Version to 3.9.5.
* Check PGP detached signature for source tarball.
+ Add upstream signing key DA248813 in d/upstream-signing-key.pgp.
+ Add pgpsigurlmangle option to d/watch.
* Fix typos in long description, thanks to
Pascal De Vuyst (Closes: #732764).
* Update years in d/copyright.
* Make Build-Depends on automake unversioned.
* Make license short names in d/copyright conformant to machine readable
format 1.0:
+ BSD-TangentOrg to BSD-3-clause-TangentOrg
+ "Paul Hsieh derivative license" to Paul-Hsieh
+ "RSA Data Security License" to RSA-Data-Security
+ "Bob Jenkins License" to Bob-Jenkins
+ BSD-Sun to BSD-3-clause-Sun
+ BSD to BSD-3-clause
* Add lintian overrides for missing symbol files.
* Include debian/upstream-signing-key.pgp in the allowed binary files.
* Remove patches included in upstream:
+ autoconf_ax_memcached
+ gcc-4.8.patch
* Unfuzz patches:
+ fix_spelling.patch
+ hurd.patch
2013-06-17 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.17-2) experimental; urgency=low
* Add hurd.patch to fix build failures on GNU/Hurd, thanks to Pino Toscano
(Closes: #644657).
2013-06-12 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.17-1) experimental; urgency=low
[ Faidon Liambotis ]
* New upstream release.
- Fixes FTBFS on multiple architectures.
* Add patch autoconf_ax_memcached, fixing an upstream bug manifesting in the
absence of a memcached binary during the execution of the test suite.
* Add --with autoreconf to dh and build-depend on dh_autoreconf; necessary
for the above autoconf patch to work.
* Remove patch fix-for-gcc47.patch from source: not in series, applied
upstream.
[ Michael Fladischer ]
* Bump Standards version to 3.9.4.
* Add 'Multi-Arch: same' to -dbg package.
* Add patch m4_pthread, which fixes the flags for pthreads.
* Add patch gcc-4.8, fixing incompatible flags with gcc-4.8 (taken from
upstream BTS).
2013-02-13 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.16-1) experimental; urgency=low
* New upstream release.
* Update spelling patch.
* Remove conflicts on older versions of libmemcached and libhashkit
(Closes:700091).
* Update spelling patch.
* Install libhashkit2 manpages manually.
* Bump SONAME to 11 for libmemcached.
* Manually install libmemcached manpages.
* Update naming conflict resolution to cope with new manpages.
* Drop libmemcachedprotocol package as it is broken and no longer maintained
in upstream.
* Manually install libmemcached-tools manpages.
2012-05-30 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.8-1) unstable; urgency=low
* New upstream release.
* Clean up files to allow two builds in a row.
* Fix duplicate Copyright fields.
* Switch to dh format 9:
+ Enable hardening.
+ Enable mutli-arch.

See Also

Package Description
libhashkit2_1.0.18-4_i386.deb libmemcached hashing functions and algorithms
libhavege-dev_1.9.1-1_i386.deb entropy source using the HAVEGE algorithm - development files
libhavege1_1.9.1-1_i386.deb entropy source using the HAVEGE algorithm - shared library
libhawknl-dev_1.6.8+dfsg2-1_i386.deb Hawk game oriented network library API (development headers)
libhawknl_1.6.8+dfsg2-1_i386.deb Hawk game oriented network library API
libhawtjni-runtime-java_1.10-1_all.deb Java library that provide JNI code generation
libhbaapi-dev_2.2.9-1_i386.deb SNIA HBAAPI library (development files)
libhbaapi2_2.2.9-1_i386.deb SNIA HBAAPI library
libhbalinux-dev_1.0.16-1_i386.deb Library headers files for retrieving FCOE adapter information
libhbalinux2_1.0.16-1_i386.deb Library for retrieving FCOE adapter information
libhcrypto4-heimdal_1.6~rc2+dfsg-9+deb8u1_i386.deb Heimdal Kerberos - crypto library
libhd-dev_21.6-1_i386.deb Hardware identification system library and headers
libhd-doc_21.6-1_all.deb Hardware identification system library documentation
libhd21_21.6-1_i386.deb Hardware identification system library
libhdate-dev_1.6-2.2_i386.deb Provides a library that help use hebrew dates (development files)
Advertisement
Advertisement