libcgal-qt4-10_4.5-2_i386.deb


Advertisement

Description

libcgal-qt4-10 - C++ library for computational geometry (support for Qt4)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libcgal-qt4-10
Package version 4.5
Package release 2
Package architecture i386
Package type deb
Installed size 224 B
Download size 92.77 KB
Official Mirror ftp.br.debian.org
CGAL (Computational Geometry Algorithms Library) makes the most important
of the solutions and methods developed in computational geometry available
to users in industry and academia in a C++ library. The goal is to provide
easy access to useful, reliable geometric algorithms.
The CGAL library contains:
- the Kernel with geometric primitives such as points, vectors, lines,
predicates for testing things such as relative positions of points, and
operations such as intersections and distance calculation.
- the Basic Library which is a collection of standard data structures and
geometric algorithms, such as convex hull in 2D/3D, (Delaunay)
triangulation in 2D/3D, planar map, polyhedron, smallest enclosing circle,
and multidimensional query structures.
- the Support Library which offers interfaces to other packages, e.g., for
visualisation, and I/O, and other support facilities.
This package contains libCGAL_Qt4.so used for visualization in demos.

Alternatives

Package Version Architecture Repository
libcgal-qt4-10_4.5-2_amd64.deb 4.5 amd64 Debian Main
libcgal-qt4-10 - - -

Requires

Name Value
libc6 >= 2.4
libcgal10 = 4.5-2
libgcc1 >= 1:4.1.1
libqt4-opengl >= 4:4.5.3
libqtcore4 >= 4:4.7.0~beta1
libqtgui4 >= 4:4.5.3
libstdc++6 >= 4.4.0

Download

Type URL
Binary Package libcgal-qt4-10_4.5-2_i386.deb
Source Package cgal

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcgal-qt4-10 deb package:
    # sudo apt-get install libcgal-qt4-10

Files

Path
/usr/lib/libCGAL_Qt4.so.10
/usr/lib/libCGAL_Qt4.so.10.0.4
/usr/share/doc/libcgal-qt4-10

Changelog

2014-10-16 - Joachim Reichel <reichel@debian.org>
cgal (4.5-2) unstable; urgency=medium
* Re-enable support for GMPXX (accidentally disabled in 4.1-1,
Closes: #705803).
* Remove traces of incorrect attempts to enable MPFI and NTL support.
Enabling support for these libraries causes some examples no longer
to build.
* Add libmpfi-dev and libntl-dev to Suggests: of libcgal-dev and
libcgal-demo.
* Remove section about very old versions of libqglviewer from
README.Debian, add section about enabling support for MPFI and NTL.
2014-10-10 - Joachim Reichel <reichel@debian.org>
cgal (4.5-1) unstable; urgency=medium
* New upstream release.
* Pass --no-name to gzip to favor reproducible builds.
* Adapt debian/watch to new site structure.
* Update Standards-Version to 3.9.6 (no changes needed).
2014-04-05 - Joachim Reichel <reichel@debian.org>
cgal (4.4-1) unstable; urgency=medium
* New upstream release.
* Remove patches do-not-link-example-with-qt4-support-library.patch and
fix_jet_fitting_3.patch (applied upstream).
2014-03-27 - Joachim Reichel <reichel@debian.org>
cgal (4.3-3) experimental; urgency=medium
* Remove no-longer existing Suggests: alternative libatlas.so.3gf from
libcgal-demo (Closes: 738743).
* Replace Suggests: libqglviewer-qt4-dev by libqglviewer-dev for
libcgal-demo.
2014-01-26 - Joachim Reichel <reichel@debian.org>
cgal (4.3-2) experimental; urgency=medium
* Added patch fix_jet_fitting_3 (Closes: #736482).
* Update Standards-Version to 3.9.5 (no changes needed).
2013-10-17 - Joachim Reichel <reichel@debian.org>
cgal (4.3-1) experimental; urgency=low
* New upstream release.
* Remove patch patch fix-fpu-rounding-modes-ia64 (applied upstream).
2013-07-28 - Joachim Reichel <reichel@debian.org>
cgal (4.2-5) unstable; urgency=low
* Add Replaces: libcgal-dev (<< 4.1-1), Breaks: libcgal-dev (<< 4.1-1) to
libcgal-qt4-dev (Closes: #718006).
* Update Standards-Version to 3.9.3 (no changes needed).
* Removed hardening-no-fortify-functions from lintian overrides for
libcgal-qt4-10 and libcgal-ipelets. Added spelling-error-in-binary to
lintian overrides for libcgal-ipelets.
2013-05-21 - Joachim Reichel <reichel@debian.org>
cgal (4.2-4) unstable; urgency=low
* Fix FTBFS on i386, hurd-i386, and kfreebsd-i386 caused by missing
handling of excess FPU precision in recently added test
rounding_math_simple.cpp.
* Add patch fix-fpu-rounding-modes-ia64 to fix FTBFS on ia64.
* Remove -DWITH_NTL=ON from cmake configuration for CGAL ipelets (not
needed).
2013-05-20 - Joachim Reichel <reichel@debian.org>
cgal (4.2-3) unstable; urgency=low
* Change Recommends: libcgal10-qt4 of libcgal-demo to the correct
package name libcgal-qt4-10.
* Add a stand-alone test extracted from Interval_nt.h (fails on ia64).
* Update Standards-Version to 3.9.4 (no changes needed).
2013-05-08 - Joachim Reichel <reichel@debian.org>
cgal (4.2-2) unstable; urgency=low
* Upload to unstable.

See Also

Package Description
libcgal-qt4-dev_4.5-2_i386.deb C++ library for computational geometry (development files, support for Qt4)
libcgal10_4.5-2_i386.deb C++ library for computational geometry
libcgi-ajax-perl_0.707-1_all.deb Perl-specific system for writing Asynchronous web applications
libcgi-application-basic-plugin-bundle-perl_0.8_all.deb bundle of basic plugins for CGI::Application
libcgi-application-dispatch-perl_3.12-1_all.deb request dispatcher for CGI::Application
libcgi-application-extra-plugin-bundle-perl_0.6_all.deb bundle of extra CGI::Application plugins
libcgi-application-perl_4.50-2_all.deb framework for building reusable web-applications
libcgi-application-plugin-actiondispatch-perl_0.99-1_all.deb attribute extension for CGI::Application
libcgi-application-plugin-anytemplate-perl_0.18-1+deb8u1_all.deb module supporting any templating system in CGI::Application
libcgi-application-plugin-authentication-perl_0.20-3_all.deb authentication framework for CGI::Application
libcgi-application-plugin-authorization-perl_0.07-2_all.deb authorization framework for CGI::Application
libcgi-application-plugin-autorunmode-perl_0.18-1_all.deb CGI::App plugin to automatically register runmodes
libcgi-application-plugin-captcha-perl_0.04-1_all.deb module providing CAPTCHA support in CGI::Application
libcgi-application-plugin-config-simple-perl_1.01-1_all.deb module providing Config::Simple support to CGI::Application
libcgi-application-plugin-configauto-perl_1.33-1_all.deb plugin that adds Config::Auto support to CGI::Application
Advertisement
Advertisement