libcegui-mk2-0.7.6_0.7.6-3.3_i386.deb


Advertisement

Description

libcegui-mk2-0.7.6 - Crazy Eddie's GUI (libraries)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libcegui-mk2-0.7.6
Package version 0.7.6
Package release 3.3
Package architecture i386
Package type deb
Installed size 4.60 KB
Download size 1011.47 KB
Official Mirror ftp.br.debian.org
CEGUI is a free library providing windowing and widgets for graphics
APIs and engines where such functionality is not natively available
or is severely lacking. The library is written in C++, is object
oriented, and is primarily targeted at games developers who should be
spending their time creating great games, not building GUI sub-systems
This version of CEGUI natively supports the OpenGL rendering target.

Alternatives

Package Version Architecture Repository
libcegui-mk2-0.7.6_0.7.6-3.3_amd64.deb 0.7.6 amd64 Debian Main
libcegui-mk2-0.7.6 - - -

Requires

Name Value
libboost-system1.55.0 -
libc6 >= 2.4
libdevil1c2 -
libexpat1 >= 2.0.1
libfreeimage3 -
libfreetype6 >= 2.2.1
libgcc1 >= 1:4.1.1
libgl1 -
libgl1-mesa-glx -
libglew1.10 >= 1.10.0
libglu1 -
libglu1-mesa -
liblua5.1-0 -
libogre-1.8.0 -
libois-1.3.0 -
libpcre3 >= 8.10
libsilly -
libstdc++6 >= 4.4.0
libtinyxml2.6.2 -
libxerces-c3.1 -
libxml2 >= 2.7.4

Conflicts

Name Value
libcegui-mk2-0c2a -

Replaces

Name Value
libcegui-mk2-0c2a -

Download

Type URL
Binary Package libcegui-mk2-0.7.6_0.7.6-3.3_i386.deb
Source Package cegui-mk2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcegui-mk2-0.7.6 deb package:
    # sudo apt-get install libcegui-mk2-0.7.6

Files

Path
/usr/lib/libCEGUIBase-0.7.6.so
/usr/lib/libCEGUIDevILImageCodec-0.7.6.so
/usr/lib/libCEGUIExpatParser-0.7.6.so
/usr/lib/libCEGUIFalagardWRBase-0.7.6.so
/usr/lib/libCEGUIFreeImageImageCodec-0.7.6.so
/usr/lib/libCEGUILibxmlParser-0.7.6.so
/usr/lib/libCEGUILuaScriptModule-0.7.6.so
/usr/lib/libCEGUINullRenderer-0.7.6.so
/usr/lib/libCEGUIOgreRenderer-0.7.6.so
/usr/lib/libCEGUIOpenGLRenderer-0.7.6.so
/usr/lib/libCEGUISILLYImageCodec-0.7.6.so
/usr/lib/libCEGUISTBImageCodec-0.7.6.so
/usr/lib/libCEGUISampleHelper-0.7.6.so
/usr/lib/libCEGUITGAImageCodec-0.7.6.so
/usr/lib/libCEGUITinyXMLParser-0.7.6.so
/usr/lib/libCEGUIXercesParser-0.7.6.so
/usr/share/doc/libcegui-mk2-0.7.6/changelog.Debian.gz
/usr/share/doc/libcegui-mk2-0.7.6/copyright

Changelog

2014-08-03 - Tobias Frost <tobi@debian.org>
cegui-mk2 (0.7.6-3.3) unstable; urgency=medium
* Non-maintainer upload.
* Remove unneeded depdendency on liblcms-dev (Closes: #745530) and libmng-dev
which would also pull-in lcms.
2014-03-03 - Eric Dorland <eric@debian.org>
cegui-mk2 (0.7.6-3.2) unstable; urgency=medium
* Non-maintainer upload.
* debian/control: Switch to automake1.11. (Closes: #724357)
2014-01-11 - Tobias Frost <tobi@coldtobi.de>
cegui-mk2 (0.7.6-3.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix "boost 1.53 is going away" Removing versioned dependencies
(Closes: #731019)
2013-08-14 - Muammar El Khatib <muammar@debian.org>
cegui-mk2 (0.7.6-3) unstable; urgency=low
* Bump Standards-Version to 3.9.4.
* debian/control:
+ OGRE dependency was updated to 1.8. (Closes: #704781)
+ Boost dependency was updated to 1.53.
2012-03-09 - Muammar El Khatib <muammar@debian.org>
cegui-mk2 (0.7.6-2) unstable; urgency=low
* debian/patches:
+ The patch 01_cegui-mk2_kfreebsd.patch has been updated in order to avoid
the FTBFS in kfreebsd caused by d_handle not declared. (Closes: #663152)
+ The patch 09_addingheaderforgcc4.4.patch was renamed to
02_addingheaderforgcc4.4.patch.
+ The patches 11_ftbfs_ptrdiff.patch and 12_CEGUItinyxmlparser.patch were
removed.
2012-03-05 - Muammar El Khatib <muammar@debian.org>
cegui-mk2 (0.7.6-1) unstable; urgency=low
* New upstream release. (Closes: #662074)
* debian/control:
+ Build-Depends updated. Now the library depends on libpng-dev instead of
libpng12-dev. (Closes: #662284)
* Libcegui API documentation contains the CSS files making it show correctly.
(Closes: #661222)
2012-01-19 - Muammar El Khatib <muammar@debian.org>
cegui-mk2 (0.7.5-8) unstable; urgency=low
* In this revision, the embedded tolua++ library has been deleted in order of
making CEGUI explicitly depends on the tolua library in the Debian Archive.
(Closes: #656337). Thanks to Stephen M. Webb for providing a solution.
* debian/control:
+ libtolua++5.1-dev (>= 1.0.93) has been added to the Build-Depends field.
2011-10-13 - Muammar El Khatib <muammar@debian.org>
cegui-mk2 (0.7.5-7) unstable; urgency=low
* Moved to unstable. (Closes: #645109)
2011-08-27 - Muammar El Khatib <muammar@debian.org>
cegui-mk2 (0.7.5-6) experimental; urgency=low
* debian/control: dependencies have been updated to use libxerces-c-dev.
2011-08-25 - Muammar El Khatib <muammar@debian.org>
cegui-mk2 (0.7.5-5) experimental; urgency=low
* The change introduced in previous revision of cegui-mk2 has been reverted
so that CEGUI can Build-Depends on libxml2-dev in kfreebsd. In order to
make it compile with the tinixml parser the 12_CEGUItinyxmlparser patch
has been applied.
* CEGUI was FTBFS because 'DYNLIB_HANDLE' did not name a type in
CEGUIDynamicModule.cpp, this error was fixed by applying again the patch
01_cegui-mk2_kfreebsd.patch. (Closes: #621891)

See Also

Package Description
libcegui-mk2-dev_0.7.6-3.3_i386.deb Crazy Eddie's GUI (development files)
libcegui-mk2-doc_0.7.6-3.3_all.deb Crazy Eddie's GUI (documentation)
libcephfs-dev_0.80.7-2+deb8u2_i386.deb Ceph distributed file system client library (development files)
libcephfs-java_0.80.7-2+deb8u2_all.deb Java library for the Ceph File System
libcephfs-jni_0.80.7-2+deb8u2_i386.deb Java Native Interface library for CephFS Java bindings
libcephfs1_0.80.7-2+deb8u2_i386.deb Ceph distributed file system client library
libcerf-dev_1.3-2_i386.deb Complex error function library - development files
libcerf-doc_1.3-2_all.deb Complex error function library - development files
libcerf1_1.3-2_i386.deb Complex error function library - binary files
libcext-dev_6.5-1_i386.deb Commonly used utility functions for C programs (development files)
libcext-doc_6.5-1_all.deb API documentation for ESO's C utility library libcext
libcext0_6.5-1_i386.deb Commonly used utility functions for C programs
libcf-ocaml-dev_0.10-3+b4_i386.deb OCaml library with miscellaneous utility functions
libcf-ocaml_0.10-3+b4_i386.deb OCaml library with miscellaneous utility functions
libcf0_4.1.3-7.2_i386.deb Interface for scientific data access to large binary data
Advertisement
Advertisement