gir1.2-champlain-0.12_0.12.9-1_i386.deb


Advertisement

Description

gir1.2-champlain-0.12 - C library providing ClutterActor to display maps (GObject introspection)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name gir1.2-champlain-0.12
Package version 0.12.9
Package release 1
Package architecture i386
Package type deb
Installed size 217 B
Download size 150.67 KB
Official Mirror ftp.br.debian.org
Libchamplain is a C library providing a ClutterActor to
display maps.
It supports numerous free map sources such as
OpenStreetMap (default), OpenArialMap and Maps for free.
This package contains the GObject introspection file for libchamplain.

Alternatives

Package Version Architecture Repository
gir1.2-champlain-0.12_0.12.9-1_amd64.deb 0.12.9 amd64 Debian Main
gir1.2-champlain-0.12 - - -

Requires

Name Value
gir1.2-clutter-1.0 -
libchamplain-0.12-0 >= 0.12.7

Download

Type URL
Binary Package gir1.2-champlain-0.12_0.12.9-1_i386.deb
Source Package libchamplain

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-champlain-0.12 deb package:
    # sudo apt-get install gir1.2-champlain-0.12

Files

Path
/usr/lib/girepository-1.0/Champlain-0.12.typelib
/usr/share/doc/gir1.2-champlain-0.12/AUTHORS
/usr/share/doc/gir1.2-champlain-0.12/NEWS.gz
/usr/share/doc/gir1.2-champlain-0.12/README
/usr/share/doc/gir1.2-champlain-0.12/changelog.Debian.gz
/usr/share/doc/gir1.2-champlain-0.12/changelog.gz
/usr/share/doc/gir1.2-champlain-0.12/copyright

Changelog

2014-09-22 - Andreas Henriksson <andreas@fatal.se>
libchamplain (0.12.9-1) unstable; urgency=medium
* New upstream release.
2014-07-03 - Laurent Bigonville <bigon@debian.org>
libchamplain (0.12.8-1) unstable; urgency=medium
[ Laurent Bigonville ]
* debian/control.in: Update Homepage URL
* Drop debian/patches/99_ltmain_as-needed.patch and use dh_autoreconf
--as-needed instead
[ Jackson Doak ]
* New upstream release
* debian/control:
- Replace libsoup-gnome2.4-dev with libsoup2.4-dev
- Replace autotools-dev with dh-autoreconf
* debian/rules: Use autoreconf. Closes: #733200
2014-03-08 - Emilio Pozuelo Monfort <pochu@debian.org>
libchamplain (0.12.7-1) unstable; urgency=medium
[ Andreas Henriksson ]
* New upstream release.
* Add one new symbol to debian/libchamplain-0.12-0.symbols
[ Emilio Pozuelo Monfort ]
* Bump Standards-Version to 3.9.5, no changes needed.
2013-09-21 - Michael Biebl <biebl@debian.org>
libchamplain (0.12.5-1) unstable; urgency=low
* New upstream release.
* Update symbols file for libchamplain-0.12-0.
* The gtk-doc documentation now uses an API-versioned directory. Update the
.doc-base and .install files for libchamplain-doc and libchamplain-gtk
accordingly.
2013-09-01 - Michael Biebl <biebl@debian.org>
libchamplain (0.12.4-1) unstable; urgency=low
[ Laurent Bigonville ]
* New upstream release
- Bump libclutter-1.0-dev build-dependency to >= 1.12
- Adjust debian/libchamplain-0.12-0.symbols: The removed symbols were
either not part of the public API or not used
* debian/control.in:
- Bump Standards-Version to 3.9.4 (no further changes)
- Use canonical URL for Vcs-Svn
- Fix typo in long description (Closes: #700454)
- Add build-dependency so config.{guess,sub} are getting updated during
the build
* debian/rules: Use DEB_LDFLAGS_MAINT_APPEND instead of LDFLAGS to not
override hardening flags
[ Michael Biebl ]
* Drop explicit Build-Depends on gir1.2-gtk-3.0 and gir1.2-clutter-1.0. They
are pulled in automatically by their corresponding -dev package.
* Change Build-Depends on valac-0.20 to valac (>= 0.20).
2013-05-12 - Emilio Pozuelo Monfort <pochu@debian.org>
libchamplain (0.12.3-2) unstable; urgency=low
* debian/control.in:
+ Build against valac-0.20. Fixes FTBFS. Closes: #707378.
2012-08-14 - Laurent Bigonville <bigon@debian.org>
libchamplain (0.12.3-1) unstable; urgency=low
* New upstream release (Closes: #681650)
- fix OSM cycle map source URL
2012-03-29 - Laurent Bigonville <bigon@debian.org>
libchamplain (0.12.2-1) unstable; urgency=low
* New upstream release
* debian/control:
- Bump Standards-Version to 3.9.3 (no further changes)
- Bump valac build-dependency to 0.16 (Closes: #664996)
* debian/patches/99_ltmain_as-needed.patch: Refreshed
2011-12-27 - Laurent Bigonville <bigon@debian.org>
libchamplain (0.12.1-1) unstable; urgency=low
* New upstream release
- Adjust .symbols files
* Drop debian/source/options: Use default compression for debian tarball
2011-12-14 - Laurent Bigonville <bigon@debian.org>
libchamplain (0.12.0-2) unstable; urgency=low
* debian/control.in:
- Build-dep against valac-0.14 instead of valac-0.12, mixing different
versions leads valac to crash (Closes: #650229)
- Move gir package to Section: introspection
* debian/watch: Switch to .xz tarballs

See Also

Package Description
gir1.2-cheese-3.0_3.14.1-2_i386.deb tool to take pictures and videos from your webcam - gir bindings
gir1.2-cinnamondesktop-3.0_2.2.3-3_i386.deb Introspection data for CinnamonDesktop
gir1.2-clinica-0.3_0.3.0-1_i386.deb Simple medical records manager (gobject introspection files)
gir1.2-clutter-1.0_1.20.0-1_i386.deb GObject introspection data for the Clutter 1.0 library
gir1.2-clutter-gst-1.0_1.6.0-2+b2_i386.deb Gobject introspection data for Clutter GStreamer elements
gir1.2-clutter-gst-2.0_2.0.12-1_i386.deb Gobject introspection data for Clutter GStreamer elements
gir1.2-cmenu-3.0_2.2.0-3_i386.deb GObject introspection data for the Cinnamon menu library
gir1.2-cogl-1.0_1.18.2-3_i386.deb GObject introspection data for the Cogl 1.0 library
gir1.2-coglpango-1.0_1.18.2-3_i386.deb GObject introspection data for the CoglPango 1.0 library
gir1.2-colord-1.0_1.2.1-1+b2_i386.deb GObject introspection data for the colord library
gir1.2-colordgtk-1.0_0.1.25-1.1+b1_i386.deb GObject introspection data for the colord-gtk library
gir1.2-colorhug-1.0_1.2.1-1+b2_i386.deb GObject introspection data for the colorhug library
gir1.2-cryptui-0.0_3.12.2-1+b1_i386.deb GObject introspection data for the CryptUI library
gir1.2-dbusmenu-glib-0.4_12.10.2-1_i386.deb typelib file for libdbusmenu-glib4
gir1.2-dbusmenu-gtk-0.4_12.10.2-1_i386.deb typelib file for libdbusmenu-gtk4
Advertisement
Advertisement