geany_1.24.1+dfsg-1_i386.deb


Advertisement

Description

geany - fast and lightweight IDE

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package filename geany_1.24.1+dfsg-1_i386.deb
Package name geany
Package version 1.24.1+dfsg
Package release 1
Package architecture i386
Package type deb
Category devel devel::editor devel::ide implemented-in::c interface::x11 role::program uitoolkit::gtk use::editing works-with::software:source works-with::text works-with::unicode x11::application
Homepage http://www.geany.org
License -
Maintainer Geany Packaging Team <pkg-geany-team@lists.alioth.debian.org>
Download size 1.05 MB
Installed size 2.79 MB
Geany is a small and lightweight integrated development environment.
It was developed to provide a small and fast IDE, which has only a
few dependencies from other packages. It is using only the GTK2 toolkit
and therefore you need only the GTK2 runtime libraries to run Geany.
The basic features of Geany are:
- syntax highlighting
- code completion
- auto completion of constructs like if, for and while, XML and HTML
- call tips
- folding
- many supported filetypes like C, Java, PHP, HTML, Python, Perl, Pascal
- symbol lists
- embedded terminal emulation

Alternatives

Package Version Architecture Repository
geany_1.24.1+dfsg-1_amd64.deb 1.24.1+dfsg amd64 Debian Main
geany - - -

Requires

Name Value
geany-common = 1.24.1+dfsg-1
libatk1.0-0 >= 1.12.4
libc6 >= 2.15
libcairo2 >= 1.6.0
libfontconfig1 >= 2.11
libfreetype6 >= 2.2.1
libgcc1 >= 1:4.1.1
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.37.3
libgtk2.0-0 >= 2.22.0
libpango-1.0-0 >= 1.18.0
libpangocairo-1.0-0 >= 1.14.0
libpangoft2-1.0-0 >= 1.14.0
libstdc++6 >= 4.1.1
multiarch-support -

Provides

Name Value
geany-abi-69 -
geany-api-217 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package geany_1.24.1+dfsg-1_i386.deb
Source Package geany

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install geany deb package:
    # sudo apt-get install geany

Files

Path
/usr/bin/geany
/usr/lib/i386-linux-gnu/geany/classbuilder.so
/usr/lib/i386-linux-gnu/geany/export.so
/usr/lib/i386-linux-gnu/geany/filebrowser.so
/usr/lib/i386-linux-gnu/geany/htmlchars.so
/usr/lib/i386-linux-gnu/geany/saveactions.so
/usr/lib/i386-linux-gnu/geany/splitwindow.so
/usr/lib/i386-linux-gnu/pkgconfig/geany.pc
/usr/share/applications/geany.desktop
/usr/share/doc/geany/NEWS.Debian.gz
/usr/share/doc/geany/NEWS.gz
/usr/share/doc/geany/README
/usr/share/doc/geany/TODO
/usr/share/doc/geany/changelog.Debian.gz
/usr/share/doc/geany/changelog.gz
/usr/share/doc/geany/copyright
/usr/share/man/man1/geany.1.gz
/usr/share/menu/geany
/usr/share/pixmaps/geany.xpm

Changelog

2014-04-19 - Evgeni Golov <evgeni@debian.org>
geany (1.24.1+dfsg-1) unstable; urgency=medium
* [b5fa158] Imported Upstream version 1.24+dfsg
* [e675c2e] Imported Upstream version 1.24.1+dfsg
* [2dcf5a3] refresh 20_add_debian_specific_filetypes.patch against 1.24
* [2c30296] Standards-Version: 3.9.5
* [38a6aaa] add a lintian override for the templates which contain license texts
* [55e5423] add signature check for downloads
2013-05-20 - Chow Loong Jin <hyperair@debian.org>
geany (1.23.1+dfsg-1) unstable; urgency=low
* [3b1ced4] Imported Upstream version 1.23.1+dfsg
* [b418909] Update debian-branch in gbp.conf
2013-05-10 - Chow Loong Jin <hyperair@debian.org>
geany (1.23+dfsg-2) unstable; urgency=low
* Upload to unstable, fixes FTBFS (Closes: #707368)
* [a472a80] Enable parallel builds
* [17a6378] No-change bump of Standards-Version to 3.9.4
* [ea78f31] Add README.source describing git branch structure
2013-03-13 - Evgeni Golov <evgeni@debian.org>
geany (1.23+dfsg-1) experimental; urgency=low
* [eead8ee] Imported Upstream version 1.23+dfsg
* [6d56635] use debian-branch = experimental
* [d555dec] refresh patches against 1.23
2012-06-20 - Chow Loong Jin <hyperair@debian.org>
geany (1.22+dfsg-2) unstable; urgency=low
* [dd3393d] Bump geany-plugins-common breaks version.
0.21 was the version in which the use of geany-abi-$ABI was added to both
packages.
2012-06-19 - Evgeni Golov <evgeni@debian.org>
geany (1.22+dfsg-1) unstable; urgency=low
[ Chow Loong Jin ]
* Import 20_use_x_terminal_emulator.patch from Ubuntu (Closes: #670510)
* Fix dversionmangle in debian/watch
[ Evgeni Golov ]
* use +dfsg instead of .dfsg for the version, thanks lintian
* Imported Upstream version 1.22+dfsg
* drop 20_explicitly_depend_on_gmodule.patch
* refresh patches against 1.22
* Standards-Version: 3.9.3
* Build-Depends: debhelper (>= 9)
2012-04-22 - Evgeni Golov <evgeni@debian.org>
geany (0.21.dfsg-2) unstable; urgency=low
[ Chow Loong Jin ]
* [b70e89e] Fix dversionmangle having two = signs in watch
[ Evgeni Golov ]
* [3cbb120] Explicitly depend on GModule
Closes: #666893
Upstream: https://github.com/geany/geany/commit/7b2f0fe
* [c9724db] drop unused --enable-pipe parameter to configure
2012-01-06 - Chow Loong Jin <hyperair@debian.org>
geany (0.21.dfsg-1) unstable; urgency=low
* [0c978c1] Change my email to debian.org
* [6474558] Imported Upstream version 0.21.dfsg (Closes: #654466)
* [1cbe34d] Add get-orig-source target for dropping waf
* [19fe20d] Add dversionmangle option to watchfile
2011-11-17 - Evgeni Golov <evgeni@debian.org>
geany (0.21-1) unstable; urgency=low
* Imported Upstream version 0.21
* Refresh filetypes patch against 0.21
* Fix Description (thanks lintian!)
* Standards-Version: 3.9.2
* dpatch → 3.0 (quilt)
* Switch to new dh-style debian/rules
* Add a patch to search for plugins in both, multiarch and
non-multiarch folders
* Add misc:Pre-Depends to Pre-Depends for multiarch
* Generate geany:Provides with GEANY_ABI_VERSION and GEANY_API_VERSION
* Split arch independent parts into geany-common
* Set maintainer to pkg-geany
* Set Vcs-* headers for pkg-geany
* Drop README.source, we're using standard 3.0 quilt now
2011-06-18 - Luk Claes <luk@debian.org>
geany (0.20-1.1) unstable; urgency=low
* Non-maintainer upload.
* Don't ship .la files (Closes: #621289).

See Also

Package Description
gearhead-data_1.100-2_all.deb data files for gearhead
gearhead2-data_0.628-1_all.deb data files for gearhead2
gearhead2_0.628-1_i386.deb roguelike mecha role playing game in space
gearhead_1.100-2_i386.deb roguelike mecha role playing game
gearman-job-server_1.0.6-5_i386.deb Job server for the Gearman distributed job queue
gearman-server_1.11-2_all.deb Gearman distributed job server and Perl interface
gearman-tools_1.0.6-5_i386.deb Tools for the Gearman distributed job queue
gearman_1.0.6-5_all.deb Distributed job queue
geary_0.8.2-1_i386.deb lightweight email client designed for the GNOME desktop
gecko-mediaplayer_1.0.9-2_i386.deb Multimedia plug-in for Gecko browsers
geda-doc_1.8.2-4_all.deb GPL EDA -- Electronics design software (documentation)
geda-examples_1.8.2-4_all.deb GPL EDA -- Electronics design software (example designs)
geda-gattrib_1.8.2-4_i386.deb GPL EDA -- Electronics design software (attribute editor)
geda-gnetlist_1.8.2-4_i386.deb GPL EDA -- Electronics design software (netlister)
geda-gschem_1.8.2-4_i386.deb GPL EDA -- Electronics design software (schematic editor)
Advertisement
Advertisement