emacs24_24.4+1-5+deb8u1_i386.deb


Advertisement

Description

emacs24 - GNU Emacs editor (with GTK+ GUI support)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package filename emacs24_24.4+1-5+deb8u1_i386.deb
Package name emacs24
Package version 24.4+1
Package release 5+deb8u1
Package architecture i386
Package type deb
Category editors uitoolkit::gtk
Homepage http://www.gnu.org/software/emacs/
License -
Maintainer Rob Browning <rlb@defaultvalue.org>
Download size 3.09 MB
Installed size 11.64 MB
GNU Emacs is the extensible self-documenting text editor.  This
package contains a version of Emacs with a graphical user interface
based on GTK+ (instead of the Lucid toolkit provided by the
emacs24-lucid package).

Alternatives

Package Version Architecture Repository
emacs24_24.4+1-5+deb8u1_amd64.deb 24.4+1 amd64 Debian Main
emacs24 - - -

Requires

Name Value
emacs24-bin-common = 24.4+1-5+deb8u1
gconf-service -
libacl1 >= 2.2.51-8
libasound2 >= 1.0.16
libatk1.0-0 >= 1.12.4
libc6 >= 2.16
libcairo-gobject2 >= 1.10.0
libcairo2 >= 1.2.4
libdbus-1-3 >= 1.5.12
libfontconfig1 >= 2.11
libfreetype6 >= 2.2.1
libgconf-2-4 >= 3.2.5
libgdk-pixbuf2.0-0 >= 2.22.0
libgif4 >= 4.1.4
libglib2.0-0 >= 2.37.3
libgnutls-deb0-28 >= 3.3.0
libgomp1 >= 4.2.1
libgpm2 >= 1.20.4
libgtk-3-0 >= 3.3.16
libice6 >= 1:1.0.0
libjpeg62-turbo >= 1.3.1
libm17n-0 >= 1.6.1
libmagickcore-6.q16-2 >= 8:6.8.8.2
libmagickwand-6.q16-2 >= 8:6.8.8.2
libotf0 >= 0.9.11
libpango-1.0-0 >= 1.18.0
libpangocairo-1.0-0 >= 1.14.0
libpng12-0 >= 1.2.13-4
librsvg2-2 >= 2.14.4
libselinux1 >= 1.32
libsm6 -
libtiff5 >= 4.0.3
libtinfo5 -
libx11-6 -
libxft2 >> 2.1.1
libxinerama1 -
libxml2 >= 2.7.4
libxpm4 -
libxrandr2 -
libxrender1 -
zlib1g >= 1:1.1.4

Provides

Name Value
editor -
emacsen -
info-browser -
mail-reader -
news-reader -

Conflicts

Name Value
emacs24-lucid -
emacs24-nox -

Replaces

Name Value
emacs24-lucid -
emacs24-nox -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package emacs24_24.4+1-5+deb8u1_i386.deb
Source Package emacs24

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install emacs24 deb package:
    # sudo apt-get install emacs24

Files

Path
/usr/bin/emacs24
/usr/bin/emacs24-x
/usr/share/applications/emacs24.desktop
/usr/share/doc/emacs24/README.Debian
/usr/share/doc/emacs24/changelog.Debian.gz
/usr/share/doc/emacs24/changelog.gz
/usr/share/doc/emacs24/copyright
/usr/share/emacs/24.4/etc/DOC
/usr/share/lintian/overrides/emacs24
/usr/share/man/man1/emacs24-x.1.gz
/usr/share/man/man1/emacs24.1.gz
/usr/share/menu/emacs24

Changelog

2017-09-12 - Moritz Muehlenhoff <jmm@debian.org>
emacs24 (24.4+1-5+deb8u1) jessie-security; urgency=medium
* Remove unsafe enriched mode translations
2015-03-07 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.4+1-5) unstable; urgency=medium
* emacs24-common: conflict with obsolete gnus-bonus-el package.
Thanks to Hilko Bengen for reporting the problem. (Closes: 767949)
* Add "Breaks: apel (<< 10.8+0.20120427-4)" to emacs24-common to fix
a byte-compilation problem with older versions of the package.
Thanks to Łukasz Stelmach for the report and Sébastien Villemot
for tracking down the correct version. (Closes: 775564)
2014-12-09 - Balint Reczey <balint@balintreczey.hu>
emacs24 (24.4+1-4.1) unstable; urgency=medium
* Non-maintainer upload.
* Cherry-pick 0009-lisp-startup.el-command-line.patch to fix handling
nil elements in load-path (Closes: #768751)
2014-10-25 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.4+1-4) unstable; urgency=medium
* Update emacsen-common dependency as per policy.
2014-10-23 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.4+1-3) experimental; urgency=medium
* Eliminate a race to create info/ during the build.  Add
0008-A-race-to-create-info-has-been-eliminated.patch with the
relevant changes.  Thanks to Paul Eggert <eggert@cs.ucla.edu> for
tracking down the problem and providing the fix.
2014-10-22 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.4+1-2) experimental; urgency=medium
* Adjust update_autogen and make-info-dir for DFSG removals.
Change 0003-Remove-files-that-appear-to-be-incompatible-with-the.patch
accordingly.
2014-10-21 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.4+1-1) experimental; urgency=medium
* Merge upstream version 24.4.
Remove (unneeded) src/macuvs.h and admin/unidata/IVD_Sequences.txt
until we're sure about the license:
https://lists.gnu.org/archive/html/emacs-devel/2014-10/msg00742.html
Remove new GFDL files (moved to emacs24-common-non-dfsg):
doc/misc/eww.texi
doc/misc/ido.texi
doc/misc/octave-mode.texi
doc/misc/todo-mode.texi
Remove redundant patches:
0007-Invoke-the-correct-xmlstarlet-executable-on-Debian-s.patch
0008-Emacs-should-no-longer-hang-at-startup-on-kFreeBSD.patch
0009-Emacs-should-no-longer-hang-at-startup-on-kFreeBSD.patch
0010-Emacs-should-now-build-correctly-on-GNU-Hurd.patch
0011-Gnus-should-no-longer-use-a-predictable-temp-file-na.patch
0012-Security-issues-in-find-gc.el-have-been-fixed-CVE-20.patch
0013-Security-issues-in-tramp-have-been-fixed-CVE-2014-34.patch
0014-Insecure-file-handling-in-browse-url-mosaic-has-been.patch
0015-The-compose-key-should-now-work-better-with-UIM-1-4.patch
0016-The-compose-key-should-now-work-better-with-UIM-2-4.patch
0017-The-compose-key-should-now-work-better-with-UIM-3-4.patch
0018-The-compose-key-should-now-work-better-with-UIM-4-4.patch
0019-fill-region-as-paragraph-should-better-respect-the-f.patch
0020-Emacs-should-now-follow-Make-4.0-directory-changes.patch
* Update debian/copyright* for 24.4.  Update entry for man/faq.texi
(now doc/mis/efaq.texi); add entries for doc/misc/efaq-w32.texi,
lisp/obsolete/meese.el, msdos/sedadmin.inp, nt/inc/dirent.h, and
all of the files in m4/ except gnulib-comp.m4.
* Ignore src/macuvs.h and IVD_Sequences.txt for now.  Add
0007-Don-t-try-to-build-src-macuvs.h-via-IVD_Sequences.tx.patch to
avoid trying to build src/macuvs.h (via IVD_Sequences.txt) since
we removed it for the time being, due to uncertainty over the
licensing.
* Build depend on libacl1-dev for new ACL support
* Build depend on zlib1g-dev for new zlib support
* Remove obsolete configure argument --with-crt-dir
* Look for DOC, not DOC-$(runtime_ver) in debian/rules.  The DOC
file is now just DOC.
* Don't try to remove /usr/local in debian/rules.  It's not created
during the build anymore.

See Also

Package Description
emacs_46.1_all.deb GNU Emacs editor (metapackage)
emacsen-common_2.0.8_all.deb Common facilities for all emacsen
emacspeak-espeak-server_40.0+dfsg-3_i386.deb espeak syntesis server for emacspeak
emacspeak-ss_1.12.1-4_i386.deb Emacspeak speech servers for several synthesizers
emacspeak_40.0+dfsg-3_all.deb speech output interface to Emacs
email-reminder_0.7.8-2_all.deb Send event reminders by email
embassy-domainatrix_0.1.650-1_i386.deb Extra EMBOSS commands to handle domain classification file
embassy-domalign_0.1.650-1_i386.deb Extra EMBOSS commands for protein domain alignment
embassy-domsearch_0.1.650-1_i386.deb Extra EMBOSS commands to search for protein domains
ember-media_0.7.0-1_all.deb 3D client framework for the WorldForge project -- media files
ember_0.6.2+dfsg-2.1_i386.deb 3D client framework for the WorldForge project
emboss-data_6.6.0+dfsg-1_all.deb data files for the EMBOSS package
emboss-doc_6.6.0+dfsg-1_all.deb documentation for EMBOSS
emboss-explorer_2.2.0-8_all.deb web-based GUI to EMBOSS
emboss-lib_6.6.0+dfsg-1_i386.deb EMBOSS Libraries
Advertisement
Advertisement