whiff_0.005-1_all.deb


Advertisement

Description

whiff - helper to find the first executable of a series of alternatives

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name whiff
Package version 0.005
Package release 1
Package architecture all
Package type deb
Installed size 59 B
Download size 9.04 KB
Official Mirror ftp.br.debian.org
whiff command, which takes a number of command names and returns the first one
that exists and is executable.
It assumes that all the arguments form a best-first list of
alternatives, and only prints the path to the first alternative found in
the path. If none is found, it prints an error (to stderr) and exits
with an error code.
A programmer interface is available in the App::Whiff module.

Alternatives

Package Version Architecture Repository
whiff_0.005-1_all.deb 0.005 all Debian Main
whiff - - -

Requires

Name Value
libfile-which-perl -
perl -

Download

Type URL
Binary Package whiff_0.005-1_all.deb
Source Package whiff

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install whiff deb package:
    # sudo apt-get install whiff

Files

Path
/usr/bin/whiff
/usr/share/doc/whiff/changelog.Debian.gz
/usr/share/doc/whiff/changelog.gz
/usr/share/doc/whiff/copyright
/usr/share/man/man1/whiff.1p.gz
/usr/share/man/man3/App::Whiff.3pm.gz
/usr/share/perl5/App/Whiff.pm

Changelog

2014-05-29 - gregor herrmann <gregoa@debian.org>
whiff (0.005-1) unstable; urgency=low
* Team upload.
* New upstream release.
* Strip trailing slash from metacpan URLs.
* Declare compliance with Debian Policy 3.9.5.
2013-08-26 - Florian Schlichting <fsfs@debian.org>
whiff (0.003-1) unstable; urgency=low
[ Damyan Ivanov ]
* New Upstream Version 0.002
* move VCS-* from apps/ to packages/
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
* debian/watch: update to ignore development releases.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Florian Schlichting ]
* Import Upstream version 0.003
* Remove copyright paragraph for Module::Install, which was dropped
* Add build-dependency on Test::More 0.96
* Bump Standards-Version to 3.9.4 (update to copyright-format 1.0, directly
link GPL-1)
* Bump dh compatibility to level 8 (no changes necessary)
* Switch to source format 3.0 (quilt)
* Switch to short-form debian/rules
* Update Vcs-* fields to their canonical value
* Add myself to uploaders and copyright
2009-01-12 - Brian Cassidy <brian.cassidy@gmail.com>
whiff (0.001-1) unstable; urgency=low
* Initial Release. (Closes: #511225)

See Also

Package Description
whiptail_0.52.17-1+b1_amd64.deb Displays user-friendly dialog boxes from shell scripts
whiteboard_0.1~1-1_all.deb simple collaborative text editor for the web
whitedb_0.7.2-1_amd64.deb lightweight NoSQL database library
whitedune-docs_0.30.10-1.3_all.deb documentation for whitedune
whitedune_0.30.10-1.3+b2_amd64.deb graphical VRML97/X3D viewer, editor, 3D modeller and animation tool
whizzytex_1.3.2-1.3_all.deb a WYSIWYG emacs environment for LaTeX
whohas_0.29-0.3_all.deb query multiple distributions' package archives
whois_5.2.7_amd64.deb intelligent WHOIS client
whowatch_1.8.5-1_amd64.deb Real-time user logins monitoring tool
why-examples_2.34-2_all.deb Examples of programs certified with Why
why_2.34-2_amd64.deb Software verification tool
whysynth_20090403-1.2_amd64.deb DSSI Soft Synth Interface
whyteboard_0.41.1-5_all.deb overlay painting and annotation application
wicd-cli_1.7.2.4-4.1_all.deb wired and wireless network manager - scriptable console client
wicd-curses_1.7.2.4-4.1_all.deb wired and wireless network manager - Curses client
Advertisement
Advertisement