spyder_2.3.1+dfsg-1_all.deb


Advertisement

Description

spyder - Python IDE for scientists (Python 2)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package filename spyder_2.3.1+dfsg-1_all.deb
Package name spyder
Package version 2.3.1+dfsg
Package release 1
Package architecture all
Package type deb
Category devel devel::ide devel::lang:python implemented-in::python role::program
Homepage https://bitbucket.org/spyder-ide/spyderlib
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 54.92 KB
Installed size 153.00 KB
Spyder (previously known as Pydee) is a free open-source Python
development environment providing MATLAB-like features in a simple
and light-weighted software
This is the Python 2 version of the package.

Alternatives

Package Version Architecture Repository
spyder_2.3.1+dfsg-1_all.deb 2.3.1+dfsg all Debian Main
spyder_2.2.5+dfsg-1~nd80+1_all.deb 2.2.5+dfsg all NeuroDebian Main
spyder_2.2.5+dfsg-1~nd80+1_all.deb 2.2.5+dfsg all NeuroDebian Main
spyder - - -

Requires

Name Value
python -
python-spyderlib = 2.3.1+dfsg-1
python:any >= 2.7~

Replaces

Name Value
python-spyderlib << 2.3.0+dfsg-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package spyder_2.3.1+dfsg-1_all.deb
Source Package spyder

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install spyder deb package:
    # sudo apt-get install spyder

Files

Path
/usr/bin/spyder
/usr/share/applications/spyder.desktop
/usr/share/bug/spyder/control
/usr/share/doc/spyder/README.md.gz
/usr/share/doc/spyder/changelog.Debian.gz
/usr/share/doc/spyder/changelog.gz
/usr/share/doc/spyder/copyright
/usr/share/doc/spyder/html
/usr/share/man/man1/spyder.1.gz
/usr/share/menu/spyder
/usr/share/pixmaps/spyder.png

Changelog

2014-10-19 - Ghislain Antony Vaillant <ghisvail@gmail.com>
spyder (2.3.1+dfsg-1) unstable; urgency=medium
* Team upload
[Ghislain Antony Vaillant]
* New upstream release. (Closes: #765963)
* Bump Standards-Version to 3.9.6 (no changes required).
* d/control: fix pedantic lintian warning regarding capitalization in
packages' description.
[Picca Frédéric-Emmanuel]
* Update the homepage now that upstream moved to bitbucket.
* debian/copyright
- updated for 2.3.1 version
* debian/control
+ Recommends: python-pandas and python3-pandas
2014-08-30 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (2.3.0+dfsg-4) unstable; urgency=medium
* fix the upgrade of python-spyderlib-doc (LP: #1357951, #1358055)
2014-08-01 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (2.3.0+dfsg-3) unstable; urgency=medium
* fix Breakes -> Breaks (Closes: #756803)
2014-07-22 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (2.3.0+dfsg-2) unstable; urgency=low
* move the pixmaps from the python-spyderlib to the spyder packages.
2014-07-18 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (2.3.0+dfsg-1) unstable; urgency=medium
* Imported Upstream version 2.3.0+dfsg
2014-05-29 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (2.3.0~rc+dfsg-1~experimental2) experimental; urgency=low
* Add spyder-common binary package for all the python2,3 common files
* debian/path
- 0001-fix-documentation-installation.patch (deleted)
+ 0001-fix-spyderlib-path.patch (new)
2014-05-29 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (2.3.0~rc+dfsg-1~experimental1) experimental; urgency=low
* Imported Upstream version 2.3.0~rc+dfsg
* Add python-spyderlib-doc, spyder3 and python3-spyderlib binary packages
* Bump Standards-Version to 3.9.5 (no changes required)
* Use compat level 9
* Updated URLS since upstream code moved from google code to bitbucket
* Recommends python-jedi and pyton3-jedi to allow jedi plugging
2013-10-19 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (2.2.5+dfsg-1) unstable; urgency=low
* fix the copyright file with more upstream information
* Imported Upstream version 2.2.5+dfsg
2013-09-06 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (2.2.4+dfsg-1) unstable; urgency=low
* Imported Upstream version 2.2.4+dfsg
* relax ipython dependency now that spyder support 0.13 and 1.0
2013-08-21 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (2.2.3+dfsg-1) unstable; urgency=low
* Imported Upstream version 2.2.3+dfsg
* debian/copyright updated

See Also

Package Description
spykeviewer_0.4.2-1_all.deb graphical utility for analyzing electrophysiological data
sqitch_0.996-1_all.deb Sane database change management
sql-ledger_3.0.6-2_all.deb Web based double-entry accounting program
sqlformat_0.1.13-2_all.deb SQL formatting utility
sqlgrey_1.8.0-1_all.deb Postfix Greylisting Policy Server
sqlite-doc_2.8.17-12_all.deb SQLite documentation
sqlite3-doc_3.8.7.1-1+deb8u2_all.deb SQLite 3 documentation
sqlite3_3.8.7.1-1+deb8u2_amd64.deb Command line interface for SQLite 3
sqlite_2.8.17-12_amd64.deb command line interface for SQLite
sqlitebrowser_3.2.0-1_amd64.deb GUI editor for SQLite databases
sqlline_1.0.2-5_all.deb JDBC command-line utility for issuing SQL
sqsh_2.1.7-4_amd64.deb commandline SQL client for MS SQL and Sybase servers
squareness_2.3.0-6_all.deb suite of skins for different applications
squashfs-tools_4.2+20130409-2_amd64.deb Tool to create and append to squashfs filesystems
squeak-plugins-scratch_1.4.0.2~svn.r83-2_amd64.deb Squeak plugins for the Scratch programming environment
Advertisement
Advertisement