ruby-maruku_0.7.1-1_all.deb


Advertisement

Description

ruby-maruku - Markdown-superset interpreter written in Ruby

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name ruby-maruku
Package version 0.7.1
Package release 1
Package architecture all
Package type deb
Installed size 335 B
Download size 63.68 KB
Official Mirror ftp.br.debian.org
Maruku implements a superset of the Markdown language, designed to
easily create HTML documents while only focusing on the high-level
structure and not the details. Maruku also supports LaTeX export,
which means you can produce PDF output.
Maruku prides itself of being decently fast on long documents.

Alternatives

Package Version Architecture Repository
ruby-maruku_0.7.1-1_all.deb 0.7.1 all Debian Main
ruby-maruku - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-nokogiri -

Download

Type URL
Binary Package ruby-maruku_0.7.1-1_all.deb
Source Package ruby-maruku

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-maruku deb package:
    # sudo apt-get install ruby-maruku

Files

Path
/usr/bin/maruku
/usr/bin/marutex
/usr/lib/ruby/vendor_ruby/maruku.rb
/usr/lib/ruby/vendor_ruby/maruku/attributes.rb
/usr/lib/ruby/vendor_ruby/maruku/defaults.rb
/usr/lib/ruby/vendor_ruby/maruku/document.rb
/usr/lib/ruby/vendor_ruby/maruku/element.rb
/usr/lib/ruby/vendor_ruby/maruku/errors.rb
/usr/lib/ruby/vendor_ruby/maruku/helpers.rb
/usr/lib/ruby/vendor_ruby/maruku/html.rb
/usr/lib/ruby/vendor_ruby/maruku/inspect_element.rb
/usr/lib/ruby/vendor_ruby/maruku/maruku.rb
/usr/lib/ruby/vendor_ruby/maruku/string_utils.rb
/usr/lib/ruby/vendor_ruby/maruku/textile2.rb
/usr/lib/ruby/vendor_ruby/maruku/toc.rb
/usr/lib/ruby/vendor_ruby/maruku/version.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/div.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/fenced_code.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/math.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/math/elements.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/math/parsing.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/math/to_html.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/math/to_latex.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/math/mathml_engines/blahtex.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/math/mathml_engines/itex2mml.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/math/mathml_engines/none.rb
/usr/lib/ruby/vendor_ruby/maruku/ext/math/mathml_engines/ritex.rb
/usr/lib/ruby/vendor_ruby/maruku/input/charsource.rb
/usr/lib/ruby/vendor_ruby/maruku/input/extensions.rb
/usr/lib/ruby/vendor_ruby/maruku/input/html_helper.rb
/usr/lib/ruby/vendor_ruby/maruku/input/linesource.rb
/usr/lib/ruby/vendor_ruby/maruku/input/mdline.rb
/usr/lib/ruby/vendor_ruby/maruku/input/parse_block.rb
/usr/lib/ruby/vendor_ruby/maruku/input/parse_doc.rb
/usr/lib/ruby/vendor_ruby/maruku/input/parse_span.rb
/usr/lib/ruby/vendor_ruby/maruku/input/rubypants.rb
/usr/lib/ruby/vendor_ruby/maruku/input_textile2/t2_parser.rb
/usr/lib/ruby/vendor_ruby/maruku/output/entity_table.rb
/usr/lib/ruby/vendor_ruby/maruku/output/to_html.rb
/usr/lib/ruby/vendor_ruby/maruku/output/to_latex.rb
/usr/lib/ruby/vendor_ruby/maruku/output/to_markdown.rb
/usr/lib/ruby/vendor_ruby/maruku/output/to_s.rb
/usr/lib/ruby/vendor_ruby/maruku/output/s5/fancy.rb
/usr/lib/ruby/vendor_ruby/maruku/output/s5/to_s5.rb
/usr/share/doc/ruby-maruku/README.Debian
/usr/share/doc/ruby-maruku/changelog.Debian.gz
/usr/share/doc/ruby-maruku/copyright
/usr/share/man/man1/maruku.1.gz
/usr/share/man/man1/marutex.1.gz
/usr/share/ruby-maruku/entities.xml
/usr/share/rubygems-integration/all/specifications/maruku-0.7.1.gemspec

Changelog

2014-02-21 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-maruku (0.7.1-1) unstable; urgency=low
* Team upload.
[ C├ędric Boutillier ]
* debian/control:
- remove obsolete DM-Upload-Allowed flag
- use canonical URI in Vcs-* fields
[ Jonas Genannt ]
* Imported Upstream version 0.7.1
* d/control:
- removed transitional packages (Closes: #735704)
- bumped standards version to 3.9.5 (no changes needed)
- added ruby-nokogiri as depend
- updated build-deps for running tests on build time
- removed unneeded dot in description
* d/rules: marutest and marudown no longer included by upstream
* d/copyright: updated to copyright format 1.0
* d/README.Debian: update package name, update README
* install xml file; added patch to fix path to xml in Debian
* d/ruby-tests.rake: added buildtime tests. exclude block_spec.rb
since nokogiri/diff is not available in Debian yet
2012-06-24 - Vincent Fourmond <fourmond@debian.org>
ruby-maruku (0.6.0-2) unstable; urgency=low
* Force a rebuild with newer gem2deb
* Conforms to standards 3.9.3
* Move transitional packages to Priority: extra
2011-06-06 - Vincent Fourmond <fourmond@debian.org>
ruby-maruku (0.6.0-1) unstable; urgency=low
* New upstream release, now based on the gem file
* Switch to gem2deb + debhelper
* Rename source and binary packages according to the Ruby policy and
provide transition packages
2008-04-04 - Vincent Fourmond <fourmond@debian.org>
libmaruku-ruby (0.5.8-1) unstable; urgency=low
* New upstream release
* Bumped to Standards version 3.7.3 (no changes needed)
* Removed unecessary debian/dirs, so now we are lintian-clean
2007-10-22 - Vincent Fourmond <fourmond@debian.org>
libmaruku-ruby (0.5.7-1) unstable; urgency=high
* New upstream release (Closes: #447605)
* Urgency high as it fixes a grave bug in testing
2007-07-10 - Vincent Fourmond <fourmond@debian.org>
libmaruku-ruby (0.5.6-2) unstable; urgency=low
* Uploading to unstable
2007-05-27 - Vincent Fourmond <fourmond@debian.org>
libmaruku-ruby (0.5.6-1) experimental; urgency=low
* Initial release (Closes: #426162)
* Added a manpage for maruku and marutex
* Added a linda override for the example changelog.md
* Uploading to experimental.
* Add 01-fix-shebang to fix shebangs of executables

See Also

Package Description
ruby-mathml_0.14-2_all.deb TeX formula to MathML conversion library for Ruby
ruby-mecab_0.99.6-2+b2_amd64.deb mecab binding for Ruby language
ruby-mechanize_2.7.2-2_all.deb library used for automating interaction with websites
ruby-memcache-client_1.8.5-3_all.deb Ruby client library for memcached
ruby-memoizable_0.4.2-1_all.deb memoize method return values
ruby-memoize_1.3.1-3_all.deb Ruby library providing speed up methods at the cost of memory (or disk space)
ruby-merb-assets_1.1.3-2_all.deb Plugin library for Merb that provides helpers for assets
ruby-merb-core_1.1.3+dfsg-2_all.deb Core libraries for the Merb MVC framework
ruby-merb-haml_1.1.3-3_all.deb Plugin library for Merb that provides access to ruby-haml
ruby-merb-helpers_1.1.3-1_all.deb Plugin library for Merb that provides view helpers
ruby-merb-param-protection_1.1.3-2_all.deb Merb plugin with controller methods to filter parameters
ruby-mercenary_0.3.4-1_all.deb Lightweight and flexible library for writing command-line apps in Ruby
ruby-messagebus-api_3.0.7+git.20130130.97b34ece-1_all.deb Send email through the Message Bus service
ruby-metaclass_0.0.4-1_all.deb Ruby library adding a metaclass method to all Ruby objects
ruby-metaid_1.0-8_all.deb Some additional methods to make metaprogramming easier
Advertisement
Advertisement