qalc_0.9.7-9_amd64.deb


Advertisement

Description

qalc - Powerful and easy to use command line calculator

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name qalc
Package version 0.9.7
Package release 9
Package architecture amd64
Package type deb
Installed size 261 B
Download size 108.60 KB
Official Mirror ftp.br.debian.org
Qalculate! is small and simple to use but with much power and versatility
underneath.  Features include customizable functions, units, arbitrary
precision using a one-line fault-tolerant expression entry.
This package contains the command line version of Qalculate!.

Alternatives

Package Version Architecture Repository
qalc_0.9.7-9_i386.deb 0.9.7 i386 Debian Main
qalc - - -

Requires

Name Value
libc6 >= 2.4
libcln6 -
libgcc1 >= 1:4.1.1
libglib2.0-0 >= 2.12.0
libncurses5 >= 5.5-5~
libqalculate5 -
libreadline6 >= 6.0
libstdc++6 >= 4.1.1
libtinfo5 -
libxml2 >= 2.6.27

Download

Type URL
Binary Package qalc_0.9.7-9_amd64.deb
Source Package libqalculate

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install qalc deb package:
    # sudo apt-get install qalc

Files

Path
/usr/bin/qalc
/usr/share/doc/qalc/changelog.Debian.gz
/usr/share/doc/qalc/changelog.gz
/usr/share/doc/qalc/copyright
/usr/share/man/man1/qalc.1.gz

Changelog

2013-05-18 - Vincent Legout <vlegout@debian.org>
libqalculate (0.9.7-9) unstable; urgency=low
* Standards-Version 3.9.4, no changes needed
* Use dh-autoreconf to run autoreconf at build-time, fix FTBFS on x32.
Thanks to Daniel Schepler for the patch (#700685)
2012-06-17 - Vincent Legout <vlegout@debian.org>
libqalculate (0.9.7-8) unstable; urgency=low
* Mark libqalculate5-data Multi-arch:foreign
* libqalculate5: Move libqalculate5-data from Recommends to Depends
(Closes: #677308)
2012-04-28 - Vincent Legout <vlegout@debian.org>
libqalculate (0.9.7-7) unstable; urgency=low
* New arch:all binary package libqalculate5-data.
* Add debian/libqalculate5-data.install, move architecture-independent files
from libqalculate5 to libqalculate5-data. (Closes: #670026)
* libqalculate5-data Breaks and Replaces libqalculate5 (<< 0.9.7-7).
* Do not make libqalculate5-data Multi-arch: foreign. Thus libqalculate5 can
only recommend libqalculate5-data.
* Standards-Version 3.9.3.
* debhelper 9 has been released, update Build-Depends.
2011-12-03 - Vincent Legout <vlegout@debian.org>
libqalculate (0.9.7-6) unstable; urgency=low
* debian/control:
- Update Standards-Version to 3.9.2 (No changes needed)
- Use my debian.org email address
- Remove the DM-Upload-Allowed field
* Convert to multiarch:
- Bump debhelper compat to 9
- Update libqalculate5.install and libqalculate-dev.install to use
/usr/lib/*/ instead of /usr/lib/
- libqalculate5: Add Multi-Arch: same and Pre-Depends: ${misc:Pre-Depends}
- libqalculate-dev: Set Multi-Arch: same
2011-03-25 - Vincent Legout <vincent@legout.info>
libqalculate (0.9.7-5) unstable; urgency=low
* Update to debhelper 8 (debian/compat, debian/control)
* Build-depend on libgmp-dev instead of libgmp3-dev
* Add DM-Upload-Allowed field
2010-09-19 - Vincent Legout <vincent@legout.info>
libqalculate (0.9.7-4) unstable; urgency=low
* Update Breaks and Replace fields for libqalculate5. (Closes: #597377)
2010-07-29 - Vincent Legout <vincent@legout.info>
libqalculate (0.9.7-3) unstable; urgency=low
* debian/patches/fr-po.patch: Added. Fix french translation
(Closes: #590739, #472560, #528491)
* debian/control:
- Update Standards-Version to 3.9.1
- Fix conflicts-with-version lintian warning. Use Breaks instead of
Conflicts and set that libqalculate5 replaces qalc << 0.8
2010-06-25 - Vincent Legout <vincent@legout.info>
libqalculate (0.9.7-2) unstable; urgency=low
* debian/control:
- Add Depends on libxml2-dev for libqalculate-dev (Closes: #571155)
- Update Standards-Version to 3.8.4
* Move /usr/share/qalculate/*.xml and /usr/share/locale/* to libqalculate5
binary package (Closes: 583267)
* debian/patches/spell-fixes.patch: Fix spelling mistakes in the currencies.
Thanks to Jonathan Riddell (Closes: 583266)
* debian/patches/units-fixes.patch: Fix spelling mistakes in the units.
(Closes: #452492)
* Add debian/clean and remove the override_dh_auto_clean target in
debian/rules
2010-01-24 - Vincent Legout <vincent@legout.info>
libqalculate (0.9.7-1) unstable; urgency=low
* New upstream version: (Closes: #520699)
- Remove 01_cln and 02_gcc43 patches, merged upstream
* debian/rules: No need to run autoconf anymore
* debian/control:
- Remove Build-Depends on intltool and autoconf
- Add Build-Depends on libxml-parser-perl
* debian/libqalculate-doc.doc-base: Fix typo
* Soname change to libqalculate5:
- debian/control: Rename libqalculate4 to libqalculate5
- debian/control: libqalculate-dev depends on libqalculate5
- Rename libqalculate4.install to libqalculate5.install
* Switch to 3.0 (quilt) source format

See Also

Package Description
qalculate-gtk_0.9.7-6_amd64.deb Powerful and easy to use desktop calculator - GTK+ version
qalculate_0.9.7-6_all.deb Powerful and easy to use desktop calculator - transitional
qapt-batch_1.3.0-2.1_amd64.deb Batch package manager for KDE
qapt-deb-installer_1.3.0-2.1_amd64.deb tool for installing deb files
qapt-utils_1.3.0-2.1_amd64.deb complete collection of QApt package management utilities
qasconfig_0.18.0-1_amd64.deb ALSA configuration browser
qashctl_0.18.0-1_amd64.deb mixer for ALSA's High level Control Interface
qasmixer_0.18.0-1_amd64.deb ALSA mixer for the desktop
qastools-common_0.18.0-1_all.deb QasTools common files
qbittorrent-nox_3.1.10-1_amd64.deb bittorrent client based on libtorrent-rasterbar (without X support)
qbittorrent_3.1.10-1_amd64.deb bittorrent client based on libtorrent-rasterbar with a Qt4 GUI
qbrew_0.4.1-3_amd64.deb Homebrewer's recipe calculator
qbzr_0.23.1-1_all.deb Graphical interface for Bazaar using the Qt toolkit
qca2-utils_2.0.3-6_amd64.deb command line tool for the Qt Cryptographic Architecture
qcomicbook_0.8.2-1+b1_amd64.deb qt viewer for comic book archives (cbr/cbz/cba/cbg/cbb)
Advertisement
Advertisement