python3-mako_1.0.0+dfsg-0.1_all.deb


Advertisement

Description

python3-mako - fast and lightweight templating for the Python 3 platform

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name python3-mako
Package version 1.0.0+dfsg
Package release 0.1
Package architecture all
Package type deb
Installed size 272 B
Download size 58.32 KB
Official Mirror ftp.br.debian.org
Mako is a template library written in Python. It provides a familiar, non-XML
syntax which compiles into Python modules for maximum performance. Mako's
syntax and API borrows from the best ideas of many others, including Django
templates, Cheetah, Myghty, and Genshi. Conceptually, Mako is an embedded
Python (i.e. Python Server Page) language, which refines the familiar ideas of
componentized layout and inheritance to produce one of the most
straightforward and flexible models available, while also maintaining close
ties to Python calling and scoping semantics.

Alternatives

Package Version Architecture Repository
python3-mako_1.0.0+dfsg-0.1_all.deb 1.0.0+dfsg all Debian Main
python3-mako - - -

Requires

Name Value
python3-markupsafe -
python3:any >= 3.3.2-2~

Download

Type URL
Binary Package python3-mako_1.0.0+dfsg-0.1_all.deb
Source Package mako

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-mako deb package:
    # sudo apt-get install python3-mako

Files

Path
/usr/lib/python3/dist-packages/Mako-1.0.0.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/Mako-1.0.0.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/Mako-1.0.0.egg-info/entry_points.txt
/usr/lib/python3/dist-packages/Mako-1.0.0.egg-info/not-zip-safe
/usr/lib/python3/dist-packages/Mako-1.0.0.egg-info/requires.txt
/usr/lib/python3/dist-packages/Mako-1.0.0.egg-info/top_level.txt
/usr/lib/python3/dist-packages/mako/__init__.py
/usr/lib/python3/dist-packages/mako/_ast_util.py
/usr/lib/python3/dist-packages/mako/ast.py
/usr/lib/python3/dist-packages/mako/cache.py
/usr/lib/python3/dist-packages/mako/cmd.py
/usr/lib/python3/dist-packages/mako/codegen.py
/usr/lib/python3/dist-packages/mako/compat.py
/usr/lib/python3/dist-packages/mako/exceptions.py
/usr/lib/python3/dist-packages/mako/filters.py
/usr/lib/python3/dist-packages/mako/lexer.py
/usr/lib/python3/dist-packages/mako/lookup.py
/usr/lib/python3/dist-packages/mako/parsetree.py
/usr/lib/python3/dist-packages/mako/pygen.py
/usr/lib/python3/dist-packages/mako/pyparser.py
/usr/lib/python3/dist-packages/mako/runtime.py
/usr/lib/python3/dist-packages/mako/template.py
/usr/lib/python3/dist-packages/mako/util.py
/usr/lib/python3/dist-packages/mako/ext/__init__.py
/usr/lib/python3/dist-packages/mako/ext/autohandler.py
/usr/lib/python3/dist-packages/mako/ext/babelplugin.py
/usr/lib/python3/dist-packages/mako/ext/beaker_cache.py
/usr/lib/python3/dist-packages/mako/ext/preprocessors.py
/usr/lib/python3/dist-packages/mako/ext/pygmentplugin.py
/usr/lib/python3/dist-packages/mako/ext/turbogears.py
/usr/share/doc/python3-mako/changelog.Debian.gz
/usr/share/doc/python3-mako/copyright
/usr/share/python3/dist/python3-mako

Changelog

2014-11-11 - Ivo De Decker <ivodd@debian.org>
mako (1.0.0+dfsg-0.1) unstable; urgency=medium
* Non-maintainer upload.
* Remove minified javascript files from upstream source. They are not used
in the build process. Closes: #722265
2014-06-10 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.0-1) unstable; urgency=medium
* New upstream release
* Add python-changelog and python-sphinx-paramlinks to Build-Depends
(needed while rebuilding documentation)
* Enable Python 3.X tests during build (add necessary packages to
Build-Depends)
* Update links to upstream changelog (now points to changelog.rst)
* Add lintian override for source-is-missing doc/searchindex.js
(this file is generated by sphinx-build, all sources are in the tarball)
2013-12-29 - Piotr Ożarowski <piotr@debian.org>
mako (0.9.1-1) unstable; urgency=low
* New upstream release
* Standards-Version bumped to 3.9.5 (no changes needed)
2013-08-31 - Piotr Ożarowski <piotr@debian.org>
mako (0.9.0-1) unstable; urgency=low
* New upstream release
2013-05-25 - Piotr Ożarowski <piotr@debian.org>
mako (0.8.1-1) unstable; urgency=low
* New upstream release
2013-05-05 - Piotr Ożarowski <piotr@debian.org>
mako (0.8.0-2) unstable; urgency=low
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Piotr Ożarowski ]
* Standards-Version bumped to 3.9.4 (no changes needed)
2013-04-12 - Piotr Ożarowski <piotr@debian.org>
mako (0.8.0-1) experimental; urgency=low
* New upstream release
2012-11-12 - Piotr Ożarowski <piotr@debian.org>
mako (0.7.3-1) experimental; urgency=low
* New upstream release
2012-07-13 - Piotr Ożarowski <piotr@debian.org>
mako (0.7.1-1) experimental; urgency=low
* New upstream release
(upload to experimental due to Wheezy freeze)
2012-03-31 - Piotr Ożarowski <piotr@debian.org>
mako (0.7.0-1) unstable; urgency=low
* New upstream release
* Standards-Version bumped to 3.9.3 (no changes needed)

See Also

Package Description
python3-marisa_0.2.4-8_amd64.deb Python3 bindings for MARISA
python3-markdown_2.5.1-2_all.deb text-to-HTML conversion library/tool (implemented in Python 3)
python3-markups_0.5.2-1_all.deb Wrapper around various text markups, implemented in Python 3
python3-markupsafe_0.23-1+b1_amd64.deb HTML/XHTML/XML string library for Python 3
python3-matplotlib_1.4.2-3.1_amd64.deb Python based plotting system in a style similar to Matlab (Python 3)
python3-mccabe_0.2.1-1_all.deb Python code complexity checker (Python 3)
python3-mdp_3.3-2_all.deb Modular toolkit for Data Processing
python3-mediainfodll_0.7.70-1_all.deb library for reading metadata from media files -- shared library
python3-memcache_1.53+2014.06.08.git.918e88c496-1_all.deb pure python memcached client - Python 3.x
python3-memprof_0.3.3-3+b1_amd64.deb memory profiler for Python (Python 3)
python3-metaconfig_0.1.4a1-3_all.deb Python ConfigParser bootstrapping library (Python3)
python3-mia_0.1.6-1_amd64.deb Python-3 bindings for the MIA image processing library
python3-mimeparse_0.1.4-1+deb8u1_all.deb Parse mime-types and quality parameters - python 3.x
python3-minimal_3.4.2-2_amd64.deb minimal subset of the Python language (default python3 version)
python3-misaka_1.0.2-3+b1_amd64.deb binding for Sundown, a markdown parsing library - python 3.x
Advertisement
Advertisement