python-plist_1.11-3_amd64.deb


Advertisement

Description

python-plist - Library for handling Apple binary and XML property lists

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name python-plist
Package version 1.11
Package release 3
Package architecture amd64
Package type deb
Installed size 208 B
Download size 47.34 KB
Official Mirror ftp.br.debian.org
libplist is a library for reading and writing the Apple binary and XML
property lists format. It's part of the libimobiledevice stack, providing
access to iDevices (iPod, iPhone, iPad ...).
This package contains the Python bindings

Alternatives

Package Version Architecture Repository
python-plist_1.11-3_i386.deb 1.11 i386 Debian Main
python-plist - - -

Requires

Name Value
libc6 >= 2.4
libplist2 >= 1.11
libpython2.7 >= 2.7
libxml2 >= 2.6.27
python << 2.8
python >= 2.7

Download

Type URL
Binary Package python-plist_1.11-3_amd64.deb
Source Package libplist

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-plist deb package:
    # sudo apt-get install python-plist

Files

Path
/usr/include/plist/cython/plist.pxd
/usr/lib/pyshared/python2.7/plist.so
/usr/lib/python2.7/dist-packages/plist.so
/usr/share/doc/python-plist/changelog.Debian.gz
/usr/share/doc/python-plist/copyright

Changelog

2014-03-29 - Chow Loong Jin <hyperair@debian.org>
libplist (1.11-3) unstable; urgency=medium
* [516e84a] Patch to fix endian detection (Closes: #742673)
* [df245be] Fix typo in libplist-doc description (Closes: #732766)
2014-03-26 - Chow Loong Jin <hyperair@debian.org>
libplist (1.11-2) unstable; urgency=medium
* Team upload
* [f625f06] Re-add .pxd file to python-plist.install.
Looks like it's needed by python-imobiledevice.
2014-03-25 - Chow Loong Jin <hyperair@debian.org>
libplist (1.11-1) unstable; urgency=medium
* Team upload
* [02a25b6] Imported Upstream version 1.11
* [a308129] Adapt packaging to use autotools
* [1e2ef46] Bump Standards-Version to 3.9.5 (no changes required)
* [cbdbd1a] Drop 03-remove-rpath.patch.
We don't need a patch to avoid rpath linkage with the new autotools build
system.
* [608a31e] Refresh 01-libs.private.patch
* [c0e674f] Build-dep on pkg-config
* [a5f8276] Rename libplist and libplist++ for SONAME bump
* [47cb416] Drop libplist++2.shlibs
* [406fb90] Call dpkg-gensymbols with -c4
* [8490574] Update install files for SONAME change and drop .pxd
* [cc8efd7] Drop *.la and *.a prior to dh_install
* [6fa64b7] Update .symbols files
2013-09-16 - Chow Loong Jin <hyperair@debian.org>
libplist (1.10-1) unstable; urgency=low
[ Julien Lavergne ]
* New upstream release (Closes: #706378)
* debian/rules:
- Remove workaround for moving plutil utils, since the name change
completely.
* debian/libplist++-dev.install:
- Install new files.
* debian/libplist1.symbols:
- Update symbols.
* debian/control:
- Update VCS fields.
- Update Standards-Version to 3.9.4.
- Remove dm-upload-allowed.
* debian/libplist++1.shlibs:
- Add a shlibs file, since symbols file is too unstable.
[ Chow Loong Jin ]
* debian/{control,rules}: Multiarchify things
* debian/control:
- Mark lib packages as multi-arch same
- Add dpkg-dev build-dep for default.mk include
* debian/libplist*1.install: Update paths in install files for multiarch
* debian/plistutils.manpages: Rename manpage to match binary rename
* debian/rules: Update LDFLAGS handling and drop CFLAGS override
* debian/lintian-overrides:
- Add lintian-overrides for hardening-no-fortify-functions
2012-07-20 - Julien Lavergne <julien.lavergne@gmail.com>
libplist (1.8-2) experimental; urgency=low
* debian/control:
- Replace build-depends on swig by cython, to enable python bindings made
by cython.
- Build-depends on debhelper (>= 9.20120417~) to fix hardening with cmake.
- Build-depends on chrpath.
- Update to Standards-Version: 3.9.3, no change needed.
* debian/python-plist.install:
- Update files installed by cython.
* debian/libplist++-dev.install:
- Remove the swig files.
* debian/rules:
- Remove files generated by swig.
- Remove rpath problem.
- Fix dh sequence order.
* debian/compat:
- Bump to 9.
2012-01-13 - Julien Lavergne <julien.lavergne@gmail.com>
libplist (1.8-1) unstable; urgency=low
* New upstream release.
2011-10-10 - Julien Lavergne <julien.lavergne@gmail.com>
libplist (1.7-1) unstable; urgency=low
* New upstream release.
* debian/rules:
- Run tests on all arches. 
* debian/README.Debian:
- Remove, since tests suit runs on all arches.
* debian/copyright:
- Fix DEP5 format.
2011-07-23 - Julien Lavergne <julien.lavergne@gmail.com>
libplist (1.6-2) unstable; urgency=medium
* debian/README.Debian :
- Add to mention supported archs.
* debian/rules:
- Only run the test suit on supported archs. (Closes: #633457).

See Also

Package Description
python-plotly_1.2.9-1_all.deb Python plotting library for publication-quality graphs
python-plplot-qt_5.10.0+dfsg-1_amd64.deb Scientific plotting library (python qt GUI)
python-plplot_5.10.0+dfsg-1_amd64.deb Python support for PLplot, a plotting library
python-plumbum_1.4.2-1+deb8u1_all.deb library for writing shell script-like programs in Python 2
python-plwm_2.6a+20080530-1.1_all.deb Pointless Window Manager - Python libraries for creating Window Managers
python-ply-doc_3.4-5_all.deb Lex and Yacc implementation for Python (documentation)
python-ply_3.4-5_all.deb Lex and Yacc implementation for Python2
python-pmock_0.3.1+s20140625-2_all.deb Python module for unit testing using mock objects
python-pmw-doc_1.3.2-6_all.deb Pmw -- Python MegaWidgets
python-pmw_1.3.2-6_all.deb Pmw -- Python MegaWidgets
python-pocketsphinx_0.8-5_amd64.deb Speech recognition tool - python bindings
python-poker-engine_1.3.6-1.2_all.deb multiplayer poker engine with abstract variants specifications
python-polib-doc_1.0.5-1_all.deb Python library to parse and manage gettext catalogs (documentation)
python-polib_1.0.5-1_all.deb Python library to parse and manage gettext catalogs
python-polybori_0.8.3-3+b2_amd64.deb polynomials over Boolean Rings, Python module
Advertisement
Advertisement