python-kombu_3.0.21-2_all.deb


Advertisement

Description

python-kombu - AMQP Messaging Framework for Python

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name python-kombu
Package version 3.0.21
Package release 2
Package architecture all
Package type deb
Installed size 831 B
Download size 161.60 KB
Official Mirror ftp.br.debian.org
The aim of Kombu is to make messaging in Python as easy as possible by
providing an idiomatic high-level interface for the AMQP protocol. It is meant
to replace the carrot library by providing a compatibility layer.
Features:
* Allows application authors to support several message server solutions by
using pluggable transports.
* Supports automatic encoding, serialization and compression of message
payloads.
* The ability to ensure that an operation is performed by gracefully handling
connection and channel errors.

Alternatives

Package Version Architecture Repository
python-kombu_3.0.21-2_all.deb 3.0.21 all Debian Main
python-kombu - - -

Requires

Name Value
python-amqp -
python-anyjson >= 0.3.3
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-kombu_3.0.21-2_all.deb
Source Package kombu

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-kombu deb package:
    # sudo apt-get install python-kombu

Files

Path
/usr/lib/python2.7/dist-packages/kombu/__init__.py
/usr/lib/python2.7/dist-packages/kombu/abstract.py
/usr/lib/python2.7/dist-packages/kombu/clocks.py
/usr/lib/python2.7/dist-packages/kombu/common.py
/usr/lib/python2.7/dist-packages/kombu/compat.py
/usr/lib/python2.7/dist-packages/kombu/compression.py
/usr/lib/python2.7/dist-packages/kombu/connection.py
/usr/lib/python2.7/dist-packages/kombu/entity.py
/usr/lib/python2.7/dist-packages/kombu/exceptions.py
/usr/lib/python2.7/dist-packages/kombu/five.py
/usr/lib/python2.7/dist-packages/kombu/log.py
/usr/lib/python2.7/dist-packages/kombu/message.py
/usr/lib/python2.7/dist-packages/kombu/messaging.py
/usr/lib/python2.7/dist-packages/kombu/mixins.py
/usr/lib/python2.7/dist-packages/kombu/pidbox.py
/usr/lib/python2.7/dist-packages/kombu/pools.py
/usr/lib/python2.7/dist-packages/kombu/serialization.py
/usr/lib/python2.7/dist-packages/kombu/simple.py
/usr/lib/python2.7/dist-packages/kombu/syn.py
/usr/lib/python2.7/dist-packages/kombu-3.0.21.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/kombu-3.0.21.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/kombu-3.0.21.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/kombu-3.0.21.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/kombu-3.0.21.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/kombu/async/__init__.py
/usr/lib/python2.7/dist-packages/kombu/async/debug.py
/usr/lib/python2.7/dist-packages/kombu/async/hub.py
/usr/lib/python2.7/dist-packages/kombu/async/semaphore.py
/usr/lib/python2.7/dist-packages/kombu/async/timer.py
/usr/lib/python2.7/dist-packages/kombu/tests/__init__.py
/usr/lib/python2.7/dist-packages/kombu/tests/case.py
/usr/lib/python2.7/dist-packages/kombu/tests/mocks.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_clocks.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_common.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_compat.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_compression.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_connection.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_entities.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_log.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_messaging.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_mixins.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_pidbox.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_pools.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_serialization.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_simple.py
/usr/lib/python2.7/dist-packages/kombu/tests/test_syn.py
/usr/lib/python2.7/dist-packages/kombu/tests/async/__init__.py
/usr/lib/python2.7/dist-packages/kombu/tests/async/test_hub.py
/usr/lib/python2.7/dist-packages/kombu/tests/async/test_semaphore.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/__init__.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_SQS.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_amqplib.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_base.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_filesystem.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_librabbitmq.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_memory.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_mongodb.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_pyamqp.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_redis.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_sqlalchemy.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/test_transport.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/virtual/__init__.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/virtual/test_base.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/virtual/test_exchange.py
/usr/lib/python2.7/dist-packages/kombu/tests/transport/virtual/test_scheduling.py
/usr/lib/python2.7/dist-packages/kombu/tests/utils/__init__.py
/usr/lib/python2.7/dist-packages/kombu/tests/utils/test_amq_manager.py
/usr/lib/python2.7/dist-packages/kombu/tests/utils/test_debug.py
/usr/lib/python2.7/dist-packages/kombu/tests/utils/test_encoding.py
/usr/lib/python2.7/dist-packages/kombu/tests/utils/test_functional.py
/usr/lib/python2.7/dist-packages/kombu/tests/utils/test_utils.py
/usr/lib/python2.7/dist-packages/kombu/transport/SLMQ.py
/usr/lib/python2.7/dist-packages/kombu/transport/SQS.py
/usr/lib/python2.7/dist-packages/kombu/transport/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/amqplib.py
/usr/lib/python2.7/dist-packages/kombu/transport/base.py
/usr/lib/python2.7/dist-packages/kombu/transport/beanstalk.py
/usr/lib/python2.7/dist-packages/kombu/transport/couchdb.py
/usr/lib/python2.7/dist-packages/kombu/transport/filesystem.py
/usr/lib/python2.7/dist-packages/kombu/transport/librabbitmq.py
/usr/lib/python2.7/dist-packages/kombu/transport/memory.py
/usr/lib/python2.7/dist-packages/kombu/transport/mongodb.py
/usr/lib/python2.7/dist-packages/kombu/transport/pyamqp.py
/usr/lib/python2.7/dist-packages/kombu/transport/pyro.py
/usr/lib/python2.7/dist-packages/kombu/transport/redis.py
/usr/lib/python2.7/dist-packages/kombu/transport/zmq.py
/usr/lib/python2.7/dist-packages/kombu/transport/zookeeper.py
/usr/lib/python2.7/dist-packages/kombu/transport/django/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/django/managers.py
/usr/lib/python2.7/dist-packages/kombu/transport/django/models.py
/usr/lib/python2.7/dist-packages/kombu/transport/django/management/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/django/management/commands/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/django/management/commands/clean_kombu_messages.py
/usr/lib/python2.7/dist-packages/kombu/transport/django/migrations/0001_initial.py
/usr/lib/python2.7/dist-packages/kombu/transport/django/migrations/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/sqlalchemy/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/sqlalchemy/models.py
/usr/lib/python2.7/dist-packages/kombu/transport/virtual/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/virtual/exchange.py
/usr/lib/python2.7/dist-packages/kombu/transport/virtual/scheduling.py
/usr/lib/python2.7/dist-packages/kombu/utils/__init__.py
/usr/lib/python2.7/dist-packages/kombu/utils/amq_manager.py
/usr/lib/python2.7/dist-packages/kombu/utils/compat.py
/usr/lib/python2.7/dist-packages/kombu/utils/debug.py
/usr/lib/python2.7/dist-packages/kombu/utils/encoding.py
/usr/lib/python2.7/dist-packages/kombu/utils/eventio.py
/usr/lib/python2.7/dist-packages/kombu/utils/functional.py
/usr/lib/python2.7/dist-packages/kombu/utils/limits.py
/usr/lib/python2.7/dist-packages/kombu/utils/text.py
/usr/lib/python2.7/dist-packages/kombu/utils/url.py
/usr/share/doc/python-kombu/FAQ
/usr/share/doc/python-kombu/NEWS.Debian.gz
/usr/share/doc/python-kombu/README.rst.gz
/usr/share/doc/python-kombu/changelog.Debian.gz
/usr/share/doc/python-kombu/changelog.gz
/usr/share/doc/python-kombu/copyright

Changelog

2014-08-11 - Brian May <bam@debian.org>
kombu (3.0.21-2) unstable; urgency=low
* Python3 package. Closes: #754047.
* New upstream release. Closes: #757691.
* Remove recommends/build-depends on python-librabbitmq as it is still
broken.
2014-08-09 - Michael Fladischer <FladischerMichael@fladi.at>
kombu (3.0.19-3) unstable; urgency=low
* Add python-librabbitmq (>= 1.5.2) to Recommends as a optional faster
transport than python-amqp.
* Add python-librabbitmq (>= 1.5.2) to Build-Depends to enable additional
tests during build.
* Drop versioned dependencies on python-amqp as there are no older releases
in the archive.
* Run wrap-and-sort on the packaging code.
2014-07-22 - Brian May <bam@debian.org>
kombu (3.0.19-2) unstable; urgency=medium
[ Michael Fladischer ]
* Fix output redirection for nose tests used in autopkgtest (see #460242).
[ Brian May ]
* Remove depends on python-librabbitmq, as python-librabbitmq is broken
(see #747270). python-amqp should be sufficient.
2014-06-23 - Michael Fladischer <FladischerMichael@fladi.at>
kombu (3.0.19-1) unstable; urgency=low
* New upstream release.
* Add autopkgtest that runs the upstream test suite against the installed
package.
2014-04-23 - Michael Fladischer <FladischerMichael@fladi.at>
kombu (3.0.15-1) unstable; urgency=low
* New upstream release.
* Update Dependencies on python-amqp to (>= 1.4.5).
* Add python-redis to Build-Depends to allow tests for the redis transport
to run and add it to Suggests to for anyone who uses it as a transport.
* Add python-msgpack to Build-Depends in order to enable further tests.
2014-04-10 - Michael Fladischer <FladischerMichael@fladi.at>
kombu (3.0.14-1) unstable; urgency=low
* New upstream release.
* Make Depends and Build-Depends on python-pymongo versioned (>=
2.6.2), thanks to Benjamin Drung.
* Check PGP signature on upstream tarball:
+ Add signature URL to debian/watch.
+ Include upstream public PGP key 030A2708.
+ Allow debian/upstream-signing-key.pgp to be included as a binary.
* Add patch to remove usage of remote-hosted images in documentation.
* Remove .PHONY declarations from debian/rules.
2014-02-11 - Michael Fladischer <FladischerMichael@fladi.at>
kombu (3.0.12-1) unstable; urgency=medium
* New upstream release.
* Refresh remove_nose-cover3.patch.
* Drop remove_nose-cover3.patch, no longer needed.
* Bump Build-Depends and Depends on python-ampq to >= 1.4.3.
2013-12-11 - Michael Fladischer <FladischerMichael@fladi.at>
kombu (3.0.7-1) unstable; urgency=low
* New upstream release.
* No longer supports python 2.5, reflect in X-Python-Version.
* Bump Standards version to 3.9.5.
* Bump Depends and Build-Depends on python-amqp to >= 1.3.3.
* Bump upper version limit for Build-Depends on python-amqp to (<<
2.0).
* Refresh patch.
* README was renamed to README.rst.
* Add kombu.egg-info/requires.txt do debian/clean.
* Make Build-Depends on python-all and python-pika unversioned as no
prior versions are available in Wheezy.
2013-10-07 - Michael Fladischer <FladischerMichael@fladi.at>
kombu (2.5.15-1) unstable; urgency=low
* New upstream release.
2013-09-02 - Michael Fladischer <FladischerMichael@fladi.at>
kombu (2.5.14-1) unstable; urgency=low
* New upstream release.
* Bump debhelper Build-Depends to >= 8.1.0~.
* Bump Standards version to 3.9.4.
* Bump Depends and Build-Depends on python-amqp to >= 1.0.13.
* Add python-librabbitmq to Build-Depends and Depends as the preferred
alternative to python-amqp.
* Add python-beanstalkc to Build-Depends and Suggests.
* Drop temporary workaround for Metadata-Version in d/rules.

See Also

Package Description
python-krbv_1.0.90-1_amd64.deb Python extension module for Kerberos 5
python-ktoblzcheck_1.47-1_all.deb library for verification of account numbers and bank codes (Python bindings)
python-kzorp_3.9.5-4_all.deb Python bindings for kzorp
python-laditools_1.0.1-2_all.deb Python module to control and monitor the LADI system
python-lamson_1.0pre11-1_all.deb A pure Python SMTP server
python-landslide_1.0.1-1_all.deb Lightweight markup language-based html5 slideshow generator
python-larch_1.20131130-1_all.deb B-tree library for Python
python-lasso_2.4.1-1_amd64.deb Library for Liberty Alliance and SAML protocols - Python bindings
python-launchpadlib_1.10.2+ds-2_all.deb Launchpad web services client library
python-lazr.config-doc_2.0.1-1_all.deb ini-file format handling supporting schemas and inheritance
python-lazr.config_2.0.1-1_all.deb ini-file format handling supporting schemas and inheritance
python-lazr.delegates-doc_2.0.1-1_all.deb easily write objects that delegate behavior
python-lazr.delegates_2.0.1-1_all.deb easily write objects that delegate behavior
python-lazr.restfulclient_0.13.3-1_all.deb client for lazr.restful-based web services
python-lazr.smtptest-doc_2.0.2-1_all.deb framework for testing SMTP-based applications and libraries
Advertisement
Advertisement