ppp_2.4.6-3.1_amd64.deb


Advertisement

Description

ppp - Point-to-Point Protocol (PPP) - daemon

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name ppp
Package version 2.4.6
Package release 3.1
Package architecture amd64
Package type deb
Installed size 930 B
Download size 329.61 KB
Official Mirror ftp.br.debian.org
The Point-to-Point Protocol provides a standard way to transmit
datagrams over a serial link, as well as a standard way for the machines
at either end of the link to negotiate various optional characteristics
of the link.
This package is most commonly used to manage a modem for dial-up or
certain kinds of broadband connections.

Alternatives

Package Version Architecture Repository
ppp_2.4.6-3.1_i386.deb 2.4.6 i386 Debian Main
ppp - - -

Requires

Name Value
init-system-helpers >= 1.18~
libc6 >= 2.15
libpam-modules -
libpam-runtime -
libpam0g >= 0.99.7.1
libpcap0.8 >= 0.9.8
procps -

Download

Type URL
Binary Package ppp_2.4.6-3.1_amd64.deb
Source Package ppp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ppp deb package:
    # sudo apt-get install ppp

Files

Path
/etc/bash_completion.d/pon
/etc/chatscripts/gprs
/etc/chatscripts/pap
/etc/init.d/pppd-dns
/etc/logrotate.d/ppp
/etc/pam.d/ppp
/etc/ppp/ip-down
/etc/ppp/ip-up
/etc/ppp/ipv6-down
/etc/ppp/ipv6-up
/etc/ppp/options
/etc/ppp/ip-down.d/0000usepeerdns
/etc/ppp/ip-up.d/0000usepeerdns
/lib/systemd/system/pppd-dns.service
/usr/bin/plog
/usr/bin/poff
/usr/bin/pon
/usr/lib/pppd/2.4.6/minconn.so
/usr/lib/pppd/2.4.6/openl2tp.so
/usr/lib/pppd/2.4.6/passprompt.so
/usr/lib/pppd/2.4.6/passwordfd.so
/usr/lib/pppd/2.4.6/pppoatm.so
/usr/lib/pppd/2.4.6/pppol2tp.so
/usr/lib/pppd/2.4.6/radattr.so
/usr/lib/pppd/2.4.6/radius.so
/usr/lib/pppd/2.4.6/radrealms.so
/usr/lib/pppd/2.4.6/rp-pppoe.so
/usr/lib/pppd/2.4.6/winbind.so
/usr/sbin/chat
/usr/sbin/pppd
/usr/sbin/pppdump
/usr/sbin/pppoe-discovery
/usr/sbin/pppstats
/usr/share/doc/ppp/FAQ.gz
/usr/share/doc/ppp/PLUGINS.gz
/usr/share/doc/ppp/README.Debian.gz
/usr/share/doc/ppp/README.MPPE
/usr/share/doc/ppp/README.MSCHAP80.gz
/usr/share/doc/ppp/README.MSCHAP81
/usr/share/doc/ppp/README.STATIC-IP
/usr/share/doc/ppp/README.cbcp
/usr/share/doc/ppp/README.gz
/usr/share/doc/ppp/README.pppoe
/usr/share/doc/ppp/README.pppol2tp
/usr/share/doc/ppp/README.pwfd
/usr/share/doc/ppp/README.win9x
/usr/share/doc/ppp/SETUP.gz
/usr/share/doc/ppp/changelog.Debian.gz
/usr/share/doc/ppp/changelog.gz
/usr/share/doc/ppp/copyright
/usr/share/doc/ppp/defaultroute
/usr/share/doc/ppp/examples/filters
/usr/share/doc/ppp/examples/interfaces
/usr/share/doc/ppp/examples/options.ttyXX
/usr/share/doc/ppp/examples/peers-gprs
/usr/share/doc/ppp/examples/peers-pppoa
/usr/share/doc/ppp/examples/peers-pppoe
/usr/share/doc/ppp/examples/per-linkname
/usr/share/doc/ppp/examples/popp
/usr/share/doc/ppp/examples/userscripts-down
/usr/share/doc/ppp/examples/userscripts-up
/usr/share/doc/ppp/examples/scripts/README.gz
/usr/share/doc/ppp/examples/scripts/autopppd.gz
/usr/share/doc/ppp/examples/scripts/callback
/usr/share/doc/ppp/examples/scripts/chat-callback
/usr/share/doc/ppp/examples/scripts/ip-down.local.add
/usr/share/doc/ppp/examples/scripts/ip-up.local.add
/usr/share/doc/ppp/examples/scripts/ipv6-down.sample
/usr/share/doc/ppp/examples/scripts/ipv6-up.sample
/usr/share/doc/ppp/examples/scripts/options-rsh-loc
/usr/share/doc/ppp/examples/scripts/options-rsh-rem
/usr/share/doc/ppp/examples/scripts/options-ssh-loc
/usr/share/doc/ppp/examples/scripts/options-ssh-rem
/usr/share/doc/ppp/examples/scripts/plog
/usr/share/doc/ppp/examples/scripts/poff
/usr/share/doc/ppp/examples/scripts/pon
/usr/share/doc/ppp/examples/scripts/pon.1
/usr/share/doc/ppp/examples/scripts/ppp-off
/usr/share/doc/ppp/examples/scripts/ppp-on
/usr/share/doc/ppp/examples/scripts/ppp-on-dialer
/usr/share/doc/ppp/examples/scripts/ppp-on-rsh
/usr/share/doc/ppp/examples/scripts/ppp-on-ssh
/usr/share/doc/ppp/examples/scripts/redialer
/usr/share/doc/ppp/examples/scripts/secure-card
/usr/share/doc/ppp/examples/scripts/chatchat/README.gz
/usr/share/doc/ppp/examples/scripts/chatchat/chatchat.c.gz
/usr/share/lintian/overrides/ppp
/usr/share/man/man1/plog.1.gz
/usr/share/man/man1/poff.1.gz
/usr/share/man/man1/pon.1.gz
/usr/share/man/man8/chat.8.gz
/usr/share/man/man8/pppd-radattr.8.gz
/usr/share/man/man8/pppd-radius.8.gz
/usr/share/man/man8/pppd.8.gz
/usr/share/man/man8/pppdump.8.gz
/usr/share/man/man8/pppoe-discovery.8.gz
/usr/share/man/man8/pppstats.8.gz
/usr/share/ppp/chap-secrets
/usr/share/ppp/pap-secrets
/usr/share/ppp/provider.chatscript
/usr/share/ppp/provider.peer

Changelog

2015-04-14 - Emanuele Rocca <ema@debian.org>
ppp (2.4.6-3.1) unstable; urgency=high
* Non-maintainer upload.
* Urgency high due to fix for DoS vulnerability.
* Fix buffer overflow in rc_mksid().
The function converts the PID of pppd to hex to generate a pseudo-unique
string. If the process id is bigger than 65535 (FFFF), its hex
representation will be longer than 4 characters, resulting in a buffer
overflow. This bug can be exploited to cause a remote DoS.
(Closes: #782450)
2014-10-19 - Chris Boot <debian@bootc.net>
ppp (2.4.6-3) unstable; urgency=high
* Urgency high due to fix for CVE-2014-3158.
* Cherry-pick patches from 2.4.7 upstream release. These are 9 of 11 patches
in the 2.4.7 upstream release of PPP, including the fix for CVE-2014-3158.
The two patches left out were not imported in order to preserve ABI
stability. (Closes: #762789)
- ppp-2.4.7-001-pppd-Separate-IPv6-handling-for-sifup-sifdown.patch
- ppp-2.4.7-002-pppol2tp-Connect-up-down-events-to-notifiers-and-add.patch
- ppp-2.4.7-003-pppd-Add-declarations-to-eliminate-compile-warnings.patch
- ppp-2.4.7-004-pppd-Eliminate-some-unnecessary-ifdefs.patch
- ppp-2.4.7-005-radius-Fix-realms-config-file-option.patch
- ppp-2.4.7-006-pppd-Eliminate-potential-integer-overflow-in-option-.patch
- ppp-2.4.7-007-pppd-Eliminate-memory-leak-with-multiple-instances-o.patch
- ppp-2.4.7-008-pppd-Fix-a-stack-variable-overflow-in-MSCHAP-v2.patch
- ppp-2.4.7-009-winbind-plugin-Add-DMPPE-1-to-eliminate-compiler-war.patch
* Refresh debian/patches/cifdefroute.dif
* Update Standards-Version to 3.9.6 (no changes required).
2014-04-17 - Chris Boot <debian@bootc.net>
ppp (2.4.6-2) unstable; urgency=medium
* d/rules: Fix ppp-udeb module path by using a shell expression for PPPDDIR.
* Update Breaks for network-manager to (<< 0.9.8.8-7~). (Closes: #744814)
* Update Breaks for network-manager-pptp and pppdcapiplugin.
* Update lintian overrides to account for changed plugin path.
2014-04-13 - Chris Boot <debian@bootc.net>
ppp (2.4.6-1) unstable; urgency=medium
* New upstream release. (Closes: #718873)
* Enable GPG signature checking for uscan:
- Add pgpsigurlmangle option to debian/watch
- Add debian/upstream/signing-key.asc
- Remove linitian override for debian-watch-may-check-gpg-signature
2014-01-27 - Chris Boot <debian@bootc.net>
ppp (2.4.5+git20130610-4) unstable; urgency=medium
* Remove obsolete --update-rcd-params from dh_installinit. (Closes: #727162)
* Remove obsolete Build-Depends on quilt.
* Add systemd service file for ppp-dns: (Closes: #716864)
- Build-Depend on dh-systemd
- Use dh_installinit --name instead of --init-script
- Add dh_systemd_enable and dh_systemd_start to debian/rules
Thanks to Shawn Landden for providing a patch.
* Add LSB Description header to init script.
* Make init script source /lib/lsb/init-functions for systemd compatibility.
* Override a number of lintian tags:
- init.d-script-does-not-implement-optional-option etc/init.d/pppd-dns
status
- non-standard-dir-perm etc/chatscripts/ and etc/ppp/peers/
- package-contains-readme-for-other-platform-or-distro
usr/share/doc/ppp/README.win9x
- setuid-binary usr/sbin/pppd
- debian-watch-may-check-gpg-signature
See the lintian overrides files for reasoning.
* Add support for arbitrary interface naming: (Closes: #458646)
- Add debian/patches/ppp-2.4.2-ifname.diff based on openSUSE patch.
* Fix a potential buffer overflow in the radius plugin:
- Add debian/patches/ppp-2.4.4-strncatfix.patch from openSUSE.
* Update debian/copyright:
- Add myself to the list of maintainers
- Change reference to GPL symlink license to GPL-2
* Update Standards-Version to 3.9.5 (no changes required).
* Refresh debian/patches/cifdefroute.dif from OpenSUSE (Closes: #425163) and
add patch header.

See Also

Package Description
pppconfig_2.3.21_all.deb Text menu based utility for configuring ppp
pppdcapiplugin_3.25+dfsg1-3.5_amd64.deb ISDN utilities - pppd plug-in for CAPI support
pppoe_3.8-3_amd64.deb PPP over Ethernet driver
pppoeconf_1.21_all.deb configures PPPoE/ADSL connections
pps-tools_0.20120406+g0deb9c7e-2_amd64.deb LinuxPPS support tools and headers
ppsh_1.6.6-1_amd64.deb Program to parse and pretty print arbitrary Haskell Show output
pptp-linux_1.7.2-7_amd64.deb Point-to-Point Tunneling Protocol (PPTP) Client
pptpd_1.4.0-5_amd64.deb PoPToP Point to Point Tunneling Server
pqiv_2.2-1_amd64.deb Lightweight image viewer
praat_5.4.0-1_amd64.deb program for speech analysis and synthesis
prads_0.3.3-1_amd64.deb Passive Real-time Asset Detection System
prank_0.0.140110-1_amd64.deb Probabilistic Alignment Kit for DNA, codon and amino-acid sequences
prayer-accountd_1.3.5-dfsg1-2+b1_amd64.deb account management daemon for Prayer
prayer-templates-dev_1.3.5-dfsg1-2+b1_amd64.deb tools for compiling Prayer templates
prayer-templates-src_1.3.5-dfsg1-2_all.deb templates for customizing Prayer Webmail
Advertisement
Advertisement