plasma-widget-uim_1.8.6-8_amd64.deb


Advertisement

Description

plasma-widget-uim - Universal Input Method - KDE Plasma widget

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name plasma-widget-uim
Package version 1.8.6
Package release 8
Package architecture amd64
Package type deb
Installed size 81 B
Download size 20.55 KB
Official Mirror ftp.br.debian.org
Uim is an input method module library which supports various scripts and can
act as a front end for a range of input methods, including Anthy, Canna,
PRIME, or SKK (for Japanese), Pinyin (for Chinese), Byeoru (for Korean), and
M17n (for many other languages). Most of its functions are implemented in
Scheme, so it's very simple and flexible.
This package contains a KDE Plasma widget which can configure uim, monitor
its conversion mode, and so on.

Alternatives

Package Version Architecture Repository
plasma-widget-uim_1.8.6-8_i386.deb 1.8.6 i386 Debian Main
plasma-widget-uim - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libkdecore5 >= 4:4.3.4
libkdeui5 >= 4:4.3.4
libplasma3 >= 4:4.5.90
libqt4-dbus >= 4:4.8.0
libqt4-svg >= 4:4.8.0
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libstdc++6 >= 4.1.1
libuim-data >= 1:1.8.6-8
libuim-scm0 >= 1:1.5.7
libuim8 >= 1:1.5.7
uim-common >= 1:1.8.6-8
uim-qt >= 1:1.8.6-8
uim-utils >= 1:1.8.6-8

Replaces

Name Value
uim-applet-kde << 1:1.8.5-2~

Download

Type URL
Binary Package plasma-widget-uim_1.8.6-8_amd64.deb
Source Package uim

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install plasma-widget-uim deb package:
    # sudo apt-get install plasma-widget-uim

Files

Path
/usr/lib/kde4/plasma_applet_uim.so
/usr/share/doc/plasma-widget-uim
/usr/share/kde4/services/plasma-applet-uim.desktop

Changelog

2014-11-13 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6-8) unstable; urgency=medium
* debian/control
- depends emacs24 instead of emacs23. emacs23 has been removed from jessie.
2014-06-21 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6-7) unstable; urgency=medium
* Add a workaround for gtk+ >= 3.7.8 (Closes: #752226).
- debian/patches/workaround_for_gtk3_higher_3.7.8.patch: new file.
- debian/patches/series: update.
2014-04-24 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6-6) unstable; urgency=medium
* debian/README.Debian: remove "framebuffer" from "Using uim-fep".
* debian/README.Debian.uim-fep: add config example for Using uim-fep.
* support alternatives for uim-toolbar requested by im-config.
- debian/uim-common.{postinst,prerm}; new file.
- debian/uim-gtk3.{postinst,prerm}; new file.
- debian/uim-gtk2.0.{postinst,prerm}; new file.
- debian/uim-qt.{postinst,prerm}; new file.
* fix FTBFS on ppc64el. pick up from uim 1:1.8.6-4ubuntu1.
thanks to Matthias Klose <doko@ubuntu.com> (Closes: #744673).
- debian/patches/ppc64el.patch: new file
- debian/rules: use autotools_dev with dh.
2014-04-02 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6-5) unstable; urgency=medium
* debian/control: uim-tcode depends t-code-common instead of t-code.
* add note for uim-fep (Closes: #743277).
- debian/README.Debian: add note.
- debian/README.Debian.uim-fep: new file.
- debian/uim-fep.docs: add README.Debian.uim-fep.
* bump up Standards-Version 3.9.5
2013-10-24 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6-4) unstable; urgency=low
* debian/control: use automake instead of automake1.10 (Closes: #724442).
* debian/patches/close_socket_after_uim_skk_requests_disconnection.patch
- cherry-pick from upstream.
- close socket after uim-skk requests disconnection (Closes: #727086).
2013-09-15 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6-3) unstable; urgency=low
* drop uim-prime.
- debian/uim-prime.install: remove.
- debian/uim-prime.postinst: remove.
- debian/uim-prime.prerm: remove.
- debian/libuim-data.install: add uim-prime's scm.
- debian/uim-common.install: add uim-prime's icon.
- debian/README.Debian: remove uim-prime.
- debian/control: remove prime from b-d.
add Breaks/Replaces: uim-prime to uim-common and libuim-data.
- debian/rules: remove uim-prime from override_dh_link.
2013-07-06 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6-2) unstable; urgency=low
* debian/control
- tighten dependency avoid broken-symlink library (Closes: #715123).
* debian/patches/pass_cppflags_to_cmake_cxx_flags.patch: New file.
- pass CPPFLAGS to CMAKE_CXX_FLAGS for hardening.
* debian/patches/fix_spelling_error_sigscheme.patch
- fix spelling error sigscheme: charater character.
2013-06-30 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6-1) unstable; urgency=low
* New upstream release.
- Avoid a crash when a Canna server name is specified.
Thanks to Kouichi ONO <kou1.ono@gmail.com> (Closes: #713997).
* debian/uim-el.emacsen-startup
- do not require uim-leim if LOGNAME is root (Closes: #671818).
2013-05-11 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.5-2) unstable; urgency=low
* drop im-switch support (Closes: #629490)
- debian/README.Debian: remove im-switch documentation.
- debian/control: drop Recommendation.
- debian/im-switch/: drop directory.
- debian/rules: drop installation stuff.
- debian/uim-xim.{postinst,prerm}: drop update-alternatives stuff.
* drop obsoleted DMUA header.
- debian/control: remove DM-Upload-Allowed: yes.
* drop transitional packages: uim-qt3 uim-applet-kde uim-hangul.
- debian/control: drop transitional packages.
- debian/rules: drop symlinks.
* bump up Standards-Version 3.9.4

See Also

Package Description
plasma-widget-veromix_0.18.3-1.1_all.deb Mixer for the PulseAudio sound server (Plasma)
plasma-widget-yawp_0.4.2-1_amd64.deb Yet Another Weather Plasmoid fetches weather forecasts for you
plasma-widgets-addons_4.14.2-1_amd64.deb additional widgets for Plasma
plasma-widgets-workspace_4.11.13-2_amd64.deb plasma widgets and containments for the KDE Plasma Workspace
plasmidomics_0.2.0-3_all.deb draw plasmids and vector maps with PostScript graphics export
plastimatch_1.5.16+dfsg-2_amd64.deb medical image reconstruction and registration
playitslowly_1.4.0-1_all.deb Plays back audio files at a different speed or pitch
playmidi_2.4debian-10_amd64.deb MIDI player
plee-the-bear-data_0.6.0-3.1_all.deb data for Plee the Bear
plee-the-bear_0.6.0-3.1_amd64.deb 2D platform game
pleiades_1.5.0-1_all.deb Japanese translation plug-in for Eclipse using dynamic AOP
plink_1.07-3_amd64.deb whole-genome association analysis toolset
plm_2.4.11+repack-2_all.deb Programming exerciser in Java, Python and others
ploop_1.12.1-1_amd64.deb tools to work with ploop devices and images
plopfolio.app_0.1.0-6+b4_amd64.deb Personal dashboard for GNUstep
Advertisement
Advertisement