maq_0.7.1-5_amd64.deb


Advertisement

Description

maq - maps short fixed-length polymorphic DNA sequence reads to reference sequences

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name maq
Package version 0.7.1
Package release 5
Package architecture amd64
Package type deb
Installed size 559 B
Download size 313.88 KB
Official Mirror ftp.br.debian.org
Maq (short for Mapping and Assembly with Quality) builds mapping assemblies
from short reads generated by the next-generation sequencing machines. It was
particularly designed for Illumina-Solexa 1G Genetic Analyzer, and has a
preliminary functionality to handle ABI SOLiD data. Maq is previously known as
mapass2.
Developmemt of Maq stopped in 2008. Its successors are BWA and SAMtools.

Alternatives

Package Version Architecture Repository
maq_0.7.1-5_i386.deb 0.7.1 i386 Debian Main
maq - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:4.1.1
libstdc++6 >= 4.1.1
zlib1g >= 1:1.2.3.3

Download

Type URL
Binary Package maq_0.7.1-5_amd64.deb
Source Package maq

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install maq deb package:
    # sudo apt-get install maq

Files

Path
/usr/bin/farm-run.pl
/usr/bin/maq
/usr/bin/maq.pl
/usr/bin/maq_eval.pl
/usr/bin/maq_plot.pl
/usr/share/doc-base/maq
/usr/share/doc/maq/AUTHORS
/usr/share/doc/maq/README
/usr/share/doc/maq/changelog.Debian.gz
/usr/share/doc/maq/changelog.gz
/usr/share/doc/maq/copyright
/usr/share/doc/maq/maq.pdf
/usr/share/lintian/overrides/maq
/usr/share/man/man1/maq.1.gz
/usr/share/maq/asub
/usr/share/maq/fq_all2std.pl
/usr/share/maq/maq_post.pl
/usr/share/maq/maq_sanger.pl
/usr/share/maq/paf_utils.pl
/usr/share/maq/solid2fastq.pl

Changelog

2012-04-25 - Andreas Tille <tille@debian.org>
maq (0.7.1-5) unstable; urgency=low
[ Charles Plessy ]
* renamed debian/upstream-metadata.yaml to debian/upstream
[ Andreas Tille ]
* debian/upstream:
- Removed duplicated entry DOI
- Moved PMID to references
* debian/source/format: 3.0 (quilt)
* debian/reference: removed because references are kept in
debian/upstream (also removed from debian/docs)
* debian/control:
- Standards-Version: 3.9.3 (no changes needed)
- Fixed Vcs fields
- Build-Depends: dh-autoreconf
- Dropped from Build-Depends: quilt, cdbs
* debian/patches/20_prevent_-64_option.patch: Dropped in favour
of using dh-autoreconf
* debian/rules: converted to dh
* debian/copyright: cme fix dpkg-copyright
* debian/patches/gcc-4.7.patch: Enable building with g++-4.7
Closes: #667270
* debian/README.source: Removed because there is no point any
more to explain how to use quilt
2011-03-13 - Charles Plessy <plessy@debian.org>
maq (0.7.1-4) unstable; urgency=low
* Development of Maq stopped in 2008. Its successors are BWA and SAMtools.
(debian/control, debian/maq.doc-base).
* DEP-5 conformant debian/copyright file, checked with ‘config-edit’.
* Use Debhelper 8 (debian/control, debian/compat).
* Collected various information in debian/upstream-metadata.yaml.
* Incremented Standards-Version in debian/policy to reflect
conformance with Policy 3.9.1 (no changes needed).
2009-07-17 - Charles Plessy <plessy@debian.org>
maq (0.7.1-3) unstable; urgency=low
* Distribute scripts that are not installed by upstream’s
makefile in /usr/share/maq (debian/install).
* Incremented Standards-Version in debian/policy to reflect
conformance with Policy 3.8.2 (no changes needed).
* debian/patch: made headers conformant with current draft of DEP3.
2009-04-16 - Andreas Tille <tille@debian.org>
maq (0.7.1-2) unstable; urgency=low
* Enable LARGEFILE64_SOURCE to prevent a problem with zlib on
64bit archs (Thanks to Peter Green <plugwash@p10link.net> for
the patch)
Closes: #506009
* Standards-Version: 3.8.1 (no changes needed)
2008-11-16 - Charles Plessy <plessy@debian.org>
maq (0.7.1-1) unstable; urgency=low
* New upstream release 0.7.1 (Closes: 505820)
- Accepts reads shorter than 127 bp (63 bp before).
- .map alignment changes and not backward-compatible.
- Reversion to short reads possible with --enable-shortreads.
* New upstream release 0.6.8
- New features for the 1000 genome project.
- Error dependency coefficient reduced from 0.93 to 0.85.
- Added mapvalidate command.
- Support generating GLF format.
- The mapcheck command can optionally dump additional information.
* debian/patches:
- 20_perl_path.patch deleted because accepted upstream.
- 10_prevent_-64_option.patch reorganised to only modify configure.ac
and forwarded upstream.
- 20_prevent_-64_option.patch changes configure and can be regenerated
by running autoreconf.
* debian/control: typo corrected in short description (Closes: #492979)
* debian/reference: BibTeX reference downloaded from 
http://genome.cshlp.org/citmgr?gca=genome;18/11/1851 with abstract
removed because it is a copyrighted work.
* debian/README.Sources renamed README.source to comply with Policy.
2008-07-16 - Andreas Tille <tille@debian.org>
maq (0.6.7-1) unstable; urgency=low
[ Charles Plessy ]
* Initial release (Closes: #489836)
[ Andreas Tille ]
* Rudely deleted -m64 option from configure because multiarch
building leads to several problems

See Also

Package Description
maqview_0.2.5-6_amd64.deb graphical read alignment viewer for short gene sequences
marble-data_4.14.2-1_all.deb data files for Marble
marble-mobile_4.14.2-1_amd64.deb globe and map widget for mobile form factors
marble-plugins_4.14.2-1_amd64.deb plugins for Marble
marble-qt_4.14.2-1_amd64.deb globe and map widget (no KDE dependencies)
marble-touch_4.14.2-1_amd64.deb globe and map widget for tablets
marble_4.14.2-1_amd64.deb globe and map widget
marco-common_1.8.2+dfsg1-6_all.deb lightweight GTK+ window manager for MATE (common files)
marco_1.8.2+dfsg1-6_amd64.deb lightweight GTK+ window manager for MATE
maria-doc_1.3.5-4_all.deb documentation of Maria
maria_1.3.5-4_amd64.deb reachability analyzer for Algebraic System Nets
mariadb-client-10.0_10.0.32-0+deb8u1_amd64.deb MariaDB database client binaries
mariadb-client-core-10.0_10.0.32-0+deb8u1_amd64.deb MariaDB database core client binaries
mariadb-client_10.0.32-0+deb8u1_all.deb MariaDB database client (metapackage depending on the latest version)
mariadb-common_10.0.32-0+deb8u1_all.deb MariaDB common metapackage
Advertisement
Advertisement