magit_1.2.1-1_all.deb


Advertisement

Description

magit - Emacs interface for Git

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: magit
Package version: 1.2.1
Package release: 1
Package architecture: all
Package type: deb
Installed size: 421 B
Download size: 84.96 KB
Official Mirror: ftp.br.debian.org
With Magit, you can inspect and modify your Git repositories with Emacs. You can review and commit the changes you have made to the tracked files, for example, and you can browse the history of past changes. There is support for cherry picking, reverting, merging, rebasing, and other common Git operations.

Alternatives

    Download

    Binary package: magit_1.2.1-1_all.deb
    Source package: magit

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install magit deb package:
      # sudo apt-get install magit

    Files

    • /etc/emacs/site-start.d/50magit.el
    • /usr/lib/emacsen-common/packages/compat/magit
    • /usr/lib/emacsen-common/packages/install/magit
    • /usr/lib/emacsen-common/packages/remove/magit
    • /usr/share/doc/magit/README.Debian
    • /usr/share/doc/magit/README.md
    • /usr/share/doc/magit/changelog.Debian.gz
    • /usr/share/doc/magit/copyright
    • /usr/share/emacs/site-lisp/magit/magit-bisect.el
    • /usr/share/emacs/site-lisp/magit/magit-blame.el
    • /usr/share/emacs/site-lisp/magit/magit-classic-theme.el
    • /usr/share/emacs/site-lisp/magit/magit-install.el
    • /usr/share/emacs/site-lisp/magit/magit-key-mode.el
    • /usr/share/emacs/site-lisp/magit/magit-simple-keys.el
    • /usr/share/emacs/site-lisp/magit/magit-stgit.el
    • /usr/share/emacs/site-lisp/magit/magit-svn.el
    • /usr/share/emacs/site-lisp/magit/magit-topgit.el
    • /usr/share/emacs/site-lisp/magit/magit-wip.el
    • /usr/share/emacs/site-lisp/magit/magit.el
    • /usr/share/emacs/site-lisp/magit/rebase-mode.el
    • /usr/share/info/magit.info.gz

    Changelog

    2014-07-25 - Timo Juhani Lindfors <timo.lindfors@iki.fi> magit (1.2.1-1) unstable; urgency=low * New upstream release. * debian/watch: Use releases from Github and use HTTPS. * Add emacsen.compat file (emacsen policy 2.0.8). * Don't depend on dpkg, install-info (policy 3.9.5). * Depend on emacsen-common, not emacs (emacsen policy 2.0.8) (closes: #754019). * Bump standards-version to 3.9.5. * Use custom-set-faces instead of setq in example (closes: #720883). * Use canonical Vcs addresses to make lintian happy. * Drop bug-718861.patch since new upstream version contains it. * Depend on git instead of transitional git-core package. * Build-Depend on emacs instead of emacs23 since emacs23 is going to be removed.

    2013-08-06 - Timo Juhani Lindfors <timo.lindfors@iki.fi> magit (1.2.0-2) unstable; urgency=low * Backport patch to fix incompatibility with emacs-snapshot 24.3.50 (Closes: #718861) - bug-718861.patch

    2013-05-13 - Timo Juhani Lindfors <timo.lindfors@iki.fi> magit (1.2.0-1) unstable; urgency=low * Upload to unstable.

    2013-02-24 - Timo Juhani Lindfors <timo.lindfors@iki.fi> magit (1.2.0-1~experimental1) experimental; urgency=low * New upstream release (Closes: #695479). * Drop patch autogenerate-autoloads.diff. * Bump standards-version to 3.9.4, no changes needed. * Upload to experimental since wheezy is frozen.

    2012-07-02 - Timo Juhani Lindfors <timo.lindfors@iki.fi> magit (1.1.1-3) unstable; urgency=low * Add emacs24 to the list of supported emacs versions (closes: #679781)

    2012-05-21 - Timo Juhani Lindfors <timo.lindfors@iki.fi> magit (1.1.1-2) unstable; urgency=low * Backport upstream commit c8cfaf37b7c142edc6714d86691b8720f2606328 for autogenerating autoloads (closes: #671922). * Bump Standards-Version to 3.9.3 (no changes needed). * Update upstream homepage URL. * Remove DM-Upload-Allowed.

    2012-01-23 - Timo Juhani Lindfors <timo.lindfors@iki.fi> magit (1.1.1-1) unstable; urgency=low [ Timo Juhani Lindfors] * New upstream release. [ Rémi Vanicat ] * Install contrib .el files

    2011-12-31 - Timo Juhani Lindfors <timo.lindfors@iki.fi> magit (1.1.0-1) unstable; urgency=low * New upstream release. * Use upstream tarball instead of regenerating one from git tag, mostly because make dist nowadays embeds version numbers to the *.el files (LP: #853567). * Drop patch inherit-standard-faces.diff that is now upstream. * Update watch file path.

    2011-08-30 - Timo Juhani Lindfors <timo.lindfors@iki.fi> magit (1.0.0-2) unstable; urgency=low * Bump Standards-Version to 3.9.2 (no changes needed). * Drop article from package description to make lintian happy. * Add patch inherit-standard-faces.diff - Backport upstream commit 3d0ea1d60fbc0a8135e2146418c0c64c9d05705a to use standard faces where possible (closes: #637193).

    2011-04-11 - Teemu Hukkanen <tjhukkan@iki.fi> magit (1.0.0-1) unstable; urgency=low [ Timo Juhani Lindfors ] * New upstream release. * Drop support for emacsen other than emacs23 or emacs-snapshot (closes: #619480). [ Teemu Hukkanen ] * Add DM-Upload-Allowed.

    Advertisement
    Advertisement