magics++_2.22.7.dfsg.1-4_amd64.deb


Advertisement

Description

magics++ - Executables for the magics++ library

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: magics++
Package version: 2.22.7.dfsg.1
Package release: 4
Package architecture: amd64
Package type: deb
Installed size: 83 B
Download size: 39.07 KB
Official Mirror: ftp.br.debian.org
Magics++ is the latest generation of the ECMWF's Meteorological plotting software MAGICS. Although completely redesigned in C++, it is intended to be as backwards-compatible as possible with the Fortran interface. Besides its programming interfaces (Fortran and C), Magics++ offers MagML, a plot description language based on XML aimed at automatic web production. This package contains the MagcML binary that may be used with magics++.

Alternatives

    Download

    Source package: magics++

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install magics++ deb package:
      # sudo apt-get install magics++

    Files

    • /usr/bin/magjson
    • /usr/bin/magmlx
    • /usr/bin/mapgen_clip
    • /usr/share/doc/magics++/changelog.Debian.gz
    • /usr/share/doc/magics++/changelog.gz
    • /usr/share/doc/magics++/copyright

    Changelog

    2014-10-30 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.22.7.dfsg.1-4) unstable; urgency=medium * Build -fPIC for mipsel. Closes: #766832

    2014-10-15 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.22.7.dfsg.1-3) unstable; urgency=medium * Ship all header files in /usr/include/magics. * Fix arch-dependent stuff in magics-config, which breaks multiarch. Pull from magics.pc instead. Closes: #732621. * Include HAVE_* definitions in extra flags passed to Cmake so that magics_config matches 2.8.15 version needed for metview. Closes: #765524. * Disable qt5 for the moment. * Enable MAGICS_TIFF. Add libtiff-dev to dependencies.

    2014-10-05 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.22.7.dfsg.1-2) unstable; urgency=medium * Disable OS Check so we build Hurd, kFreeBSD.

    2014-09-16 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.22.7.dfsg.1-1) unstable; urgency=medium * New upstream release. Build using cmake not configure. Closes: #677210. * DFSG version as .bin files removed (unnecessary). * Now use xz compression. * grib-api now works on mips, so drop conditional depenency on not using emos/grib-api on mips. Closes: #756591. * Drop unnecessary dependency on python3-all-dev until python3 is supported. Closes: #750599. * Build against Qt5 * Add ksh depends for magics++ (magjson script) * Add versioned soname for libmagplus.so.3.0.0 * Add drop-gen-dates.patch to drop dates in autogenerated header files; creates false positives in diff-detection scripts. Closes: #731621.

    2014-07-22 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.18.15-6) unstable; urgency=medium * Add dependency on libterralib-dev to libmagics++-dev. Change references to Terralib headers that ship in Debian rather than local ones (not included). * Drop unnecessary dependency on hdf5. Closes: #755709.

    2013-12-16 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.18.15-5) unstable; urgency=medium * Build-Depend on libq4-dev. No longer use libmotif-dev. Closes: #723526, #732328. * Change libmagics++-metview-dev to section: libdevel, default to science; python-* to python

    2013-12-12 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.18.15-4) unstable; urgency=medium * Fix hardening rules: disable PIE as it breaks python shlibs. * Add --enable-metview to support MetView. * Add libmagics++-metview-dev to provide libs needed by MetView only.

    2013-12-08 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.18.15-3) unstable; urgency=medium * Update Homepage. * Standards-Version: 3.9.5 * Set python-magics++ as utils, not python to match overrides

    2013-09-03 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.18.15-2) unstable; urgency=low * Don't use emoslib on mips: emoslib needs grib-api, not available there. * Now use --enable-opengl as we have real motif in Debian.

    2013-05-22 - Alastair McKinstry <mckinstry@debian.org> magics++ (2.18.15-1) unstable; urgency=low * New upstream release. * Transition B-D: libgd2-xpm-dev -> libgd2-dev * Standards-Version: 3.9.4 * Depend on debhelper >=9.

    Advertisement
    Advertisement