lwm_1.2.2-5_amd64.deb


Advertisement

Description

lwm - lightweight window manager

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: lwm
Package version: 1.2.2
Package release: 5
Package architecture: amd64
Package type: deb
Installed size: 114 B
Download size: 40.72 KB
Official Mirror: ftp.br.debian.org
Low resource Window manager ideal for older PCs. It uses a minimum of external libraries, thus very little memory. It doesn't iclude icons, icon docs, button bars or root menus.

Alternatives

Provides

  • x-window-manager

    Download

    Binary package: lwm_1.2.2-5_amd64.deb
    Source package: lwm

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install lwm deb package:
      # sudo apt-get install lwm

    Files

    • /usr/bin/lwm
    • /usr/share/doc/lwm/BUGS
    • /usr/share/doc/lwm/TODO
    • /usr/share/doc/lwm/changelog.Debian.gz
    • /usr/share/doc/lwm/changelog.gz
    • /usr/share/doc/lwm/copyright
    • /usr/share/man/man1/lwm.1.gz
    • /usr/share/menu/lwm
    • /usr/share/xsessions/lwm.desktop

    Changelog

    2013-06-11 - Jari Aalto <jari.aalto@cante.net> lwm (1.2.2-5) unstable; urgency=low * debian/control - (Build-Depends): Rm dpkg-dev; not needed with debhelper 9. - (Standards-Version): Update to 3.9.4. - (Vcs-*): Update to anonscm.debian.org. * debian/copyright - Sync Debian mantainers with debian/copyright. - (Comment): New. Move extra information here. * debian/debian-vars.mk - Delete. No longer needed. * debian/rules - Add install variables form debian-vars.mk.

    2012-03-23 - Jari Aalto <jari.aalto@cante.net> lwm (1.2.2-4) unstable; urgency=low * debian/control - (Build-Depends): Rm dpkg-dev; not needed with debhelper 9. - (Standards-Version): Update to 3.9.3.1. * debian/copyright - Update to format 1.0. * debian/rules - Enable all hardening flags. - Use DEB_*_MAINT_* variables.

    2012-02-13 - Jari Aalto <jari.aalto@cante.net> lwm (1.2.2-3) unstable; urgency=low * debian/compat - Update to 9 * debian/control - (Build-Depends): update to debhelper 9, dpkg-dev 1.16.1. - (Standards-Version): Update to 3.9.2. * debian/copyright - Update to DEP5. * debian/patches - (20): Fix code for gcc hardened format specifiers. * debian/rules - Use hardened CFLAGS. http://wiki.debian.org/ReleaseGoals/SecurityHardeningBuildFlags

    2010-10-12 - Jari Aalto <jari.aalto@cante.net> lwm (1.2.2-2) unstable; urgency=low * debian/compat - Update to 8. * debian/control - (Build-Depends): update to debhelper 8. - (Standards-Version): Update to 3.9.1. * debian/patches - (40): New. Increase target area for close box. Patch thanks to Joey Hess <joeyh@debian.org> (Closes: #453170). * debian/rules - Simplify rules. - (override_dh_installwm): New. - (override_dh_auto_install): New. - (install): Delete.

    2010-03-20 - Jari Aalto <jari.aalto@cante.net> lwm (1.2.2-1) unstable; urgency=low * New upstream release. * debian/copyright - (Upstream Authors): add note about invalid email. * debian/rules: - (binary): remove binary-indep.

    2010-03-09 - Jari Aalto <jari.aalto@cante.net> lwm (1.2.1-2) unstable; urgency=low * New maintainer (Closes: #572506). - Move to packaging format "3.0 (quilt)". - ACK NMU (Closes: #537321). * debian/clean - New file. * debian/compat: - Update to 7. * debian/control - (Build-Depends): update to debhelper 7.1. - (Description): use neutral tone (Closes: #439572). - (Depends): add ${misc:Depends}, add xterm etc. before virtual x-terminal-emulator. - (Homepage): update to Freshmeat. - (Standards-Version): update to 3.8.4. - (Suggests): new field. * debian/copyright - Update layout. * debian/debian-vars.mk - New file. * debian/lwm.desktop - New file (Closes: #330055). * debian/patches - Convert inline changes to patches. - (Number 05): Link with ICE library (FTBFS minor; Closes: #555571). * debian/rules - Update to dh(1). - (install): Define CC, otherwise the build fails under pbuilder. * debian/source/format - New file. * debian/watch - New file.

    2009-07-16 - Ansgar Burchardt <ansgar@43-1.org> lwm (1.2.1-1.2) unstable; urgency=low * Non-maintainer upload. * Build-depend on xutils-dev instead of xutils for xmkmf (Closes: #485209). * Build-depend on x11proto-core-dev instead of x-dev (Closes: #515382). * debian/rules: Use $(MAKE) distclean instead of $(MAKE) clean, do not ignore errors. * Set debhelper compat version to 5. * Install man page as "lwm.1.gz". * Mention copyright holder and years of copyright in debian/copyright. * debian/control: Add Homepage field. * debian/control: Bump Standards-Version to 3.8.2.

    Advertisement
    Advertisement