luajit_2.0.3+dfsg-3_amd64.deb


Advertisement

Description

luajit - Just in time compiler for Lua programming language version 5.1

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: luajit
Package version: 2.0.3+dfsg
Package release: 3
Package architecture: amd64
Package type: deb
Installed size: 476 B
Download size: 199.95 KB
Official Mirror: ftp.br.debian.org
LuaJIT implements the full set of language features defined by Lua 5.1. The virtual machine (VM) is API- and ABI-compatible to the standard Lua interpreter and can be deployed as a drop-in replacement. This package contains the standalone interpreter/jitter that can be used as a replacement for the standard lua5.1 interpreter.

Alternatives

    Download

    Source package: luajit

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install luajit deb package:
      # sudo apt-get install luajit

    Files

    • /usr/bin/luajit
    • /usr/bin/luajit-2.0.3
    • /usr/share/doc/luajit/changelog.Debian.gz
    • /usr/share/doc/luajit/copyright
    • /usr/share/man/man1/luajit.1.gz

    Changelog

    2014-04-25 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.3+dfsg-3) unstable; urgency=medium * Fix FTBFS when /sbin is not in $PATH (Closes: 744917)

    2014-04-08 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.3+dfsg-2) unstable; urgency=medium * Fix multilib value in .pc file (Closes: #743762)

    2014-03-13 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.3+dfsg-1) unstable; urgency=medium * New upstream release * All patches disabled: integrated in the upstream makefile

    2014-02-12 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.2+dfsg-3) unstable; urgency=medium * Add powerpcspe architecture for the -dev package (Closes: #734700)

    2013-09-18 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.2+dfsg-2) unstable; urgency=low * Fix .pc to spit -L/usr/lib/$DEB_HOST_MULTIARCH * Fix .pc to spit multiarch aware INSTALL_CMOD * Add /usr/lib/$DEB_HOST_MULTIARCH/lua/jit/ to the paths luajit will look at to find .lua files. Meant to be used for luajit specific files.

    2013-06-09 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.2+dfsg-1) unstable; urgency=low * New upstream release

    2013-05-20 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.1+hotfix1+dfsg-1) unstable; urgency=low * New upsream release * Packaging moved to git

    2012-11-03 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.0+dfsg-1) unstable; urgency=low * New upstream release

    2012-04-08 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.0~rc1+dfsg-1) experimental; urgency=low * New upstream release adding support for mips, mipsel, powerpcspe and armhf (Closes: #634244) * libluajit-5.1-common made Multi-Arch: foreign (Closes: #691657)

    2012-02-04 - Enrico Tassi <gareuselesinge@debian.org> luajit (2.0.0~beta9+dfsg-2) unstable; urgency=low * Added patch beta9_hotfix1 * Update copyright file to adhere to DEP5

    Advertisement
    Advertisement