lua-socket_3.0~rc1-3_amd64.deb


Advertisement

Description

lua-socket - TCP/UDP socket library for the Lua language

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name lua-socket
Package version 3.0~rc1
Package release 3
Package architecture amd64
Package type deb
Installed size 423 B
Download size 55.77 KB
Official Mirror ftp.br.debian.org
Luasocket provides a TCP/UDP socket library for the Lua language
Also provided are HTTP and SMTP implementations, a simple
FTP implementation and some URL parsing functions.
Luasocket supports blocking and non-blocking sockets
and also provides a select() interface to the language.

Alternatives

Package Version Architecture Repository
lua-socket_3.0~rc1-3_i386.deb 3.0~rc1 i386 Debian Main
lua-socket - - -

Requires

Name Value
libc6 >= 2.15
multiarch-support -

Provides

Name Value
lua5.1-socket -
lua5.2-socket -

Download

Type URL
Binary Package lua-socket_3.0~rc1-3_amd64.deb
Source Package luasocket

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-socket deb package:
    # sudo apt-get install lua-socket

Files

Path
/usr/lib/x86_64-linux-gnu/liblua5.1-mime.so.2
/usr/lib/x86_64-linux-gnu/liblua5.1-mime.so.2.0.0
/usr/lib/x86_64-linux-gnu/liblua5.1-socket-serial.so.0
/usr/lib/x86_64-linux-gnu/liblua5.1-socket-serial.so.0.0.0
/usr/lib/x86_64-linux-gnu/liblua5.1-socket-unix.so.2
/usr/lib/x86_64-linux-gnu/liblua5.1-socket-unix.so.2.0.0
/usr/lib/x86_64-linux-gnu/liblua5.1-socket.so.2
/usr/lib/x86_64-linux-gnu/liblua5.1-socket.so.2.0.0
/usr/lib/x86_64-linux-gnu/liblua5.2-mime.so.2
/usr/lib/x86_64-linux-gnu/liblua5.2-mime.so.2.0.0
/usr/lib/x86_64-linux-gnu/liblua5.2-socket-serial.so.0
/usr/lib/x86_64-linux-gnu/liblua5.2-socket-serial.so.0.0.0
/usr/lib/x86_64-linux-gnu/liblua5.2-socket-unix.so.2
/usr/lib/x86_64-linux-gnu/liblua5.2-socket-unix.so.2.0.0
/usr/lib/x86_64-linux-gnu/liblua5.2-socket.so.2
/usr/lib/x86_64-linux-gnu/liblua5.2-socket.so.2.0.0
/usr/lib/x86_64-linux-gnu/lua/5.1/mime/core.so
/usr/lib/x86_64-linux-gnu/lua/5.1/socket/core.so
/usr/lib/x86_64-linux-gnu/lua/5.1/socket/serial.so
/usr/lib/x86_64-linux-gnu/lua/5.1/socket/unix.so
/usr/lib/x86_64-linux-gnu/lua/5.2/mime/core.so
/usr/lib/x86_64-linux-gnu/lua/5.2/socket/core.so
/usr/lib/x86_64-linux-gnu/lua/5.2/socket/serial.so
/usr/lib/x86_64-linux-gnu/lua/5.2/socket/unix.so
/usr/share/doc/lua-socket/changelog.Debian.gz
/usr/share/doc/lua-socket/copyright
/usr/share/lua/5.1/ltn12.lua
/usr/share/lua/5.1/mime.lua
/usr/share/lua/5.1/socket.lua
/usr/share/lua/5.1/socket/ftp.lua
/usr/share/lua/5.1/socket/headers.lua
/usr/share/lua/5.1/socket/http.lua
/usr/share/lua/5.1/socket/mbox.lua
/usr/share/lua/5.1/socket/smtp.lua
/usr/share/lua/5.1/socket/tp.lua
/usr/share/lua/5.1/socket/url.lua
/usr/share/lua/5.2/ltn12.lua
/usr/share/lua/5.2/mime.lua
/usr/share/lua/5.2/socket.lua
/usr/share/lua/5.2/socket/ftp.lua
/usr/share/lua/5.2/socket/headers.lua
/usr/share/lua/5.2/socket/http.lua
/usr/share/lua/5.2/socket/mbox.lua
/usr/share/lua/5.2/socket/smtp.lua
/usr/share/lua/5.2/socket/tp.lua
/usr/share/lua/5.2/socket/url.lua

Changelog

2013-08-12 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (3.0~rc1-3) unstable; urgency=low
* Ship tp.lua and headers.lua (Closes: #719472)
2013-08-09 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (3.0~rc1-2) unstable; urgency=low
* Uploading to unstable 
* patch: export timeout_markstart symbol (needed by lua-sec) 
2012-05-04 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (3.0~rc1-1) experimental; urgency=low
* New upstream release with Lua 5.2 support and IPv6 support
(Closes: #562163)
* Remove patch luaopen_socketunix (merged upstream)
* Remove wheezy transitional packages
* Add luasocket serial module to the package
* Clean up the rules file using the features of dh-lua >= 17
* Packaging moved to git 
2012-05-04 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (2.0.2-8) unstable; urgency=low
* Upload to unstable
* cleanup dh-lua conf files 
2012-05-02 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (2.0.2-7) experimental; urgency=low
* Bump standards-version to 3.9.3, no changes
* Switch to dh-lua and dh >= 8
* Remove packages: liblua50-socket-dev liblua50-socket2 that were
anyway broken and unusable
* Packages renamed according to the new lua policy
* Remove patches/build, no more needed  
2011-07-21 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (2.0.2-6) unstable; urgency=low
* source format 3.0 (quilt)
2011-07-20 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (2.0.2-5) unstable; urgency=low
* Multi-Arch support (lua5.1 only, build-depend lua5.1-policy >= 32)
2009-07-21 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (2.0.2-4) unstable; urgency=low
* added patch to hide internal symbols, kudos to Stefan B├╝hler 
(Closes: #537049)
* added ${misc:Depends} to Depends:
* bumped standards-version to 3.8.2, no changes were needed
2007-12-27 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (2.0.2-3) unstable; urgency=low
* Renamed luasocket-doc.docs to liblua-socket-doc.docs so that
documentation is ipart of the package (Closes: #457891)
* Added Vcs-Browser and removed XS-X- from Vcs-Svn
* Bumped Standards-Version to 3.7.3
* Placed -dev and -doc packages in the right sections
* Added documentation to every dpatch patch
2007-11-11 - Enrico Tassi <gareuselesinge@debian.org>
luasocket (2.0.2-2) unstable; urgency=low
* Renamed -doc package and added a Suggest field in control file
(Closes: #449560)

See Also

Package Description
lua-sql-doc_2.3.0-4_all.deb luasql documentation
lua-sql-mysql-dev_2.3.0-4_amd64.deb luasql development files for the Lua language
lua-sql-mysql_2.3.0-4_amd64.deb luasql library for the Lua language
lua-sql-postgres-dev_2.3.0-4_amd64.deb luasql development files for the Lua language
lua-sql-postgres_2.3.0-4_amd64.deb luasql library for the Lua language
lua-sql-sqlite3-dev_2.3.0-4_amd64.deb luasql development files for the Lua language
lua-sql-sqlite3_2.3.0-4_amd64.deb luasql library for the Lua language
lua-svn-dev_0.4.0-9_amd64.deb Development files for the Subversion library for the Lua language
lua-svn_0.4.0-9_amd64.deb Subversion library for the Lua language
lua-term-dev_0.03.20140426.g1ba9a8e-1_amd64.deb Lua module for manipulating a terminal
lua-term_0.03.20140426.g1ba9a8e-1_amd64.deb Lua module for manipulating a terminal
lua-unit_3.0-1_all.deb Lua unit testing framework
lua-uri-dev_0.1+20130926+git14fa255d-1_amd64.deb examples and test files for lua-uri
lua-uri_0.1+20130926+git14fa255d-1_amd64.deb pure Lua library to normalize and validate URIs/URLs
lua-wsapi-doc_1.6.0-2_all.deb wsapi documentation files for the Lua language
Advertisement
Advertisement