lua-posix_31-2_amd64.deb


Advertisement

Description

lua-posix - posix library for the Lua language

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: lua-posix
Package version: 31
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 258 B
Download size: 58.71 KB
Official Mirror: ftp.br.debian.org
This package contains the Lua posix library, that includes some posix functions like fork, chmod, wait, sleep and kill.

Alternatives

Provides

  • lua5.1-posix
  • lua5.2-posix

    Download

    Binary package: lua-posix_31-2_amd64.deb
    Source package: lua-posix

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install lua-posix deb package:
      # sudo apt-get install lua-posix

    Files

    • /usr/lib/x86_64-linux-gnu/liblua5.1-posix.so.1
    • /usr/lib/x86_64-linux-gnu/liblua5.1-posix.so.1.0.0
    • /usr/lib/x86_64-linux-gnu/liblua5.2-posix.so.1
    • /usr/lib/x86_64-linux-gnu/liblua5.2-posix.so.1.0.0
    • /usr/lib/x86_64-linux-gnu/lua/5.1/posix_c.so
    • /usr/lib/x86_64-linux-gnu/lua/5.2/posix_c.so
    • /usr/share/doc/lua-posix/changelog.Debian.gz
    • /usr/share/doc/lua-posix/changelog.gz
    • /usr/share/doc/lua-posix/copyright
    • /usr/share/lua/5.1/posix.lua
    • /usr/share/lua/5.2/posix.lua

    Changelog

    2014-04-08 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (31-2) unstable; urgency=medium * Sort examples alphabetically when generating the doc (Closes: #743920)

    2014-04-07 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (31-1) unstable; urgency=medium * New upstream release * Fix compilation with lua-doc >= 1.4 (Closes: #742869), thanks Colin Watson * Use autoreconf (Closes: #742870), thanks Colin Watson * Drop patch 0002-Fix-compilation-on-kfreebsd.patch (sort of applied upstream)

    2014-01-21 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (29-7) unstable; urgency=medium * Build-depend on lua-discount (Closes: #735976)

    2014-01-17 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (29-6) unstable; urgency=medium * Fix FTBFS adding -I for ncursesws (Closes: #735759)

    2013-08-26 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (29-5) unstable; urgency=low * Revert to our Hurd and kFreeBSD patch

    2013-08-26 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (29-4) unstable; urgency=low * Use upstream's patch to support Hurd * Disable kFreeBSD patch, should be fixed upstream

    2013-08-15 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (29-3) unstable; urgency=low * Ship the doc built using lua-doc

    2013-06-30 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (29-2) unstable; urgency=low * Revamp patch to fix build on hurd * Patch to fix build on kfreebsd

    2012-07-07 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (29-1) unstable; urgency=low * New upstream release * lua5.2-compat.patch not needed anymore, removed * Transitional packages for wheezy removed

    2012-07-07 - Enrico Tassi <gareuselesinge@debian.org> lua-posix (5.1.20-2) unstable; urgency=low * Build-Depend on libncursesw5-dev to be able to handle UTF-8 strings

    Advertisement
    Advertisement