lua-orbit_2.2.1+dfsg-1_all.deb


Advertisement

Description

lua-orbit - MVC web framework for Lua

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: lua-orbit
Package version: 2.2.1+dfsg
Package release: 1
Package architecture: all
Package type: deb
Installed size: 295 B
Download size: 65.12 KB
Official Mirror: ftp.br.debian.org
Orbit is a library for developing web applications according to the Model-View-Controller paradigm in Lua. Orbit also includes a basic OR mapper that currently only works with lua-sql SQLite3 driver. This package also contains the documentation and some sample applications for the orbit MVC framework.

Alternatives

Provides

  • lua5.1-orbit

    Download

    Source package: lua-orbit

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install lua-orbit deb package:
      # sudo apt-get install lua-orbit

    Files

    • /usr/share/doc/lua-orbit/changelog.Debian.gz
    • /usr/share/doc/lua-orbit/copyright
    • /usr/share/doc/lua-orbit/blog/.htaccess
    • /usr/share/doc/lua-orbit/blog/blog.lua
    • /usr/share/doc/lua-orbit/blog/blog.ws
    • /usr/share/doc/lua-orbit/blog/blog_config.lua
    • /usr/share/doc/lua-orbit/blog/blog_schema.mysql
    • /usr/share/doc/lua-orbit/blog/blog_schema.sql
    • /usr/share/doc/lua-orbit/blog/head.jpg
    • /usr/share/doc/lua-orbit/blog/markdown.lua
    • /usr/share/doc/lua-orbit/blog/random_text.lua
    • /usr/share/doc/lua-orbit/blog/style.css
    • /usr/share/doc/lua-orbit/doc/us/example.html
    • /usr/share/doc/lua-orbit/doc/us/index.html
    • /usr/share/doc/lua-orbit/doc/us/license.html
    • /usr/share/doc/lua-orbit/doc/us/makedoc.lua
    • /usr/share/doc/lua-orbit/doc/us/markdown.lua
    • /usr/share/doc/lua-orbit/doc/us/orbit.png
    • /usr/share/doc/lua-orbit/doc/us/pages.html
    • /usr/share/doc/lua-orbit/doc/us/reference.html
    • /usr/share/doc/lua-orbit/hello/hello.lua
    • /usr/share/doc/lua-orbit/hello/hello.ws
    • /usr/share/doc/lua-orbit/songs/songs.cgi
    • /usr/share/doc/lua-orbit/songs/songs.fcgi
    • /usr/share/doc/lua-orbit/songs/songs.lua
    • /usr/share/doc/lua-orbit/songs/songs.ws
    • /usr/share/lua/5.1/orbit.lua
    • /usr/share/lua/5.1/orbit/cache.lua
    • /usr/share/lua/5.1/orbit/model.lua
    • /usr/share/lua/5.1/orbit/ophandler.lua
    • /usr/share/lua/5.1/orbit/pages.lua
    • /usr/share/lua/5.1/orbit/routes.lua

    Changelog

    2014-02-02 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.2.1+dfsg-1) unstable; urgency=medium * New upstream release * Clarify license name in debian/copyright

    2013-08-13 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.2.0+gita6fb46e+dfsg-1) unstable; urgency=low * Clean up orig tarballs to comply to DFSG

    2012-05-01 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.2.0+gita6fb46e-1) unstable; urgency=low * New upstream snapshot fix bugs w.r.t. lua-lpeg

    2012-05-01 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.2.0+dfsg1-1) unstable; urgency=low * Add jquery-1.2.3.js to the tarball and mention it in README.source and in copyright

    2012-04-30 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.2.0+dfsg-1) unstable; urgency=low * New upstream release * Update watch file * Switch to dh-lua * Packages renamed according to the new Lua policy * debian/compat set to 8

    2011-07-23 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.1.0+dfsg-3) unstable; urgency=low * source format 3.0 (quilt) * bumped standards-version to 3.9.2, no changes needed

    2009-11-19 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.1.0+dfsg-2) unstable; urgency=low * added conflicts/replaces in control (Closes: 557053)

    2009-11-17 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.1.0+dfsg-1) unstable; urgency=low * new upstream release * added README.source * bumped standards-version to 3.8.3, no changes * bumped API version to 1, since the new release alters the API * fixed watch file

    2009-07-21 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.0.2-3) unstable; urgency=low * bumped standards-version to 3.8.2, no changes needed * build depend on lua5.1-policy-dev

    2009-03-27 - Enrico Tassi <gareuselesinge@debian.org> lua-orbit (2.0.2-2) unstable; urgency=low * depend over wsapi API/ABI version 1

    Advertisement
    Advertisement