lua-leg_0.1.3-1_all.deb


Advertisement

Description

lua-leg - Lua 5.1 grammar, with parsing and manipulation facilities

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: lua-leg
Package version: 0.1.3
Package release: 1
Package architecture: all
Package type: deb
Installed size: 78 B
Download size: 14.37 KB
Official Mirror: ftp.br.debian.org
This package contains leg, a Lua library exporting a complete Lua 5.1 grammar and a small API for user manipulation. It can be used to implement a macro preprocessor or any other task that needs to parse a .lua file.

Alternatives

Requires

Provides

  • lua5.1-leg

    Download

    Binary package: lua-leg_0.1.3-1_all.deb
    Source package: lua-leg

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install lua-leg deb package:
      # sudo apt-get install lua-leg

    Files

    • /usr/share/doc/lua-leg/changelog.Debian.gz
    • /usr/share/doc/lua-leg/copyright
    • /usr/share/lua/5.1/leg/grammar.lua
    • /usr/share/lua/5.1/leg/init.lua
    • /usr/share/lua/5.1/leg/parser.lua
    • /usr/share/lua/5.1/leg/scanner.lua

    Changelog

    2012-04-19 - Enrico Tassi <gareuselesinge@debian.org> lua-leg (0.1.3-1) unstable; urgency=low * New upstream release * Add patch to scanner.lua to avoid empty loop (Closes: #719379) * Packaging moved to git * Remove transitional packages

    2012-04-19 - Enrico Tassi <gareuselesinge@debian.org> lua-leg (0.1.2-8) unstable; urgency=low * Clean up debian/rules * Build-depend on dh-lua >= 12 * Copyright file updated to format 1.0

    2012-04-09 - Enrico Tassi <gareuselesinge@debian.org> lua-leg (0.1.2-7) unstable; urgency=low * Switch to dh-lua * Bumped standards-version to 3.9.3, no changes needed * Packages renamed according to the new lua policy

    2011-07-22 - Enrico Tassi <gareuselesinge@debian.org> lua-leg (0.1.2-6) unstable; urgency=low * source format 3.0 (quilt) * bumped standards-version to 3.9.2, no changes needed

    2009-07-21 - Enrico Tassi <gareuselesinge@debian.org> lua-leg (0.1.2-5) unstable; urgency=low * bumped standards-version to 3.8.2 * build-depend on lua5.1-policy-dev >= 22

    2009-03-23 - Enrico Tassi <gareuselesinge@debian.org> lua-leg (0.1.2-4) unstable; urgency=low * rebuild against liblua5.1-lpeg2 * fixed lua -> Lua in control * bumped standards-version to 3.8.1, no changes needed * added misc:Depends to Depends since I'm using debhelpers

    2008-03-07 - Enrico Tassi <gareuselesinge@debian.org> lua-leg (0.1.2-3) unstable; urgency=low * depend on liblua5.1-lpeg1

    2007-12-22 - Enrico Tassi <gareuselesinge@debian.org> lua-leg (0.1.2-2) unstable; urgency=low * fixed watch file * better package description

    2007-12-19 - Enrico Tassi <gareuselesinge@debian.org> lua-leg (0.1.2-1) unstable; urgency=low * Initial release. (Closes: #457198)

    Advertisement
    Advertisement