lua-json_1.3.2-1_all.deb


Advertisement

Description

lua-json - JSON decoder/encoder for Lua

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name lua-json
Package version 1.3.2
Package release 1
Package architecture all
Package type deb
Installed size 137 B
Download size 26.43 KB
Official Mirror ftp.br.debian.org
LuaJSON is a customizable JSON decoder/encoder using LPEG for parsing.

Alternatives

Package Version Architecture Repository
lua-json_1.3.2-1_all.deb 1.3.2 all Debian Main
lua-json - - -

Requires

Name Value
lua-lpeg -

Provides

Name Value
liblua5.1-json -
lua5.1-json -
lua5.2-json -

Replaces

Name Value
liblua5.1-json << 1.2.2-2~

Download

Type URL
Binary Package lua-json_1.3.2-1_all.deb
Source Package lua-json

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-json deb package:
    # sudo apt-get install lua-json

Files

Path
/usr/share/doc/lua-json/LuaJSON.txt.gz
/usr/share/doc/lua-json/README
/usr/share/doc/lua-json/ReleaseNotes-0.10.txt.gz
/usr/share/doc/lua-json/ReleaseNotes-0.9.1.txt
/usr/share/doc/lua-json/ReleaseNotes-0.9.txt
/usr/share/doc/lua-json/ReleaseNotes-1.0.1.txt
/usr/share/doc/lua-json/ReleaseNotes-1.0.2.txt
/usr/share/doc/lua-json/ReleaseNotes-1.0.3.txt
/usr/share/doc/lua-json/ReleaseNotes-1.0.txt
/usr/share/doc/lua-json/ReleaseNotes-1.1.1.txt
/usr/share/doc/lua-json/ReleaseNotes-1.1.2.txt
/usr/share/doc/lua-json/ReleaseNotes-1.1.txt
/usr/share/doc/lua-json/ReleaseNotes-1.2.1.txt
/usr/share/doc/lua-json/ReleaseNotes-1.2.2.txt
/usr/share/doc/lua-json/ReleaseNotes-1.2.txt
/usr/share/doc/lua-json/ReleaseNotes-1.3.1.txt
/usr/share/doc/lua-json/ReleaseNotes-1.3.2.txt
/usr/share/doc/lua-json/ReleaseNotes-1.3.txt
/usr/share/doc/lua-json/changelog.Debian.gz
/usr/share/doc/lua-json/copyright
/usr/share/lua/5.1/json.lua
/usr/share/lua/5.1/json/decode.lua
/usr/share/lua/5.1/json/encode.lua
/usr/share/lua/5.1/json/util.lua
/usr/share/lua/5.1/json/decode/composite.lua
/usr/share/lua/5.1/json/decode/number.lua
/usr/share/lua/5.1/json/decode/others.lua
/usr/share/lua/5.1/json/decode/state.lua
/usr/share/lua/5.1/json/decode/strings.lua
/usr/share/lua/5.1/json/decode/util.lua
/usr/share/lua/5.1/json/encode/array.lua
/usr/share/lua/5.1/json/encode/calls.lua
/usr/share/lua/5.1/json/encode/number.lua
/usr/share/lua/5.1/json/encode/object.lua
/usr/share/lua/5.1/json/encode/others.lua
/usr/share/lua/5.1/json/encode/output.lua
/usr/share/lua/5.1/json/encode/output_utility.lua
/usr/share/lua/5.1/json/encode/strings.lua
/usr/share/lua/5.2/json.lua
/usr/share/lua/5.2/json/decode.lua
/usr/share/lua/5.2/json/encode.lua
/usr/share/lua/5.2/json/util.lua
/usr/share/lua/5.2/json/decode/composite.lua
/usr/share/lua/5.2/json/decode/number.lua
/usr/share/lua/5.2/json/decode/others.lua
/usr/share/lua/5.2/json/decode/state.lua
/usr/share/lua/5.2/json/decode/strings.lua
/usr/share/lua/5.2/json/decode/util.lua
/usr/share/lua/5.2/json/encode/array.lua
/usr/share/lua/5.2/json/encode/calls.lua
/usr/share/lua/5.2/json/encode/number.lua
/usr/share/lua/5.2/json/encode/object.lua
/usr/share/lua/5.2/json/encode/others.lua
/usr/share/lua/5.2/json/encode/output.lua
/usr/share/lua/5.2/json/encode/output_utility.lua
/usr/share/lua/5.2/json/encode/strings.lua

Changelog

2014-11-08 - Bernd Zeimetz <bzed@debian.org>
lua-json (1.3.2-1) unstable; urgency=medium
* [25eb09ad] Merge branch 'upstream'
Closes: #719519
Merging upstream version 1.3.2 which is a bugfix release
to make luajson work with lpeg again. It also sets _ENV to nil using local
_ENV = nil to avoid global writing.
Documentation and tests were updated accordingly and enhanced.
* [b2bdecd4] Remove transitional package.
2014-02-13 - Bernd Zeimetz <bzed@debian.org>
lua-json (1.3.1-1) unstable; urgency=medium
* [3d18e710] Merge tag 'upstream/1.3.1'
Upstream version 1.3.1
2012-05-06 - Bernd Zeimetz <bzed@debian.org>
lua-json (1.3-1) unstable; urgency=low
* [e90dafec] Changes by Enrico Tassi - thanks for the patch!
* Switch to dh-lua
* Package renamed according to the new Lua policy
* [2f427b4d] Make debian/watch work again.
* [6d097344] Merge tag 'upstream/1.3'
Upstream version 1.3
* [14787062] Enable support for Lua5.2
* [1f053906] Use 3.0 (quilt) format as we have symlinks in the debian folder.
2011-07-28 - Bernd Zeimetz <bzed@debian.org>
lua-json (1.2.2-1) unstable; urgency=low
* [bb887c07] Merge commit 'upstream/1.2.2'
2011-02-10 - Bernd Zeimetz <bzed@debian.org>
lua-json (1.2.1-1) unstable; urgency=low
* [9b2b474a] Fixing filenamemangle in watch file.
* [cdacecf3] Merge branch 'upstream'
2010-05-27 - Bernd Zeimetz <bzed@debian.org>
lua-json (1.1.1-1) unstable; urgency=low
* New upstream version.
* [f05a443c] Merge branch 'upstream'
* [e296fdd1] Bumping  Standards-Version to 3.8.4. No changes needed.
* [0b8d7f9f] Updating watch file.
* [853dd452] src directory was renamed to lua, update debian/install.
2009-05-13 - Bernd Zeimetz <bzed@debian.org>
lua-json (0.10-2) unstable; urgency=low
* [9c816ef8] Depend on liblua5.1-lpeg2 or liblua5.1-lpeg1
(Closes: #528548).
2008-12-09 - Bernd Zeimetz <bzed@debian.org>
lua-json (0.10-1) unstable; urgency=low
* Initial release.

See Also

Package Description
lua-ldap-dev_1.1.0-1-geeac494-6_amd64.deb LDAP development files for the Lua language
lua-ldap_1.1.0-1-geeac494-6_amd64.deb LDAP library for the Lua language
lua-ldoc_1.4.2-1_all.deb LuaDoc-compatible documentation generation system
lua-leg-dev_0.1.3-1_all.deb Leg development files for the Lua language
lua-leg_0.1.3-1_all.deb Lua 5.1 grammar, with parsing and manipulation facilities
lua-lemock-dev_0.6-1_all.deb LeMock (Lua Easy Mock) for unit test
lua-lemock_0.6-1_all.deb LeMock (Lua Easy Mock) for unit test
lua-lgi-dev_0.8.0-2_amd64.deb lgi development files for the Lua language
lua-lgi_0.8.0-2_amd64.deb Lua bridge to GObject based libraries
lua-logging_1.3.0-1_all.deb Logging library for the Lua language
lua-lpeg-dev_0.12-1_amd64.deb LPeg development files for the Lua language
lua-lpeg_0.12-1_amd64.deb LPeg library for the Lua language
lua-lpty-dev_1.0.1-1_amd64.deb PTY library for the Lua language - development files
lua-lpty_1.0.1-1_amd64.deb PTY library for the Lua language
lua-luxio0_8-1_amd64.deb Posix bindings for Lua
Advertisement
Advertisement