lua-dbi-postgresql_0.5.hg5ba1dd988961-2_amd64.deb


Advertisement

Description

lua-dbi-postgresql - DBI library for the Lua language, PostgreSQL backend

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: lua-dbi-postgresql
Package version: 0.5.hg5ba1dd988961
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 61 B
Download size: 9.01 KB
Official Mirror: ftp.br.debian.org
Lua DBI is a database interface library for Lua. It is designed to provide a RDBMS agnostic API for handling database operations. LuaDBI also provides support for prepared statement handles, placeholders and bind parameters for all database operations. This package contains the PostgreSQL backend. Lua DBI is a better alternative to lua-sql since it supports prepared statements.

Alternatives

Provides

  • lua5.1-dbi-postgresql

    Download

    Source package: lua-dbi

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install lua-dbi-postgresql deb package:
      # sudo apt-get install lua-dbi-postgresql

    Files

    • /usr/lib/x86_64-linux-gnu/liblua5.1-dbi-postgresql.so.0
    • /usr/lib/x86_64-linux-gnu/liblua5.1-dbi-postgresql.so.0.0.0
    • /usr/lib/x86_64-linux-gnu/lua/5.1/dbdpostgresql.so
    • /usr/share/doc/lua-dbi-postgresql/changelog.Debian.gz
    • /usr/share/doc/lua-dbi-postgresql/copyright

    Changelog

    2013-09-18 - Enrico Tassi <gareuselesinge@debian.org> lua-dbi (0.5.hg5ba1dd988961-2) unstable; urgency=low * Build-depend on postgresql-server-dev-all

    2013-08-10 - Enrico Tassi <gareuselesinge@debian.org> lua-dbi (0.5.hg5ba1dd988961-1) unstable; urgency=low * New upstream snapshot fixing mysql bug * Packaging moved to git

    2012-06-30 - Enrico Tassi <gareuselesinge@debian.org> lua-dbi (0.5+svn78-5~dbg4matthew1) unstable; urgency=low * debian/compat set to 9 * new package lua-dbi-mysql-dbg * new package lua-dbi-sqlite3-dbg * new package lua-dbi-postgresql-dbg

    2012-06-29 - Enrico Tassi <gareuselesinge@debian.org> lua-dbi (0.5+svn78-4) unstable; urgency=low * Add patch preventing an off by one in mysql driver: http://code.matthewwild.co.uk/luadbi/rev/5ba1dd988961

    2012-04-30 - Enrico Tassi <gareuselesinge@debian.org> lua-dbi (0.5+svn78-3) unstable; urgency=low * Add path: mysql-memory-consumption from http://code.matthewwild.co.uk/luadbi/rev/7c968f66bccd

    2012-04-09 - Enrico Tassi <gareuselesinge@debian.org> lua-dbi (0.5+svn78-2) unstable; urgency=low * Ship -dev packages

    2012-04-09 - Enrico Tassi <gareuselesinge@debian.org> lua-dbi (0.5+svn78-1) unstable; urgency=low * Initial release. (Closes: #668173)

    Advertisement
    Advertisement