lua-copas_1.2.0-1_all.deb


Advertisement

Description

lua-copas - Copas is a dispatcher of concurrent TCP/IP requests

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name lua-copas
Package version 1.2.0
Package release 1
Package architecture all
Package type deb
Installed size 99 B
Download size 23.75 KB
Official Mirror ftp.br.debian.org
Copas is a dispatcher of concurrent TCP/IP requests based on corutines.
A server registered with Copas should provide a handler for requests and use
Copas socket functions to send the response. Copas loops through requests and
invokes the corresponding handlers.
This package also contains the documentation of copas.

Alternatives

Package Version Architecture Repository
lua-copas_1.2.0-1_all.deb 1.2.0 all Debian Main
lua-copas - - -

Requires

Name Value
lua-coxpcall -
lua-socket -

Provides

Name Value
lua5.1-copas -
lua5.2-copas -

Download

Type URL
Binary Package lua-copas_1.2.0-1_all.deb
Source Package lua-copas

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-copas deb package:
    # sudo apt-get install lua-copas

Files

Path
/usr/share/doc/lua-copas/changelog.Debian.gz
/usr/share/doc/lua-copas/copyright
/usr/share/doc/lua-copas/us/copas.png
/usr/share/doc/lua-copas/us/index.html
/usr/share/doc/lua-copas/us/license.html
/usr/share/doc/lua-copas/us/manual.html
/usr/share/doc/lua-copas/us/reference.html
/usr/share/lua/5.1/copas.lua
/usr/share/lua/5.2/copas.lua

Changelog

2012-05-11 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.2.0-1) unstable; urgency=low
* New upstream release supporting lua 5.2
* Packaging moved to git
* Transitional packages removed
2012-05-03 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.1.6-5) unstable; urgency=low
* Update depends on liblua5.1-socket2 -> lua-socket 
2012-05-03 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.1.6-4) unstable; urgency=low
* Fix lua module name
2012-05-03 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.1.6-3) unstable; urgency=low
* Fixed dependency of transitional package liblua5.1-copas-dev
2012-05-02 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.1.6-2) unstable; urgency=low
* Package description fixed, thanks Tollef Fog Heen for spotting it.
(Closes: #671145) 
2012-04-30 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.1.6-1) unstable; urgency=low
* New upstream release
* Switch to dh-lua
* Packages renames according to the new lua policy
* Copyright format 1.0
* debian/comapt set to 8
* bumped standards version to 3.9.3 
2011-07-22 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.1.5-3) unstable; urgency=low
* source format 3.0 (quilt)
* bumped standards version to 3.9.2, no changes
2009-07-21 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.1.5-2) unstable; urgency=low
* build-depend on lua5.1-policy-dev >= 22
* bumped standards version to 3.8.2, no changes
2009-04-20 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.1.5-1) unstable; urgency=low
* New upstream bugfix release
2009-03-24 - Enrico Tassi <gareuselesinge@debian.org>
lua-copas (1.1.4-1) unstable; urgency=low
* new upstream bugfix release 
* bumped standards version to 3.8.1, no changes needed
* added ${misc:Depends} to Depends:

See Also

Package Description
lua-cosmo_13.01.30-2_all.deb Template library for the Lua language
lua-coxpcall_1.14.0-2_all.deb Protected function calls across coroutines for Lua
lua-curl-dev_0.3.0-9_amd64.deb libcURL development files for the Lua language
lua-curl_0.3.0-9_amd64.deb libcURL bindings for the Lua language
lua-curses-dev_31-2_amd64.deb curses development files for the Lua language
lua-curses_31-2_amd64.deb curses library for the Lua language
lua-cyrussasl-dev_1.0.0-6_amd64.deb Cyrus SASL development files for the Lua language
lua-cyrussasl_1.0.0-6_amd64.deb Cyrus SASL library for the Lua language
lua-dbi-common_0.5.hg5ba1dd988961-2_all.deb DBI library for the Lua language, common files
lua-dbi-mysql-dev_0.5.hg5ba1dd988961-2_amd64.deb DBI library for the Lua language, MySQL development files
lua-dbi-mysql_0.5.hg5ba1dd988961-2_amd64.deb DBI library for the Lua language, MySQL backend
lua-dbi-postgresql-dev_0.5.hg5ba1dd988961-2_amd64.deb DBI library for the Lua language, PostgreSQL development files
lua-dbi-postgresql_0.5.hg5ba1dd988961-2_amd64.deb DBI library for the Lua language, PostgreSQL backend
lua-dbi-sqlite3-dev_0.5.hg5ba1dd988961-2_amd64.deb DBI library for the Lua language, sqlite3 development files
lua-dbi-sqlite3_0.5.hg5ba1dd988961-2_amd64.deb DBI library for the Lua language, sqlite3 backend
Advertisement
Advertisement