lua-cgi_5.2~alpha2-1_all.deb


Advertisement

Description

lua-cgi - CGI library for the Lua language

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: lua-cgi
Package version: 5.2~alpha2
Package release: 1
Package architecture: all
Package type: deb
Installed size: 491 B
Download size: 103.97 KB
Official Mirror: ftp.br.debian.org
CGILua is a tool for creating dynamic Web pages and manipulating input data from Web forms. CGILua allows the separation of logic and data handling from the generation of pages, making it easy to develop web applications with Lua. CGILua requires a SAPI implementation to work. The lua-wsapi packages provides a few ready to use SAPI implementations. This package also contains the documentation for the Lua CGI library.

Alternatives

Provides

  • lua5.1-cgi

    Download

    Source package: lua-cgi

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install lua-cgi deb package:
      # sudo apt-get install lua-cgi

    Files

    • /usr/share/doc/lua-cgi/README.Debian
    • /usr/share/doc/lua-cgi/changelog.Debian.gz
    • /usr/share/doc/lua-cgi/copyright
    • /usr/share/doc/lua-cgi/doc/br/cgi-128.gif
    • /usr/share/doc/lua-cgi/doc/br/index.html
    • /usr/share/doc/lua-cgi/doc/br/libraries.html
    • /usr/share/doc/lua-cgi/doc/br/license.html
    • /usr/share/doc/lua-cgi/doc/br/manual.html
    • /usr/share/doc/lua-cgi/doc/br/reference.html
    • /usr/share/doc/lua-cgi/doc/br/sapi.html
    • /usr/share/doc/lua-cgi/doc/us/cgi-128.gif
    • /usr/share/doc/lua-cgi/doc/us/index.html
    • /usr/share/doc/lua-cgi/doc/us/libraries.html
    • /usr/share/doc/lua-cgi/doc/us/license.html
    • /usr/share/doc/lua-cgi/doc/us/manual.html
    • /usr/share/doc/lua-cgi/doc/us/reference.html
    • /usr/share/doc/lua-cgi/doc/us/sapi.html
    • /usr/share/doc/lua-cgi/examples/app.lua
    • /usr/share/doc/lua-cgi/examples/authentication_conf.lua
    • /usr/share/doc/lua-cgi/examples/check.lua
    • /usr/share/doc/lua-cgi/examples/index.lp
    • /usr/share/doc/lua-cgi/examples/login.lp
    • /usr/share/doc/lua-cgi/examples/test.lp.gz
    • /usr/share/doc/lua-cgi/examples/cgilua/config.lua
    • /usr/share/doc/lua-cgi/examples/css/doc.css
    • /usr/share/doc/lua-cgi/examples/img/keplerproject.gif
    • /usr/share/doc/lua-cgi/examples/img/test.jpg
    • /usr/share/doc/lua-cgi/examples/jquery/jquery-1.2.3.js
    • /usr/share/doc/lua-cgi/examples/jquery/jquery-1.2.3.min.js
    • /usr/share/doc/lua-cgi/launchers/cgilua.cgi
    • /usr/share/doc/lua-cgi/launchers/cgilua.fcgi
    • /usr/share/lua/5.1/cgilua.lua
    • /usr/share/lua/5.1/cgilua/authentication.lua
    • /usr/share/lua/5.1/cgilua/cookies.lua
    • /usr/share/lua/5.1/cgilua/dispatcher.lua
    • /usr/share/lua/5.1/cgilua/loader.lua
    • /usr/share/lua/5.1/cgilua/lp.lua
    • /usr/share/lua/5.1/cgilua/mime.lua
    • /usr/share/lua/5.1/cgilua/post.lua
    • /usr/share/lua/5.1/cgilua/readuntil.lua
    • /usr/share/lua/5.1/cgilua/serialize.lua
    • /usr/share/lua/5.1/cgilua/session.lua
    • /usr/share/lua/5.1/cgilua/urlcode.lua

    Changelog

    2012-05-11 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.2~alpha2-1) unstable; urgency=low * Packaging moved to git * Remove transitional packages * New upstream release working on lua5.2 too * Removing embedded sapi library, recommend lua-wsapi

    2012-05-01 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.1.4+dfsg-2) unstable; urgency=low * Update dependency on liblua5.1-socket2 -> lua-socket

    2012-05-01 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.1.4+dfsg-1) unstable; urgency=low * Ship the jquery file in the tarball, and use README.source to document it

    2012-05-01 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.1.4-2) unstable; urgency=low * Ship a non minimized version of jquery.js and mention it in the copyright

    2012-04-28 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.1.4-1) unstable; urgency=low * New upstream release * Switch to dh-lua * debian/compat set to 8 * bumped standards-version to 3.9.3, no changes needed * Packages renamed according to the new Lua policy

    2011-07-22 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.1.3-3) unstable; urgency=low * source format 3.0 (quilt) * bumped standards-version to 3.9.2, no changes needed

    2009-07-21 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.1.3-2) unstable; urgency=low * build depend on lua5.1-policy-dev >= 22 * bumped standards-version to 3.8.2, no changes needed

    2009-03-24 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.1.3-1) unstable; urgency=low * new upstream bugfix release * bumped standards-version to 3.8.1, no changes needed

    2008-05-21 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.1.2-1) unstable; urgency=low * new upstream release

    2008-04-19 - Enrico Tassi <gareuselesinge@debian.org> lua-cgi (5.1.2~rc1-1) unstable; urgency=low * new upstream release candidate * added a suggests on liblua5.1-wsapi0 * added README.Debian to the -dev package (was only in the non -dev) * updated standards to 3.7.3 * removed XS- from VCS-Svn control file field * added VCS-Browser field to the control file

    Advertisement
    Advertisement