lp-solve_5.5.0.13-7+b1_amd64.deb


Advertisement

Description

lp-solve - Solve (mixed integer) linear programming problems

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: lp-solve
Package version: 5.5.0.13
Package release: 7+b1
Package architecture: amd64
Package type: deb
Installed size: 667 B
Download size: 266.56 KB
Official Mirror: ftp.br.debian.org
The linear programming (LP) problem can be formulated as: Solve A.x >= V1, with V2.x maximal. A is a matrix, x is a vector of (nonnegative) variables, V1 is a vector called the right hand side, and V2 is a vector specifying the objective function. An integer linear programming (ILP) problem is an LP with the constraint that all the variables are integers. In a mixed integer linear programming (MILP) problem, some of the variables are integer and others are real. The program lp_solve solves LP, ILP, and MILP problems. It is slightly more general than suggested above, in that every row of A (specifying one constraint) can have its own (in)equality, <=, >= or =. The result specifies values for all variables. lp_solve uses the 'Simplex' algorithm and sparse matrix methods for pure LP problems. If one or more of the variables is declared integer, the Simplex algorithm is iterated with a branch and bound algorithm, until the desired optimal solution is found. lp_solve can read MPS format input files. Homepage http://www.geocities.com/lpsolve/

Alternatives

    Download

    Source package: lp-solve

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install lp-solve deb package:
      # sudo apt-get install lp-solve

    Files

    • /usr/bin/lp_solve
    • /usr/lib/lp_solve/liblpsolve55.so
    • /usr/share/doc/lp-solve/NEWS.Debian.gz
    • /usr/share/doc/lp-solve/README.Debian
    • /usr/share/doc/lp-solve/README.txt.gz
    • /usr/share/doc/lp-solve/changelog.Debian.amd64.gz
    • /usr/share/doc/lp-solve/changelog.Debian.gz
    • /usr/share/doc/lp-solve/copyright

    Changelog

    2009-12-03 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.13-7) unstable; urgency=low * move to "3.0 (quilt)" format; move downloaded docs into extra docs tarball and move change from 5.5.0.10-6 from only in .diff.gz (oops!) to proper patch * include headers needed for plugin libraries (closes: #555830), thanks Matthias Kümmerer * add ${misc:Depends} * remove debian/watch (closes: #529154)

    2009-06-10 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.13-6) unstable; urgency=low * build against suitesparse 3.4.0 (libcolamd2.7.1)

    2009-05-06 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.13-5) unstable; urgency=low * make liblpsolve55-dev depend on libsuitesparse-dev (closes: #524295)

    2009-02-22 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.13-4) unstable; urgency=low * rebuild with suitesparse 1:3.2.0-2 to only get a dep on libcolamd-3.2.0 * upload to unstable

    2009-01-26 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.13-3) experimental; urgency=low * build against suitesparse 3.2.0

    2008-12-28 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.13-2) experimental; urgency=low * add Homepage: (closes: #509917)

    2008-12-01 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.13-1) experimental; urgency=low * New upstream release (closes: #507462)

    2008-02-22 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.10-10) unstable; urgency=low * build against libsuitesparse-3.1.0

    2007-10-18 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.10-9) unstable; urgency=low * build liblpsolve55.so with -fPIC instead of -fpic and revert last -fpic change

    2007-09-11 - Rene Engelhard <rene@debian.org> lp-solve (5.5.0.10-8) unstable; urgency=low * also specify -fpic when linking liblpsolve55.so * run ccc using -e

    Advertisement
    Advertisement