lout_3.39-1_amd64.deb


Advertisement

Description

lout - Typesetting system, an alternative to (La)TeX

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name lout
Package version 3.39
Package release 1
Package architecture amd64
Package type deb
Installed size 1.58 KB
Download size 332.85 KB
Official Mirror ftp.br.debian.org
Lout is a document formatting system similar in style to LaTeX, i.e.
it works with mark-up files - plain text files containing commands to
control the formatting.
Lout offers a very full range of features, including
* PostScript, PDF, and plain text output
* optimal paragraph and page breaking
* automatic hyphenation
* PostScript EPS file inclusion and generation
* equation formatting, tables, diagrams
* rotation and scaling
* sorted indexes, bibliographic databases
* running headers and odd-even pages, automatic cross referencing
* multilingual documents including hyphenation (most European languages are
supported, including Russian),
* formatting of C/C++ programs.
Lout may be extended by writing definitions which are much simpler than
the equivalent troff or TeX macros.
Lout has several advantages over (La)TeX.  It is much smaller, and it is
much easier to understand how to do things in Lout (including writing
definitions) than in TeX or LaTeX.  Lout's PostScript output is very small
and clean.
However, it is much less widely used than (La)TeX, so there are
fewer add-on definition packages for Lout than for (La)TeX and fewer
local experts around to ask about problems.  You are unlikely to
find many Lout documents floating around the 'net.

Alternatives

Package Version Architecture Repository
lout_3.39-1_i386.deb 3.39 i386 Debian Main
lout - - -

Requires

Name Value
libc6 >= 2.3
lout-common = 3.39-1
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package lout_3.39-1_amd64.deb
Source Package lout

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lout deb package:
    # sudo apt-get install lout

Files

Path
/usr/bin/lout
/usr/bin/prg2lout
/usr/share/doc/lout/README
/usr/share/doc/lout/README.Debian
/usr/share/doc/lout/READMEPDF.gz
/usr/share/doc/lout/changelog.Debian.gz
/usr/share/doc/lout/copyright
/usr/share/doc/lout/lout.barcodes
/usr/share/doc/lout/lout.eiffel
/usr/share/doc/lout/lout.latin2
/usr/share/doc/lout/lout.russian
/usr/share/doc/lout/lout.teq
/usr/share/doc/lout/lout.tib
/usr/share/doc/lout/maillist
/usr/share/doc/lout/notes_dsc.gz
/usr/share/doc/lout/whatsnew.gz
/usr/share/man/man1/lout.1.gz
/usr/share/man/man1/prg2lout.1.gz

Changelog

2010-09-26 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.39-1) unstable; urgency=low
* New upstream release.
* [debian/source/format] Added - switch to source format 3.0 (quilt).
* [debian/rules] Replace deprecated "dh_clean -k" with "dh_prep".
* [debian/control]
* Updated homepage.
* Added Depends: ${misc:Depends}
* Updated Standards-Version. 
* [debian/copyright] Reworked, updated.
2008-10-15 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.38-1) unstable; urgency=low
* New upstream release. Upstream changes include:
* Fiddled with prg2lout.c hoping to fix its intermittent crash bug
* Converted "non-zero exit status of filter" from a fatal error to a
warning, so the unfixed prg2lout error has fewer repercussions
This takes care of the intermittent FTBFS. (Closes: #400178)
2008-09-21 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.37-1) unstable; urgency=low
* New upstream release.
* [debian/compat] Updated debhelper version.
* [debian/lout-doc.doc-base.design, debian/lout-doc.doc-base.expert]
Converted to UTF-8.
* [debian/lout-doc.doc-base.*] Update section to "Text".
* [debian/rules] Remove locale directory if empty.
* [debian/control] Added Homepage. Updated debhelper build dependency.
Updated Standards-Version. 
2007-07-29 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.36-1) unstable; urgency=low
* New upstream release.
2007-07-17 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.35-2) unstable; urgency=low
* [debian/control] Use ${source:Version} rather than ${Source-Version} to
make the package safe for binNMUs. (Closes: #432987)
2007-04-14 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.35-1) unstable; urgency=low
* New upstream release.
2007-03-11 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.34-1) unstable; urgency=low
* New upstream release.
2006-11-22 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.33-1) unstable; urgency=high
* New upstream release.
* [include/diagf] Add "@DHULine @DHUArrow @UHDLine @UHDArrow" as per
upstream notice post 3.33 release.
* [debian/rules] Pass LOUTLIBDIR and LOUTDOCDIR during build, to
get the right @SysInclude path. (Closes: #398202)
2006-11-05 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.32-1) unstable; urgency=medium
* New upstream release.
* [debian/control] Updated Standards-Version.
* [debian/rules] Simplify using new `-r' option.
2005-12-11 - J.H.M. Dassen (Ray) <jdassen@debian.org>
lout (3.31-2) unstable; urgency=medium
* Do away with the circular dependency between lout and lout-common as 
circular dependencies are problematic in some upgrade scenarios. 
(Closes: #341986)
* [debian/control] Replaced lout-common Depends: lout by a Suggests:
dependency.
* [debian/rules] Don't symlink /usr/share/doc/lout-common to
/usr/share/doc/lout ; instead, let debhelper create a
/usr/share/doc/lout-common documentation directory.
* [debian/lout-common.preinst] New. As dpkg won't replace a symlink with
a directory, remove the symlink to make things work.
* [debian/control] Use '*' rather than 'o' as the bullet character in the
descriptions to improve formatting in aptitude. (Closes: #338972)
* [debian/compat] New. Switch to debhelper compatibility level 5.
* [debian/control] Tighten debhelper build dependency accordingly.
* [debian/rules] No longer specify debhelper compatibility level here.
* [debian/copyright] Updated.

See Also

Package Description
love-doc_0.9.1-3_all.deb 2D game development framework - documentation
love_0.9.1-3_amd64.deb 2D game development framework based on Lua and OpenGL
lowpan-test-tools_0.3-1_amd64.deb Testing programs for LoWPAN stack in Linux
lowpan-tools_0.3-1_amd64.deb Base programs for LoWPAN in Linux, the net-tools for LoWPAN
lp-solve-doc_5.5.0.13-7_all.deb Solve (mixed integer) linear programming problems - documentation
lp-solve_5.5.0.13-7+b1_amd64.deb Solve (mixed integer) linear programming problems
lpc21isp_1.97-1_amd64.deb In-circuit programming (ISP) of ARM and Cortex microcontrollers
lpctools_1.06-1_amd64.deb interface to NXP LPC Microcontrollers ISP serial interface
lpe_1.2.7-2_amd64.deb Lightweight Programmer's Editor
lpr_2008.05.17.1_amd64.deb BSD lpr/lpd line printer spooling system
lprng-doc_3.8.A~rc2-3_all.deb lpr/lpd printer spooling system (documentation)
lprng_3.8.B-2_amd64.deb lpr/lpd printer spooling system
lptools_0.2.0-2_all.deb Tools for working with Launchpad
lrcalc_1.2-1_amd64.deb programs for calculating Littlewood-Richardson coefficients
lrslib_0.43-1_amd64.deb package to enumerate vertices and extreme rays of a convex polyhedron
Advertisement
Advertisement