londonlaw_0.2.1-18_all.deb


Advertisement

Description

londonlaw - Scotland Yard board game with network support

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name londonlaw
Package version 0.2.1
Package release 18
Package architecture all
Package type deb
Installed size 3.30 KB
Download size 3.02 MB
Official Mirror ftp.br.debian.org
London Law is an online multiplayer adaptation of the classic Scotland Yard
board game (also see Wikipedia), first published by Ravensburger in 1983. The
game is unusually asymmetric; one player controls the movements of the criminal
Mr. X as he tries to evade Scotland Yard, while another one to five players
control five detectives trying to track him down. Mr. X has an advantage in
access to transportation routes, and his precise location remains hidden for
most of the game. The detectives have only the advantage of superior numbers,
so they must work in concert to limit the criminal's options. London Law
features an attractive map overlaid on high-resolution satellite imagery.

Alternatives

Package Version Architecture Repository
londonlaw_0.2.1-18_all.deb 0.2.1 all Debian Main
londonlaw - - -

Requires

Name Value
python -
python-twisted-core -
python-wxgtk3.0 -
python-zope.interface -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package londonlaw_0.2.1-18_all.deb
Source Package londonlaw

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install londonlaw deb package:
    # sudo apt-get install londonlaw

Files

Path
/usr/games/london-client
/usr/games/london-server
/usr/lib/python2.7/dist-packages/londonlaw-0.2.1.egg-info
/usr/lib/python2.7/dist-packages/londonlaw/__init__.py
/usr/lib/python2.7/dist-packages/londonlaw/london-client.py
/usr/lib/python2.7/dist-packages/londonlaw/london-server.py
/usr/lib/python2.7/dist-packages/londonlaw/common/__init__.py
/usr/lib/python2.7/dist-packages/londonlaw/common/config.py
/usr/lib/python2.7/dist-packages/londonlaw/common/map.py
/usr/lib/python2.7/dist-packages/londonlaw/common/protocol.py
/usr/lib/python2.7/dist-packages/londonlaw/common/util.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/AutoListCtrl.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/ChatPanel.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/ConnectWindow.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/GameListWindow.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/GuiNetMessenger.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/HistoryWindow.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/MainWindow.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/MapWindow.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/MoveDialog.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/PlayerIcon.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/Protocol.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/RegistrationWindow.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/ScrolledLabel.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/SetHash.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/StaticBitmap.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/TextPanel.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/__init__.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/graphicalmap.py
/usr/lib/python2.7/dist-packages/londonlaw/guiclient/utility.py
/usr/lib/python2.7/dist-packages/londonlaw/server/Game.py
/usr/lib/python2.7/dist-packages/londonlaw/server/GameRegistry.py
/usr/lib/python2.7/dist-packages/londonlaw/server/Pawn.py
/usr/lib/python2.7/dist-packages/londonlaw/server/Protocol.py
/usr/lib/python2.7/dist-packages/londonlaw/server/Team.py
/usr/lib/python2.7/dist-packages/londonlaw/server/__init__.py
/usr/share/applications/londonlaw.desktop
/usr/share/doc-base/londonlaw
/usr/share/doc/londonlaw/TODO
/usr/share/doc/londonlaw/changelog.Debian.gz
/usr/share/doc/londonlaw/changelog.gz
/usr/share/doc/londonlaw/copyright
/usr/share/doc/londonlaw/manual.html
/usr/share/doc/londonlaw/manual.pdf.gz
/usr/share/doc/londonlaw/readme.protocol.gz
/usr/share/icons/londonlaw.png
/usr/share/londonlaw/guiclient/images/map-number-mask.png
/usr/share/londonlaw/guiclient/images/map-quarter.jpg
/usr/share/londonlaw/guiclient/images/map.jpg
/usr/share/londonlaw/guiclient/images/pin0.png
/usr/share/londonlaw/guiclient/images/pin1.png
/usr/share/londonlaw/guiclient/images/pin2.png
/usr/share/londonlaw/guiclient/images/pin3.png
/usr/share/londonlaw/guiclient/images/pin4.png
/usr/share/londonlaw/guiclient/images/pin5.png
/usr/share/londonlaw/guiclient/images/playericon0.jpg
/usr/share/londonlaw/guiclient/images/playericon1.jpg
/usr/share/londonlaw/guiclient/images/playericon2.jpg
/usr/share/londonlaw/guiclient/images/playericon3.jpg
/usr/share/londonlaw/guiclient/images/playericon4.jpg
/usr/share/londonlaw/guiclient/images/playericon5.jpg
/usr/share/londonlaw/guiclient/images/smalldownarrow.png
/usr/share/londonlaw/guiclient/images/smalluparrow.png
/usr/share/londonlaw/guiclient/images/stuck.png
/usr/share/londonlaw/guiclient/images/thinking.png
/usr/share/londonlaw/guiclient/images/ticket0.png
/usr/share/londonlaw/guiclient/images/ticket1.png
/usr/share/londonlaw/guiclient/images/ticket2.png
/usr/share/londonlaw/guiclient/images/ticket3.png
/usr/share/londonlaw/guiclient/images/ticket4.png
/usr/share/man/man6/london-client.6.gz
/usr/share/man/man6/london-server.6.gz
/usr/share/menu/londonlaw
/usr/share/pixmaps/londonlaw.xpm

Changelog

2014-10-05 - Juhani Numminen <juhaninumminen0@gmail.com>
londonlaw (0.2.1-18) unstable; urgency=medium
[ Olly Betts ]
* Update to work with wxPython 3.0 (Closes: #759084):
+ New patch wxpy3.0-compat.patch, incorporating updated version of
01_wx24_fix.patch.
[ Juhani Numminen ]
* debian/control:
+ Add myself to Uploaders.
+ Merge Build-Depends and -Indep. The both had to be installed anyway
to build this package.
+ Wrap-and-sort Build-Depends and Depends.
+ Update Depends on python-wxgtk2.8 to python-wxgtk3.0 and
python-zopeinterface to python-zope.interface.
+ Update VCS fields.
+ Change to debhelper (>= 9), dh-python. Drop cdbs.
+ Change Priority to optional.
+ Fix the format of X-Python-Version to comply with python policy.
+ Bump Standards-Version to 3.9.6. No changes required.
* debian/rules:
+ Move installing and cleaning into new files d/install and d/clean.
+ Change to debhelper (>= 9), dh-python. Drop cdbs.
* debian/patches/python-zope-fixes.patch: Add a DEP-3 patch header.
* debian/londonlaw.desktop: Add some Keywords.
* debian/copyright: Rewrite to copyright-format 1.0.
* debian/compat: Change to 9.
* debian/docs: Add doc/TODO and doc/readme.protocol.
* debian/watch: Switch to version 3.
* debian/doc-base: New file to register the manual with doc-base.
* Rename to simplify packaging file names:
+ debian/londonlaw.links    -> debian/links
+ debian/londonlaw.manpages -> debian/manpages
* Not needed or applicable anymore, drop these files:
- debian/londonlaw.dirs
- debian/londonlaw.overrides
- debian/pycompat
- debian/source.lintian-overrides
2013-10-20 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
londonlaw (0.2.1-17) unstable; urgency=low
* Team upload.
* Fix loading wrong wx version. Refresh 01_wx24_fix.patch to use wxpython 2.8.
* Update to standards version 3.9.4. No changes necessary.
2013-10-20 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
londonlaw (0.2.1-16) unstable; urgency=low
* Team upload.
* Acknowledge previous NMUs, changes are integrated into Games Team's git
* Install an XPM icon for Debian's menu system (Closes: #726811)
2013-05-16 - Matthias Klose <doko@debian.org>
londonlaw (0.2.1-15.2) unstable; urgency=low
* Non maintainer upload.
* Remove explicit dependency on python2.6. Closes: #653803.
2011-11-24 - Olly Betts <olly@survex.com>
londonlaw (0.2.1-15.1) unstable; urgency=low
* Non-maintainer upload.
* Update to use python-wxgtk2.8.
2011-06-05 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
londonlaw (0.2.1-15) unstable; urgency=low
* Team upload.
* Update londonlaw.desktop:
* Remove deprecated Encoding variable from londonlaw.desktop
* Don't use absolute path to londonlaw.png in Icon variable
* Update to standards version 3.9.2. No changes
2011-03-10 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
londonlaw (0.2.1-14) unstable; urgency=low
* Use dh_python2 instead of python-central in debian/rules. (Closes: #616877)
* Drop build-dependency on python-central
* Remove XB-Python-Version from debian/control
* Bump versioned build-dependency of cdbs to 0.4.90
* Remove DEB_PYTHON_SYSTEM variable from debian/rules
* Make python2.6 a versioned build-dependency and require at least
python2.6 2.6.6-3
* Add python-support as build-dependency
2010-08-03 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
londonlaw (0.2.1-13) unstable; urgency=low
* Acknowledge cleanung up the package by Jonas Smedegaard
* Get rid of cdbs and debhelper mixture
* Properly fix the installation of some in /usr/local
2010-08-01 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
londonlaw (0.2.1-12) unstable; urgency=low
* Rename misleading named patch debian-changes-0.2.1-11 to
python-zope-fixes.patch and drop off-topic generated comments from it
* Update to standards version 3.9.1 without changes
* Add --install-data= parameter to DEB_PYTHON_INSTALL_ARGS_ALL in the rules
file. This avoids the game data to be installed in /usr/local/

See Also

Package Description
lookup-el_1.4.1-13_all.deb emacsen interface to electronic dictionaries
lookup_1.08b-11_amd64.deb interactive utility to search text files quickly
loook_0.8.0-1_all.deb Search strings in ODF documents
looptools_2.8-1_amd64.deb Integral Evaluator of One-loop Feynman Diagram
loqui_0.5.5-3_amd64.deb GTK+ based multipane IRC/Chat Client
lordsawar-data_0.2.0-2.1_all.deb Clone of the popular SSG game Warlords II - data files
lordsawar_0.2.0-2.1_amd64.deb Clone of the popular SSG game Warlords II
lostirc_0.4.6-4_amd64.deb simple gtk-based IRC client
lottanzb_0.6-1_all.deb simple and automated Usenet downloader for Newzbin (NZB) files
lout-common_3.39-1_all.deb Common files for the Lout typesetting system
lout-doc_3.39-1_all.deb Documentation on the Lout typesetting system
lout_3.39-1_amd64.deb Typesetting system, an alternative to (La)TeX
love-doc_0.9.1-3_all.deb 2D game development framework - documentation
love_0.9.1-3_amd64.deb 2D game development framework based on Lua and OpenGL
lowpan-test-tools_0.3-1_amd64.deb Testing programs for LoWPAN stack in Linux
Advertisement
Advertisement