logcheck_1.3.17_all.deb


Advertisement

Description

logcheck - mails anomalies in the system logfiles to the administrator

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: logcheck
Package version: 1.3.17
Package release:
Package architecture: all
Package type: deb
Installed size: 216 B
Download size: 73.71 KB
Official Mirror: ftp.br.debian.org
Logcheck helps spot problems and security violations in your logfiles automatically and will send the results to you in e-mail. Logcheck was part of the Abacus Project of security tools, but this version has been rewritten.

Alternatives

    Download

    Binary package: logcheck_1.3.17_all.deb
    Source package: logcheck

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install logcheck deb package:
      # sudo apt-get install logcheck

    Files

    • /etc/cron.d/logcheck
    • /etc/logcheck/logcheck.conf
    • /etc/logcheck/logcheck.logfiles
    • /usr/bin/logcheck-test
    • /usr/sbin/logcheck
    • /usr/share/doc/logcheck/AUTHORS
    • /usr/share/doc/logcheck/CHANGES
    • /usr/share/doc/logcheck/CREDITS
    • /usr/share/doc/logcheck/NEWS.Debian.gz
    • /usr/share/doc/logcheck/README.Debian
    • /usr/share/doc/logcheck/README.Maintainer
    • /usr/share/doc/logcheck/README.how.to.interpret
    • /usr/share/doc/logcheck/README.keywords
    • /usr/share/doc/logcheck/README.logcheck
    • /usr/share/doc/logcheck/TODO
    • /usr/share/doc/logcheck/changelog.gz
    • /usr/share/doc/logcheck/copyright
    • /usr/share/doc/logcheck/log-summary-ssh
    • /usr/share/lintian/overrides/logcheck
    • /usr/share/logcheck/header.txt
    • /usr/share/man/man1/logcheck-test.1.gz
    • /usr/share/man/man8/logcheck.8.gz

    Changelog

    2014-10-24 - Hannes von Haugwitz <hannes@vonhaugwitz.com> logcheck (1.3.17) unstable; urgency=low [ Hannes von Haugwitz ] * debian/control: - dropped obsolete Replaces fields - removed 'deprecated' notice from logtail's short description - bumped to Standards-Version 3.9.6 (no changes necessary) * Migrated to dh7 style debian/rules file * debian/compat: - bumped to dh compatibility level 9 - updated copyright year to 2014 * debian/README.backports: removed (obsolete) * src/logcheck: - changed '#!/bin/bash' to '#!/usr/bin/env bash' - use '/run/lock/logcheck' instead of '/var/lock/logcheck' - set VERSION to the current version, thanks to Pascal Wittmann * ignore.d.workstation/wpasupplicant: - adjusted 'Group rekeying' rule and ignore 'CTRL-EVENT-SCAN-STARTED' message (LP: #1325349) * ignore.d.server/dhcp: - adjust rule to match new URL (closes: #744205) * debian/copyright: - removed obsolete 'fork' notice * docs/README.Maintainer: - fixed typo (closes: #764336) * ignore.d.server/ssh: - match key fingerprint when using key exchange auth (closes: #743000) * ignore.d.server/dkim-filter: removed - package has been removed from debian [ Alberto Gonzalez Iniesta ] * ignore.d.workstation/kernel: - fixed reworded "Caching mode page" message, thanks to Hagen Fuchs for the patch (closes: #743378)

    2014-01-26 - Hannes von Haugwitz <hannes@vonhaugwitz.com> logcheck (1.3.16) unstable; urgency=low * ignore.d.server/ssh: - updated "subsystem request for sftp" rule (closes: #706085) * debian/control: - removed obsolete DM-Upload-Allowed field - build-depend on debhelper (>= 9) - bumped to Standards-Version 3.9.5 (no changes necessary) * ignore.d.server/smartd: - allow additional '[SAT]' field after controller pattern (closes: #653444) * ignore.d.server/exim4: - removed 'gluck.debian.org' specific rule (closes: #722312) * debian/logcheck-database.postinst, debian/logcheck.postinst: - applied patches by Loïc Minier (closes: #645588): - add logcheck alias on install not on upgrade - use [ -z ... ] rather than [ ! -n ... ] - fix indentation and whitespaces in postinsts - merge two tests into a single lt-nl comparison * ignore.d.server/cron-apt: - allow '-o quiet=1' in dist-upgrade rule (closes: #717247) * debian/logcheck-database.maintscript: added debian/logcheck-database.preinst: removed - use dpkg-maintscript-helper to remove obsolete config files - dropped handling of config files removed before squeeze release * ignore.d.server/puppetd: removed - rules are part of puppet-common package

    Advertisement
    Advertisement