llvm-3.4-runtime_3.4.2-13_amd64.deb


Advertisement

Description

llvm-3.4-runtime - Modular compiler and toolchain technologies, IR interpreter

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name llvm-3.4-runtime
Package version 3.4.2
Package release 13
Package architecture amd64
Package type deb
Installed size 186 B
Download size 46.84 KB
Official Mirror ftp.br.debian.org
LLVM is a collection of libraries and tools that make it easy to build
compilers, optimizers, just-in-time code generators, and many other
compiler-related programs.
LLVM uses a single, language-independent virtual instruction set both
as an offline code representation (to communicate code between
compiler phases and to run-time systems) and as the compiler internal
representation (to analyze and transform programs). This persistent
code representation allows a common set of sophisticated compiler
techniques to be applied at compile-time, link-time, install-time,
run-time, or "idle-time" (between program runs).
This package provides the minimal required to execute programs in LLVM
format.

Alternatives

Package Version Architecture Repository
llvm-3.4-runtime_3.4.2-13_i386.deb 3.4.2 i386 Debian Main
llvm-3.4-runtime - - -

Requires

Name Value
binfmt-support -
libc6 >= 2.14
libffi6 >= 3.0.4
libgcc1 >= 1:4.1.1
libllvm3.4 -
libstdc++6 >= 4.1.1
libtinfo5 -

Conflicts

Name Value
llvm << 2.7-1

Replaces

Name Value
llvm << 2.7-1

Download

Type URL
Binary Package llvm-3.4-runtime_3.4.2-13_amd64.deb
Source Package llvm-toolchain-3.4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install llvm-3.4-runtime deb package:
    # sudo apt-get install llvm-3.4-runtime

Files

Path
/usr/bin/lli-3.4
/usr/bin/lli-child-target-3.4
/usr/lib/llvm-3.4/bin/lli
/usr/lib/llvm-3.4/bin/lli-child-target
/usr/share/binfmts/llvm-3.4-runtime.binfmt
/usr/share/doc/llvm-3.4-runtime/NEWS.Debian.gz
/usr/share/doc/llvm-3.4-runtime/changelog.Debian.gz
/usr/share/doc/llvm-3.4-runtime/copyright
/usr/share/lintian/overrides/llvm-3.4-runtime
/usr/share/man/man1/lli-3.4.1.gz

Changelog

2014-10-15 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-13) unstable; urgency=medium
* Try again to fix the arm64 FTBFS (Closes: #764530)
2014-10-10 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-12) unstable; urgency=medium
* Drop the LFS changes. FTBFS on most of the archs
2014-10-09 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-11) unstable; urgency=medium
* Fix some issues in the testsuite
* lldb arm64 is disabled but a directory was installed. Create an empty
directory to make dh_install happy. (Closes: #764530)
* Build with LFS (large file support) (Closes: #759162)
2014-09-26 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-10) unstable; urgency=medium
* Fix my screw up. Add .1 to the libclang soname to make
dpkg-shlibdeps happy
* python-lldb-3.4 and lldb-3.3: error when trying to install together
(Closes: #762902)
* Remove useless dependency on doxygen
2014-09-24 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-9) unstable; urgency=medium
* Upload in unstable
* Disable the co-instability of lldb & python-lldb
(Python stuff conflicts)
2014-09-18 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-9~exp2) experimental; urgency=medium
* Remove the useless dependency lldb-3.4 => liblldb-3.4. Should be
transparently managed by Debian tools
* Does not have multiarch include paths on !linux (Closes: #759303)
* Fails to find C++ include paths under Kfreebsd (Closes: #731711)
Thanks to Steven Chamberlain for the help on the two previous fixes
2014-08-30 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-9~exp1) experimental; urgency=medium
* libclang-3.4.so should be used instead libclang.so. Update the soname
to match the new lib name (Closes: #759538)
* Rename liblldb.so to liblldb-3.4.so + update of the soname.
* python-clang-3.4 description updated
* liblldb-3.4 and python-lldb-3.4 added
* lldb-3.4-dev renamed to liblldb-3.4-dev to match the previous changes
* Manpages for llvm-ranlib, clang-apply-replacements, pp-trace and clang-tidy
added
* clang-3.4 should depends on binutils (for ld, at least)
(Closes: #751030)
* clang/www/analyzer/scripts/dbtree.js removed
2014-08-16 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-8) unstable; urgency=medium
* Try to bring back lldb-3.4-dev on mips & mipsel (Closes: #758314)
2014-08-05 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-7) unstable; urgency=medium
* Upload in unstable
* Try to bring back lldb on mips & mipsel
* Force scan-build to use the same version of clang
* Try to fix hurd (hurd-EIEIO-undef.diff)
2014-08-02 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.4 (1:3.4.2-7~exp1) experimental; urgency=medium
* Co installation of clang (Closes: #736057)
- scan-build => scan-build-3.4
- scan-view => scan-view-3.4
- asan_symbolize => asan_symbolize-3.4
* Remove of pollycc
* clang alternatives are managed by llvm-defaults

See Also

Package Description
llvm-3.4-tools_3.4.2-13_amd64.deb Modular compiler and toolchain technologies, tools
llvm-3.4_3.4.2-13_amd64.deb Modular compiler and toolchain technologies
llvm-3.5-dev_3.5-10_amd64.deb Modular compiler and toolchain technologies, libraries and headers
llvm-3.5-doc_3.5-10_all.deb Modular compiler and toolchain technologies, documentation
llvm-3.5-examples_3.5-10_all.deb Modular compiler and toolchain technologies, examples
llvm-3.5-runtime_3.5-10_amd64.deb Modular compiler and toolchain technologies, IR interpreter
llvm-3.5-tools_3.5-10_amd64.deb Modular compiler and toolchain technologies, tools
llvm-3.5_3.5-10_amd64.deb Modular compiler and toolchain technologies
llvm-dev_3.5-25_amd64.deb Low-Level Virtual Machine (LLVM), libraries and headers
llvm-runtime_3.5-25_amd64.deb Low-Level Virtual Machine (LLVM), bytecode interpreter
llvm_3.5-25_amd64.deb Low-Level Virtual Machine (LLVM)
lm-sensors_3.3.5-2_amd64.deb utilities to read temperature/voltage/fan sensors
lm4flash_20140816~a565880+dfsg-1_amd64.deb Command-line firmware flashing tool to communicate with the Stellaris Launchpad
lmarbles_1.0.7-1.1_amd64.deb A game where you build figures out of colored marbles
lmdb-doc_0.9.14-1_all.deb Lightning Memory-Mapped Database doxygen documentation
Advertisement
Advertisement