lldpd_0.7.11-2+deb8u1_amd64.deb


Advertisement

Description

lldpd - implementation of IEEE 802.1ab (LLDP)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name lldpd
Package version 0.7.11
Package release 2+deb8u1
Package architecture amd64
Package type deb
Installed size 488 B
Download size 162.21 KB
Official Mirror ftp.br.debian.org
LLDP is an industry standard protocol designed to supplant
proprietary Link-Layer protocols such as Extreme's EDP (Extreme
Discovery Protocol) and CDP (Cisco Discovery Protocol). The goal of
LLDP is to provide an inter-vendor compatible mechanism to deliver
Link-Layer notifications to adjacent network devices.
This implementation provides LLDP sending and reception, supports
VLAN and includes an SNMP subagent that can interface to an SNMP
agent through AgentX protocol.
This daemon is also able to deal with CDP, SONMP, FDP and EDP
protocol. It also handles LLDP-MED extension.

Alternatives

Package Version Architecture Repository
lldpd_0.7.11-2+deb8u1_i386.deb 0.7.11 i386 Debian Main
lldpd - - -

Requires

Name Value
adduser -
init-system-helpers >= 1.18~
libbsd0 >= 0.6.0
libc6 >= 2.15
libevent-2.0-5 >= 2.0.10-stable
libpci3 >= 1:3.2.1-1
libreadline6 >= 6.0
libsensors4 >= 1:3.0.0
libsnmp30 >= 5.7.2.1+dfsg-1~dfsg
libssl1.0.0 >= 1.0.0
libwrap0 >= 7.6-4~
libxml2 >= 2.7.4

Download

Type URL
Binary Package lldpd_0.7.11-2+deb8u1_amd64.deb
Source Package lldpd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lldpd deb package:
    # sudo apt-get install lldpd

Files

Path
/etc/bash_completion.d/lldpcli.bash-completion
/etc/default/lldpd
/etc/init/lldpd.conf
/etc/init.d/lldpd
/etc/lldpd.d/README.conf
/lib/systemd/system/lldpd.service
/usr/lib/liblldpctl.so.4
/usr/lib/liblldpctl.so.4.3.0
/usr/sbin/lldpcli
/usr/sbin/lldpctl
/usr/sbin/lldpd
/usr/share/doc/lldpd/NEWS.gz
/usr/share/doc/lldpd/README.Debian
/usr/share/doc/lldpd/changelog.Debian.gz
/usr/share/doc/lldpd/changelog.gz
/usr/share/doc/lldpd/copyright
/usr/share/lintian/overrides/lldpd
/usr/share/man/man8/lldpcli.8.gz
/usr/share/man/man8/lldpctl.8.gz
/usr/share/man/man8/lldpd.8.gz
/usr/share/zsh/vendor-completions/_lldpcli

Changelog

2015-10-25 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.11-2+deb8u1) jessie; urgency=medium
* Fix a segfault when receiving incorrectly formed LLDP management
addresses:
- 0001-lldp-fix-a-buffer-overflow-when-handling-management-.patch
* Fix an assert error when receiving incorrectly formed LLDP management
addresses:
- 0002-protocols-don-t-use-assert-on-paths-that-can-be-reac.patch
2014-11-24 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.11-2) unstable; urgency=medium
* Cherry-pick 0001-lib-fix-pkgconfig-file-substitutions.patch to fix
substitutions in .pc file in liblldpctl-dev package.
2014-10-26 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.11-1) unstable; urgency=medium
* New upstream version.
* Bump Standards-Version to 3.9.6.
* Cherry-pick 0001-systemd-fix-systemd-unit-file.patch to fix systemd
unit file.
2014-07-26 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.10-1) unstable; urgency=medium
* New upstream version.
+ Update symbols.
2014-07-05 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.9-2) unstable; urgency=medium
* Depends again on libpci-dev as libsnmp-dev is not up-to-date in
kfreebsd.
2014-05-31 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.9-1) unstable; urgency=medium
* New upstream version.
* Drop dependency on libsensors4-dev and libpci-dev. libsnmp-dev now
depends on those.
2014-05-07 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.8-1) unstable; urgency=medium
* New upstream version.
* Depends on libpci-dev to workaround bug #744023. Closes: #746060.
* Bump Standards-Version to 3.9.5.
2013-11-17 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.7-1) unstable; urgency=low
* New upstream version.
+ lldpd now builds its chroot itself. This removes the need to use
mkdir/cp in lldpd.service and closes: #725098.
+ lldpd ships its own lldpd.service. Use it.
2013-08-12 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.6-2) unstable; urgency=low
* Build-Depends on dh-systemd to correctly register service files.
2013-07-22 - Vincent Bernat <bernat@debian.org>
lldpd (0.7.6-1) unstable; urgency=low
* New upstream version.

See Also

Package Description
llgal_0.13.17-2_all.deb Command-line online gallery generator
lltag_0.14.4-2_all.deb Automatic command-line mp3/ogg/flac file tagger and renamer
llvm-3.4-dev_3.4.2-13_amd64.deb Modular compiler and toolchain technologies, libraries and headers
llvm-3.4-doc_3.4.2-13_all.deb Modular compiler and toolchain technologies, documentation
llvm-3.4-examples_3.4.2-13_all.deb Modular compiler and toolchain technologies, examples
llvm-3.4-runtime_3.4.2-13_amd64.deb Modular compiler and toolchain technologies, IR interpreter
llvm-3.4-tools_3.4.2-13_amd64.deb Modular compiler and toolchain technologies, tools
llvm-3.4_3.4.2-13_amd64.deb Modular compiler and toolchain technologies
llvm-3.5-dev_3.5-10_amd64.deb Modular compiler and toolchain technologies, libraries and headers
llvm-3.5-doc_3.5-10_all.deb Modular compiler and toolchain technologies, documentation
llvm-3.5-examples_3.5-10_all.deb Modular compiler and toolchain technologies, examples
llvm-3.5-runtime_3.5-10_amd64.deb Modular compiler and toolchain technologies, IR interpreter
llvm-3.5-tools_3.5-10_amd64.deb Modular compiler and toolchain technologies, tools
llvm-3.5_3.5-10_amd64.deb Modular compiler and toolchain technologies
llvm-dev_3.5-25_amd64.deb Low-Level Virtual Machine (LLVM), libraries and headers
Advertisement
Advertisement