lldb-3.5_3.5-10_amd64.deb


Advertisement

Description

lldb-3.5 - Next generation, high-performance debugger

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: lldb-3.5
Package version: 3.5
Package release: 10
Package architecture: amd64
Package type: deb
Installed size: 872 B
Download size: 217.01 KB
Official Mirror: ftp.br.debian.org
LLDB is a next generation, high-performance debugger. It is built as a set of reusable components which highly leverage existing libraries in the larger LLVM Project, such as the Clang expression parser and LLVM disassembler.

Alternatives

Conflicts

  • lldb-3.3
  • lldb-3.4
  • lldb-3.6

    Download

    Binary package: lldb-3.5_3.5-10_amd64.deb
    Source package: llvm-toolchain-3.5

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install lldb-3.5 deb package:
      # sudo apt-get install lldb-3.5

    Files

    • /usr/bin/lldb-3.5
    • /usr/bin/lldb-gdbserver-3.5
    • /usr/bin/lldb-mi-3.5
    • /usr/bin/lldb-platform-3.5
    • /usr/lib/llvm-3.5/bin/lldb
    • /usr/lib/llvm-3.5/bin/lldb-gdbserver
    • /usr/lib/llvm-3.5/bin/lldb-mi
    • /usr/lib/llvm-3.5/bin/lldb-platform
    • /usr/share/doc/lldb-3.5/NEWS.Debian.gz
    • /usr/share/doc/lldb-3.5/changelog.Debian.gz
    • /usr/share/doc/lldb-3.5/copyright
    • /usr/share/lintian/overrides/lldb-3.5
    • /usr/share/man/man1/lldb-3.5.1.gz

    Changelog

    2015-02-27 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-10) unstable; urgency=medium * lldb-arch.diff: Fix a critical bug on lldb arch detection (Closes: #779332)

    2014-12-14 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-9) unstable; urgency=medium * Fix scan-build (patch removed during a conflict) (Closes: #773050)

    2014-12-08 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-8) unstable; urgency=medium * Bring back some patches (kfreebsd-path.diff, kfreebsd-readline.diff ignore-ifcvt3.ll.diff) * Update the soname liblldb to liblldb-3.5 * Revert the liblldb.so.1 -> liblldb-3.5.so.1 change (Closes: #771797)

    2014-11-14 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-7) unstable; urgency=medium * Improve the copyright file. Thanks to Dann Frazier (Closes: #766778) * Remove bashim (Closes: #772302, #772301) [ Andreas Beckmann ] * liblldb-3.5: Ship SONAME link liblldb.so.1 -> liblldb-3.5.so.1 (Closes: #771797) * liblldb-3.5: Breaks+Replaces: lldb-3.3 due to file conflict on liblldb.so.1. (Closes: #769113)

    2014-10-13 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-6) unstable; urgency=medium * Ignore a test failing under i386. Forwaded: http://llvm.org/bugs/show_bug.cgi?id=21257

    2014-10-09 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-5) unstable; urgency=medium * Fix various issues under Kfreebsd. Thanks to Steven Chamberlain (Closes: #761650)

    2014-09-28 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-4) unstable; urgency=medium * scan-build could not find clang binary (Closes: #758998) * Fix the ABI issues by installing a symlink (Closes: #762959, #763058). This should fix the doxygen breakage. Many thanks to Andreas Barth.

    2014-09-26 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-3) unstable; urgency=medium * Fix my screw up. Add .1 to the libclang & liblldb sonames to make dpkg-shlibdeps happy * python-clang-3.6 and python-clang-3.5: error when trying to install together (Closes: #762901) * Remove useless dependency on doxygen

    2014-09-24 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-2) unstable; urgency=medium * Upload in unstable * Disable the co-instability of lldb & python-lldb (Python stuff conflicts) * Fix the FTBFs under kfreebsd (kfreebsd-readline.diff) * Really apply patch kfreebsd-path.diff (oups) * Further improvement on lldb-mi Once more, thanks to Steven Chamberlain for the kfreebsd patches. * Try to workaround the FTBFS under ppc64el (create an empty directory)

    2014-09-18 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.5 (1:3.5-2~exp1) experimental; urgency=medium * Build lldb-mi under kfreebsd (Closes: #761650) * Fix a bad dependency from lldb-3.5 * Does not have multiarch include paths on !linux (Closes: #759303) * Fails to find C++ include paths under Kfreebsd (Closes: #731711) Thanks to Steven Chamberlain for the help on the two previous fixes

    Advertisement
    Advertisement