lighttpd-mod-mysql-vhost_1.4.35-4+deb8u1_amd64.deb


Advertisement

Description

lighttpd-mod-mysql-vhost - MySQL-based virtual host configuration for lighttpd

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package filename lighttpd-mod-mysql-vhost_1.4.35-4+deb8u1_amd64.deb
Package name lighttpd-mod-mysql-vhost
Package version 1.4.35
Package release 4+deb8u1
Package architecture amd64
Package type deb
Category httpd implemented-in::c role::shared-lib
Homepage http://lighttpd.net/
License -
Maintainer Debian lighttpd maintainers <pkg-lighttpd-maintainers@lists.alioth.debian.org>
Download size 19.49 KB
Installed size 63.00 KB
This package contains the myqsl_vhost module for lighttpd. With
this module, it is possible to write the configuration for virtual
hosts into a MySQL table instead of including it in the lighttpd
configuration file.

Alternatives

Package Version Architecture Repository
lighttpd-mod-mysql-vhost_1.4.35-4+deb8u1_i386.deb 1.4.35 i386 Debian Main
lighttpd-mod-mysql-vhost - - -

Requires

Name Value
libc6 >= 2.4
libmysqlclient18 >= 5.5.24+dfsg-1
lighttpd = 1.4.35-4+deb8u1
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lighttpd-mod-mysql-vhost_1.4.35-4+deb8u1_amd64.deb
Source Package lighttpd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lighttpd-mod-mysql-vhost deb package:
    # sudo apt-get install lighttpd-mod-mysql-vhost

Files

Path
/usr/lib/lighttpd/mod_mysql_vhost.so
/usr/share/doc/lighttpd-mod-mysql-vhost/NEWS.Debian.gz
/usr/share/doc/lighttpd-mod-mysql-vhost/changelog.Debian.gz
/usr/share/doc/lighttpd-mod-mysql-vhost/copyright

Changelog

2016-07-31 - Santiago R.R. <santiagorr@riseup.net>
lighttpd (1.4.35-4+deb8u1) jessie-security; urgency=medium
* Non-maintainer upload.
* Fix CVE-2016-1000212: Mitigate HTTPoxy vulnerability.
* Add mitigate-httpoxy-779c133c16f9af168b004dce7a2a64f16c1cb3a4.patch
2014-11-02 - Michael Gilbert <mgilbert@debian.org>
lighttpd (1.4.35-4) unstable; urgency=medium
* Disable SSLv3 by default (closes: #765702).
2014-08-18 - Michael Gilbert <mgilbert@debian.org>
lighttpd (1.4.35-3) unstable; urgency=medium
* Support building with dpkg-buildpackage -g.
* Drop libmemcache-dev build-dependency (closes: #748809).
2014-04-05 - Michael Gilbert <mgilbert@debian.org>
lighttpd (1.4.35-2) unstable; urgency=medium
* Fix a spelling error.
* Add a lintian override.
* Make VCS field canonical.
* Add myself to the uploaders.
* Use dh-autoreconf (closes: #726394, #731104).
* Disable indeterminant test on kfreebsd (closes: #731074).
2014-03-22 - Arno Töll <arno@debian.org>
lighttpd (1.4.35-1) unstable; urgency=low
* New upstream version (fixes CVE-2014-2323, CVE-2014-2324)
+ Delete patches: cve-2013-4508.patch, cve-2013-4559.patch,
cve-2013-4560.patch. Those are all cumulative included since
lighttpd 1.4.34
* Acknowledge NMUs by the security team
* Make the init script wait until lighttpd really terminates.
* Change the default document root /var/www/html (Closes: #730379), add a
Lintian override for it
* Bump the debhelper dependency to >= 9.20130624 to ensure dh_installinit is
recent enough for systemd (Closes: #713860)
* Reorder LSB init dependencies, add $local_fs to it
* Add hardening flags to lighttpd. Thanks to Michael Gilbert
for providing a patch (Closes: #741497)
* Remove W3C logo from index.html to avoid inclusion of images hosted
elsewhere
* Push standards version to 3.9.5 (no changes needed).
2013-11-16 - Michael Gilbert <mgilbert@debian.org>
lighttpd (1.4.33-1+nmu2) unstable; urgency=high
* Non-maintainer upload by the Security Team.
* Fix regression caused by the fix for cve-2013-4508 (closes: #729480).
2013-11-13 - Michael Gilbert <mgilbert@debian.org>
lighttpd (1.4.33-1+nmu1) unstable; urgency=high
* Non-maintainer upload by the Security Team (closes: #729453).
* Fix cve-2013-4508: ssl cipher suites issue.
* Fix cve-2013-4559: setuid privilege escalation issue.
* Fix cve-2013-4560: use-after-free in fam.
2013-10-15 - Arno Töll <arno@debian.org>
lighttpd (1.4.33-1) unstable; urgency=low
* Drop the connection-dos.patch - merged upstream.
* Fix "mod_extforward missing configuration file": ship requested
configuration file (Closes: #697304)
* Remove access.conf, an obsolete conffiles as we should have done since
2010 (Closes: #703215)
* Push debhelper's compat mode to 9, the use of maintscript helper requires
8.1 so we had to push the debhelper b-d anyway.
* Fix "config.guess/config.sub out of date for arm64" by adding the patch
provided by Colin Watson. Thanks (Closes: #726394).
* Fix "[PATCH] use dh-systemd for proper systemd-related maintscripts" to
add systemd support. Thanks to Michael Stapelberg (Closes: #713859)
2013-03-14 - Arno Töll <arno@debian.org>
lighttpd (1.4.31-4) unstable; urgency=high
* CVE-2013-1427: Switch the socket path for PHP when using FastCGI. /tmp is
world-writable which may cause security implications if an attacker
manages to control /tmp/php.socket before the web server (re-)starts.
* Switch VCS to git
* Push standards version (no changes)
2012-11-21 - Arno Töll <arno@debian.org>
lighttpd (1.4.31-3) unstable; urgency=high
* Fix "configuration files refer to wrong path for documentation"
by merging a patch supplied by  Denis Laxalde <denis@laxalde.org>
(Closes: #676641)
* CVE-2012-5533: Fix Denial Of Service attacks against Lighttpd by sending
faulty Connection headers

See Also

Package Description
lighttpd-mod-trigger-b4-dl_1.4.35-4+deb8u1_amd64.deb anti-deep-linking module for lighttpd
lighttpd-mod-webdav_1.4.35-4+deb8u1_amd64.deb WebDAV module for lighttpd
lighttpd_1.4.35-4+deb8u1_amd64.deb fast webserver with minimal memory footprint
lightyears_1.4-2_all.deb single player real-time strategy game with steampunk sci-fi
liguidsoap_1.1.1-7_all.deb control GUI for liquidsoap
lilo-doc_24.1-1_all.deb LInux LOader - Documentation for the classic OS boot loader
lilo_24.1-1_amd64.deb LInux LOader - the classic OS boot loader
lilv-utils_0.20.0~dfsg0-1_amd64.deb library for simple use of LV2 plugins (runtime files)
lilypond-data_2.18.2-4_all.deb LilyPond music typesetter (data files)
lilypond-doc-html-cs_2.18.2-4_all.deb LilyPond HTML Documentation in Czech
lilypond-doc-html-de_2.18.2-4_all.deb LilyPond HTML Documentation in German
lilypond-doc-html-es_2.18.2-4_all.deb LilyPond HTML Documentation in Spanish
lilypond-doc-html-fr_2.18.2-4_all.deb LilyPond HTML Documentation in French
lilypond-doc-html-hu_2.18.2-4_all.deb LilyPond HTML Documentation in Hungarian
lilypond-doc-html-it_2.18.2-4_all.deb LilyPond HTML Documentation in Italian
Advertisement
Advertisement