libxfcegui4-dev_4.10.0-2_amd64.deb


Advertisement

Description

libxfcegui4-dev - Development files for libxfcegui4-4

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libxfcegui4-dev
Package version: 4.10.0
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 699 B
Download size: 160.28 KB
Official Mirror: ftp.br.debian.org
This package contains the headers and the static library for libxfcegui4-4. If you intend to code applications which use some of these functions (probably Xfce4-based applications), then you have to install this package. The libxfcegui4 Reference Manual is also included and it can be consulted with Devhelp or a web browser.

Alternatives

    Download

    Source package: libxfcegui4

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libxfcegui4-dev deb package:
      # sudo apt-get install libxfcegui4-dev

    Files

    • /usr/include/xfce4/libxfcegui4/dialogs.h
    • /usr/include/xfce4/libxfcegui4/gtk_style.h
    • /usr/include/xfce4/libxfcegui4/gtktoxevent.h
    • /usr/include/xfce4/libxfcegui4/gui-enum-types.h
    • /usr/include/xfce4/libxfcegui4/icons.h
    • /usr/include/xfce4/libxfcegui4/libnetk.h
    • /usr/include/xfce4/libxfcegui4/libxfcegui4-config.h
    • /usr/include/xfce4/libxfcegui4/libxfcegui4.h
    • /usr/include/xfce4/libxfcegui4/netk-application.h
    • /usr/include/xfce4/libxfcegui4/netk-class-group.h
    • /usr/include/xfce4/libxfcegui4/netk-enum-types.h
    • /usr/include/xfce4/libxfcegui4/netk-pager.h
    • /usr/include/xfce4/libxfcegui4/netk-screen.h
    • /usr/include/xfce4/libxfcegui4/netk-tasklist.h
    • /usr/include/xfce4/libxfcegui4/netk-trayicon.h
    • /usr/include/xfce4/libxfcegui4/netk-util.h
    • /usr/include/xfce4/libxfcegui4/netk-window-action-menu.h
    • /usr/include/xfce4/libxfcegui4/netk-window-menu.h
    • /usr/include/xfce4/libxfcegui4/netk-window.h
    • /usr/include/xfce4/libxfcegui4/netk-workspace.h
    • /usr/include/xfce4/libxfcegui4/preview_filesel.h
    • /usr/include/xfce4/libxfcegui4/session-client.h
    • /usr/include/xfce4/libxfcegui4/xfce-appmenuitem.h
    • /usr/include/xfce4/libxfcegui4/xfce-colorbutton.h
    • /usr/include/xfce4/libxfcegui4/xfce-exec.h
    • /usr/include/xfce4/libxfcegui4/xfce-filechooser.h
    • /usr/include/xfce4/libxfcegui4/xfce-gdk-extensions.h
    • /usr/include/xfce4/libxfcegui4/xfce-gtk-extensions.h
    • /usr/include/xfce4/libxfcegui4/xfce-heading.h
    • /usr/include/xfce4/libxfcegui4/xfce-icontheme.h
    • /usr/include/xfce4/libxfcegui4/xfce-startup-notification.h
    • /usr/include/xfce4/libxfcegui4/xfce-titled-dialog.h
    • /usr/include/xfce4/libxfcegui4/xfce-widget-helpers.h
    • /usr/include/xfce4/libxfcegui4/xfce_aboutdialog.h
    • /usr/include/xfce4/libxfcegui4/xfce_clock.h
    • /usr/include/xfce4/libxfcegui4/xfce_decorbutton.h
    • /usr/include/xfce4/libxfcegui4/xfce_decortoggle.h
    • /usr/include/xfce4/libxfcegui4/xfce_framebox.h
    • /usr/include/xfce4/libxfcegui4/xfce_iconbutton.h
    • /usr/include/xfce4/libxfcegui4/xfce_menubutton.h
    • /usr/include/xfce4/libxfcegui4/xfce_movehandler.h
    • /usr/include/xfce4/libxfcegui4/xfce_scaled_image.h
    • /usr/include/xfce4/libxfcegui4/xfce_systemtray.h
    • /usr/include/xfce4/libxfcegui4/xfce_togglebutton.h
    • /usr/include/xfce4/libxfcegui4/xinerama.h
    • /usr/lib/x86_64-linux-gnu/libxfcegui4.so
    • /usr/lib/x86_64-linux-gnu/pkgconfig/libxfcegui4-1.0.pc
    • /usr/share/doc/libxfcegui4-dev/changelog.Debian.gz
    • /usr/share/doc/libxfcegui4-dev/changelog.gz
    • /usr/share/doc/libxfcegui4-dev/copyright
    • /usr/share/gtk-doc/html/libxfcegui4/XfceAboutDialog.html
    • /usr/share/gtk-doc/html/libxfcegui4/XfceAppMenuItem.html
    • /usr/share/gtk-doc/html/libxfcegui4/XfceFramebox.html
    • /usr/share/gtk-doc/html/libxfcegui4/XfceHeading.html
    • /usr/share/gtk-doc/html/libxfcegui4/XfceIconTheme.html
    • /usr/share/gtk-doc/html/libxfcegui4/XfceTitledDialog.html
    • /usr/share/gtk-doc/html/libxfcegui4/home.png
    • /usr/share/gtk-doc/html/libxfcegui4/index.html
    • /usr/share/gtk-doc/html/libxfcegui4/index.sgml
    • /usr/share/gtk-doc/html/libxfcegui4/left.png
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4-Standard-Macros.html
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4-Xfce-Gdk-extensions.html
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4-Xfce-Gtk+-extensions.html
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4-XfceFileChooser.html
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4-core.html
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4-dialogs.html
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4-fundamentals.html
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4-netk.html
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4-xfce-exec.html
    • /usr/share/gtk-doc/html/libxfcegui4/libxfcegui4.devhelp2
    • /usr/share/gtk-doc/html/libxfcegui4/reference.html
    • /usr/share/gtk-doc/html/libxfcegui4/right.png
    • /usr/share/gtk-doc/html/libxfcegui4/style.css
    • /usr/share/gtk-doc/html/libxfcegui4/up.png

    Changelog

    2013-05-22 - Yves-Alexis Perez <corsac@debian.org> libxfcegui4 (4.10.0-2) unstable; urgency=low * Upload to unstable. * debian/rules: - enable all hardening flags.

    2012-05-05 - Lionel Le Folgoc <mrpouit@gmail.com> libxfcegui4 (4.10.0-1) experimental; urgency=low * New upstream stable release. * debian/patches: - 01_xfce-exec-use-thunar.patch: dropped, now use exo-open. - 03_fix-link-lm.patch: dropped, included upstream. * debian/control: revert to unversioned libxfce4util-dev, bump required version to >= 4.10.0.

    2012-04-15 - Yves-Alexis Perez <corsac@debian.org> libxfcegui4 (4.9.0-1) experimental; urgency=low [ Lionel Le Folgoc ] * debian/patches: add missing DEP3 headers. * debian/control: switch to libxfce4util6-dev for the new api. [ Yves-Alexis Perez ] * New upstream development release. * debian/rules: - build with --parallel. - use debhelper 9 / dpkg-dev 1.16.1 hardening support. - use --fail-missing in dh_install. * debian/control: - bump debhelper build-dep to 9. - add build-dep on dpkg-dev 1.16.1. - drop hardening-includes build-dep. - update standards version to 3.9.3. - add Pre-Depends on ${misc:Pre-Depends} in libxfcegui4-4 for multiarch. * debian/compat bumped to 9. * Use multi-arch paths in install files. * debian/libxfcegui4-4.install: - stop installing glade files since they are gone. * debian/libxfcegui4-dev: - don't install static libs, we don't build them anymore.

    2011-09-05 - Yves-Alexis Perez <corsac@debian.org> libxfcegui4 (4.8.1-5) unstable; urgency=low * debian/patches: - 03_fix-link-lm added, explicit link against libmath. closes: #640452 * debian/rules: - run xdt-autogen before configure. * debian/control: - add build-dep on xfce4-dev-tools, libtool and gtk-doc-tools.

    2011-04-19 - Yves-Alexis Perez <corsac@debian.org> libxfcegui4 (4.8.1-4) unstable; urgency=low * Upload to unstable. * debian/control: - remove Martin, Emanuele, Simon and Michael from uploaders, thanks to them. - update standards version to 3.9.2.

    2011-02-14 - Yves-Alexis Perez <corsac@debian.org> libxfcegui4 (4.8.1-3) experimental; urgency=low * debian/control: - add Breaks: on xfwm4 and xfce4-settings before 4.8 because libxfcekbdprivate is now gone. closes: #613019

    2011-02-11 - Yves-Alexis Perez <corsac@debian.org> libxfcegui4 (4.8.1-2) experimental; urgency=low * debian/control: - update libxfce4util build-dep to pick 4.8.0. closes: #612853

    2011-02-10 - Yves-Alexis Perez <corsac@debian.org> libxfcegui4 (4.8.1-1) experimental; urgency=low [ Yves-Alexis Perez ] * New upstream development release. * debian/libxfcegui4-4.shlibs: - bump shlibs to 4.7. - drop libxfce4kbd-private shlib, not present anymore. * debian/control, debian/xfce-keyboard-shortcuts.install: - drop xfce-keyboard-shortcut package, now provided by libxfce4ui. * debian/control: - update standards version to 3.9.1. - add build-dep on hardening-includes. * debian/rules: - pick {C,LD}FLAGS from dpkg-buildflags - add -O1, -z,defs, --as-needed to LDFLAGS - add hardening flags to {C,LD}FLAGS. * debian/copyright updated for new releases. [ Lionel Le Folgoc ] * debian/control, debian/glade-xfce.install: - drop glade-xfce package, now provided by libxfce4ui. * debian/control: - add myself to Uploaders - drop libgladeui-1-dev build-dep, not needed anymore.

    2010-05-23 - Yves-Alexis Perez <corsac@debian.org> libxfcegui4 (4.6.4-1) unstable; urgency=low * New upstream release. * Switch to 3.0 (quilt) source format. * debian/rules: - don't use quilt addon. * debian/control: - drop quilt build-dep.

    2010-02-07 - Yves-Alexis Perez <corsac@debian.org> libxfcegui4 (4.6.3-2) unstable; urgency=low * Override dh_strip so we don't end up with an empty dbg package. * debian/control: - update standards version to 3.8.4. - update debhelper build dep because using override.

    Advertisement
    Advertisement