libxc-dev_2.1.1-1_amd64.deb


Advertisement

Description

libxc-dev - Library of Exchange-Correlation Functionals (development files)

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libxc-dev
Package version: 2.1.1
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 1.64 KB
Download size: 332.14 KB
Official Mirror: ftp.br.debian.org
LibXC is a library of exchange-correlation (XC) functionals for density-functional theory (DFT). The aim is to provide a portable, well tested and reliable set of exchange and correlation functionals that can be used by other codes. This package contains the static library, the C headers and the Fortran modules necessary for developers.

Alternatives

Requires

    Download

    Source package: libxc

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libxc-dev deb package:
      # sudo apt-get install libxc-dev

    Files

    • /usr/include/libxc_funcs_m.mod
    • /usr/include/xc.h
    • /usr/include/xc_config.h
    • /usr/include/xc_f90_lib_m.mod
    • /usr/include/xc_f90_types_m.mod
    • /usr/include/xc_funcs.h
    • /usr/include/xc_unconfig.h
    • /usr/include/xc_version.h
    • /usr/lib/x86_64-linux-gnu/libxc.a
    • /usr/lib/x86_64-linux-gnu/libxc.so
    • /usr/lib/x86_64-linux-gnu/pkgconfig/libxc.pc
    • /usr/share/doc/libxc-dev/changelog.Debian.gz
    • /usr/share/doc/libxc-dev/changelog.gz
    • /usr/share/doc/libxc-dev/copyright

    Changelog

    2014-11-29 - Michael Banck <mbanck@debian.org> libxc (2.1.1-1) unstable; urgency=medium * New upstream point release.

    2014-10-12 - Michael Banck <mbanck@debian.org> libxc (2.1.0-2) unstable; urgency=medium * debian/patches/fix_static_initialisation.patch: New patch, fixes FTBFS errors due to invalid static initialisations on some architectures. * debian/rules: Removed parallel option, as it seems to lead to FTBFS errors on some autobuilders.

    2014-10-12 - Michael Banck <mbanck@debian.org> libxc (2.1.0-1) unstable; urgency=medium * New upstream release. [ Daniel Leidert ] * debian/copyright: Updated and moved to DEP5. * debian/rules: Run dh_install with --list-missing. * debian/patches/fix_underlinkage.patch: Added. - Add missing -lm to fix underlinkage of the library. * debian/patches/testsuite_support_tmpdir.patch: Adjusted. * debian/patches/series: Adjusted. [ Michael Banck ] * debian/upstream: Moved to debian/upstream/metadata.

    2014-02-24 - Debichem Team <debichem-devel@lists.alioth.debian.org> libxc (2.0.3-1) unstable; urgency=low * New upstream release. [ Daniel Leidert ] * debian/compat: Set to 9. * debian/control: Enabled multi-arch support. (Vcs-Browser, Vcs-Svn): Fixed lintian warning. (Build-Depends): Increased debhelper version. Added dh-autoreconf (closes: #734559). * debian/copyright: Minor fix. * debian/libxc1.install, debian/libxc-dev.install: Adjusted after enabling multi-arch support. * debian/rules: Added autoreconf addon and enabled parallel building. Export FCFLAGS properly for hardening. * debian/watch: Added.

    2013-07-29 - Michael Banck <mbanck@debian.org> libxc (2.0.2-1) unstable; urgency=low * Initial release (Closes: #602110).

    Advertisement
    Advertisement