libxaw7_1.0.12-2+b1_amd64.deb


Advertisement

Description

libxaw7 - X11 Athena Widget library

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libxaw7
Package version: 1.0.12
Package release: 2+b1
Package architecture: amd64
Package type: deb
Installed size: 504 B
Download size: 194.52 KB
Official Mirror: ftp.br.debian.org
libXaw7 provides the second version of Xaw, the Athena Widgets toolkit, which is largely used by legacy X applications. This version is the most common version, as version 6 is considered deprecated, and version 8, which adds Xprint support, is unsupported and not widely used. In general, use of a more modern toolkit such as GTK+ is recommended. More information about X.Org can be found at: <URL:http://www.X.org> This module can be found at git://anongit.freedesktop.org/git/xorg/lib/libXaw

Alternatives

    Download

    Source package: libxaw

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libxaw7 deb package:
      # sudo apt-get install libxaw7

    Files

    • /usr/lib/x86_64-linux-gnu/libXaw.so.7
    • /usr/lib/x86_64-linux-gnu/libXaw7.so.7
    • /usr/lib/x86_64-linux-gnu/libXaw7.so.7.0.0
    • /usr/share/doc/libxaw7/changelog.Debian.amd64.gz
    • /usr/share/doc/libxaw7/changelog.Debian.gz
    • /usr/share/doc/libxaw7/changelog.gz
    • /usr/share/doc/libxaw7/copyright

    Changelog

    2014-07-12 - Julien Cristau <jcristau@debian.org> libxaw (2:1.0.12-2) unstable; urgency=medium * Fix typo in package description (closes: #736829). Thanks, darkestkhan! * Rewrite debian/rules to use dh. Bump debhelper compat and build-dep to 9. Use dh-autoreconf.

    2014-01-20 - Julien Cristau <jcristau@debian.org> libxaw (2:1.0.12-1) unstable; urgency=medium * New upstream release. * Fix build with -Werror=format-security, and enable it. * Remove Drew Parsons and Cyril Brulebois from Uploaders.

    2013-06-16 - Julien Cristau <jcristau@debian.org> libxaw (2:1.0.11-1) unstable; urgency=low * New upstream release. * Bump debhelper compat level to 7. * Use dpkg-buildflags, disable -Werror=format-security since that causes FTBFS. * Disable silent rules. * Remove ed from Build-Depends, no longer needed. * Get rid of debian/xsfbs, use /usr/share/quilt/quilt.make for patch/unpatch rules.

    2012-04-11 - Julien Cristau <jcristau@debian.org> libxaw (2:1.0.10-2) unstable; urgency=low * *sigh* add missing Replaces/Breaks on libxaw7-dev for the new -doc package. Some day I'll remember to add those the first time.

    2012-04-11 - Julien Cristau <jcristau@debian.org> libxaw (2:1.0.10-1) unstable; urgency=low * New upstream release. - Build fix for -Werror=pointer-to-int-cast (closes: #664934) * Split documentation to a new libxaw-doc package. * Fix up 01_Xaw_StripChart_fix.diff for new version. * Don't require (fake)root for debian/rules clean. * libxaw7-dev is now m-a: same, libxaw-doc m-a: foreign.

    2011-10-21 - Steve Langasek <vorlon@debian.org> libxaw (2:1.0.9-3) unstable; urgency=low * Build for multiarch.

    2011-02-06 - Julien Cristau <jcristau@debian.org> libxaw (2:1.0.9-2) unstable; urgency=low * Bump Standards-Version to 3.9.1. * Drop Pre-Depends on x11-common, only needed for upgrades from sarge. * Drop Conflicts/Replaces on libxaw6-dev, libxaw8-dev, libxaw-headers, last shipped in etch. * Remove David Nusinow and Brice Goglin from Uploaders. Thanks for your work! * Wrap debian/control Depends fields.

    2011-01-12 - Cyril Brulebois <kibi@debian.org> libxaw (2:1.0.9-1) experimental; urgency=low * New upstream release. * Noticeable change: xaw6.pc now only has xmu in Requires.private, no longer in Requires. Since it might trigger some FTBFS, target experimental. Better be safe than sorry.

    2010-11-06 - Cyril Brulebois <kibi@debian.org> libxaw (2:1.0.8-2) unstable; urgency=low [ Julien Cristau ] * Revert addition of libXaw.so to libxaw7.install, done by mistake in the previous revision. That file belongs in the -dev package and is already in libxaw7-dev.links (closes: #602620). Delete the link in debian/rules install instead, to avoid dh_install complaints. [ Cyril Brulebois ] * Lose the git push race, thank Alex Goebel for the report, and upload.

    2010-11-06 - Cyril Brulebois <kibi@debian.org> libxaw (2:1.0.8-1) unstable; urgency=low [ Julien Cristau ] * Update debian/copyright from upstream COPYING. * Rename the build directory to not include DEB_BUILD_GNU_TYPE for no good reason. Thanks, Colin Watson! * Remove myself from Uploaders [ Cyril Brulebois ] * New upstream release. * Bump the build-dep on xutils-dev for new macros. * Add myself to Uploaders. * Remove --disable-xaw8, removed upstream between 1.0.4 and 1.0.5. * Add xmlto, xorg-sgml-doctools, and w3m build-dep for the specs. * Replace --enable-docs with --with-xmlto and --without-fop (we want html and txt only). * Kill *.xml in the doc directory, no point in shipping them. * Switch from --list-missing to --fail-missing for additional safety. * Add usr/lib/libXaw.so to libxaw7-dev.install, it wouldn't be installed otherwise. * Refresh patch.

    Advertisement
    Advertisement