libx86-1_1.1+ds1-10_amd64.deb


Advertisement

Description

libx86-1 - x86 real-mode library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libx86-1
Package version 1.1+ds1
Package release 10
Package architecture amd64
Package type deb
Installed size 234 B
Download size 83.79 KB
Official Mirror ftp.br.debian.org
A library to provide support for making real-mode calls x86 calls. On x86
hardware, vm86 mode is used. On other platforms, x86 emulation is provided.
This package contains the shared library.

Alternatives

Package Version Architecture Repository
libx86-1_1.1+ds1-10_i386.deb 1.1+ds1 i386 Debian Main
libx86-1 - - -

Requires

Name Value
libc6 >= 2.7
multiarch-support -

Download

Type URL
Binary Package libx86-1_1.1+ds1-10_amd64.deb
Source Package libx86

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libx86-1 deb package:
    # sudo apt-get install libx86-1

Files

Path
/lib/x86_64-linux-gnu/libx86.so.1
/usr/share/doc/libx86-1/changelog.Debian.gz
/usr/share/doc/libx86-1/copyright

Changelog

2012-06-09 - Anibal Monsalve Salazar <anibal@debian.org>
libx86 (1.1+ds1-10) unstable; urgency=low
* Build with x86emu
Patch by Evgeni Golov
Closes: #492470
2012-06-08 - Anibal Monsalve Salazar <anibal@debian.org>
libx86 (1.1+ds1-9) unstable; urgency=low
* Build architectures are any-i386 and any-amd64 only
Closes: #654399, #570676, #398249
* Comment out "export DEB_BUILD_MAINT_OPTIONS = hardening=+all"
Closes: #676584
2012-06-05 - Anibal Monsalve Salazar <anibal@debian.org>
libx86 (1.1+ds1-8) unstable; urgency=low
* Debian source format is 3.0 (quilt)
* Standards version is 3.9.3
* DH compatibility level is 9
* Add multiarch support
* Use hardening options
* Fix typo in Vcs-Browser
Patch by Jakub Wilk
Closes: #634832
2011-07-01 - Anibal Monsalve Salazar <anibal@debian.org>
libx86 (1.1+ds1-7) unstable; urgency=low
* Fix debian-rules-missing-recommended-target
* Fix out-of-date-standards-version
2009-09-12 - Anibal Monsalve Salazar <anibal@debian.org>
libx86 (1.1+ds1-6) unstable; urgency=low
* New maintainer
Closes: 546252
* Fix out-of-date-standards-version
* Fix patch-system-but-no-source-readme
2009-09-12 - David Paleino <d.paleino@gmail.com>
libx86 (1.1+ds1-5) unstable; urgency=low
* Orphaning the package.
2009-06-23 - David Paleino <d.paleino@gmail.com>
libx86 (1.1+ds1-4) unstable; urgency=medium
* debian/patches/series:
- disable 01-update_lrmi.patch, 0.10 dropped support for anything
!x86, asked upstream to take a look and eventually update the
base source code (Closes: #533259)
- 01-fix_processor_flags.patch re-added.
* debian/patches/01-fix_processor_flags.patch: description added
* debian/control: Standards-Version bumped to 3.8.2 (no changes needed)
2009-06-12 - David Paleino <d.paleino@gmail.com>
libx86 (1.1+ds1-3) unstable; urgency=low
* debian/watch updated to use dversionmangle
* debian/patches/:
- 00-fix_Makefile.patch: description added
- 01-fix_processor_flags.patch removed, merged in LRMI upstream
- 01-update_lrmi.patch added, LRMI updated to 0.10
* debian/README.Debian-source updated with information about quilt
* debian/control:
- removed duplicate Section fields
- extended long description for libx86-1 (make lintian happy)
- debhelper B-D bumped to >= 7.0.50
- quilt B-D bumped to >= 0.46-7~ to use --with quilt in debian/rules
- added ${misc:Depends} to libx86-dev dependencies
- packaging moved to git, updating Vcs-* fields
- DMUA set
- Standards-Version bumped to 3.8.1 (no changes needed)
- put libx86-dbg into "debug" Section
* debian/rules:
- updated to dh7
- don't uselessly try to parallel-build it... (fixes FTBFS with dh7
layout)
- use --with quilt
* debian/compat bumped to 7
* debian/copyright updated
2008-06-26 - David Paleino <d.paleino@gmail.com>
libx86 (1.1+ds1-2) unstable; urgency=low
* Disable the x86emu backend for lpia architecture (Closes: #488100)
* debian/patches/:
- 01-fix_processor_flags.patch added, Linux 2.6.26-rc1 and newer no
longer define *_MASK; use X86_EFLAGS_* instead (thanks to Colin
Watson) (Closes: #488101)
* debian/control:
- Standards-Version bumped to 3.8.0:
+ debian/rules improved to allow parallel building $(MAKE) jobs.
2008-05-30 - David Paleino <d.paleino@gmail.com>
libx86 (1.1+ds1-1) unstable; urgency=low
* New upstream release
- fix mmap() call, which segfaulted on NX-capable kernels/arches
- handle reading addresses that are outside the process range with
the x86emu backend
* Make libx86 build again on Arch: any (Closes: #478186)
- debian/rules updated
- debian/control updated
* debian/patches:
- 00-fix_Makefile.patch updated
- 01-read_addresses_outside_process_range_x86emu.patch removed, applied
upstream.
- 02-fix_memory_mmap_flags.patch removed, applied upstream.

See Also

Package Description
libx86-dev_1.1+ds1-10_amd64.deb x86 real-mode library - development files
libx86emu-dev_1.4-2_amd64.deb x86 emulation library (development files)
libx86emu1_1.4-2_amd64.deb x86 emulation library
libxalan-c-dev_1.11-5_amd64.deb XSLT processor library for C++ [development]
libxalan-c-doc_1.11-5_all.deb XSLT processor library for C++ [development docs]
libxalan-c111_1.11-5_amd64.deb XSLT processor library for C++
libxalan2-java-doc_2.7.1-9_all.deb Documentation and examples for the Xalan-Java XSLT processor
libxalan2-java_2.7.1-9_all.deb XSL Transformations (XSLT) processor in Java
libxapian-dev_1.2.19-1+deb8u1_amd64.deb Development files for Xapian search engine library
libxapian22_1.2.19-1+deb8u1_amd64.deb Search engine library
libxapool-java_1.5.0-3_all.deb connection pooling for JDBC
libxatracker-dev_10.3.2-1+deb8u1_amd64.deb X acceleration library -- development files
libxatracker2_10.3.2-1+deb8u1_amd64.deb X acceleration library -- runtime
libxau-dev_1.0.8-1_amd64.deb X11 authorisation library (development headers)
libxau6_1.0.8-1_amd64.deb X11 authorisation library
Advertisement
Advertisement