libwnck-3-0_3.4.9-3_amd64.deb


Advertisement

Description

libwnck-3-0 - Window Navigator Construction Kit - runtime files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libwnck-3-0
Package version 3.4.9
Package release 3
Package architecture amd64
Package type deb
Installed size 334 B
Download size 143.59 KB
Official Mirror ftp.br.debian.org
A library to use for writing pagers and task lists.
This package contains runtime files.

Alternatives

Package Version Architecture Repository
libwnck-3-0_3.4.9-3_i386.deb 3.4.9 i386 Debian Main
libwnck-3-0 - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.14
libcairo2 >= 1.2.4
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.37.3
libgtk-3-0 >= 3.4
libpango-1.0-0 >= 1.14.0
libstartup-notification0 >= 0.4
libwnck-3-common -
libx11-6 -
libxres1 -
multiarch-support -

Download

Type URL
Binary Package libwnck-3-0_3.4.9-3_amd64.deb
Source Package libwnck3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwnck-3-0 deb package:
    # sudo apt-get install libwnck-3-0

Files

Path
/usr/lib/x86_64-linux-gnu/libwnck-3.so.0
/usr/lib/x86_64-linux-gnu/libwnck-3.so.0.2.2
/usr/share/doc/libwnck-3-0/AUTHORS
/usr/share/doc/libwnck-3-0/NEWS.gz
/usr/share/doc/libwnck-3-0/README
/usr/share/doc/libwnck-3-0/changelog.Debian.gz
/usr/share/doc/libwnck-3-0/changelog.gz
/usr/share/doc/libwnck-3-0/copyright

Changelog

2014-10-22 - Dmitry Shachnev <mitya57@debian.org>
libwnck3 (3.4.9-3) unstable; urgency=medium
* Backport two patches from upstream Git:
- To make get_workspace_rect() skip invalid rectangles.
- To fix missing icon in tasklist button.
2014-09-25 - Iain Lane <iain@orangesquash.org.uk>
libwnck3 (3.4.9-2) unstable; urgency=medium
* Install typelib file into MA libdir and mark gir package as M-A: same.
* Don't duplicate gnome-pkg-tools BD, thanks Lintian.
2014-09-13 - Andreas Henriksson <andreas@fatal.se>
libwnck3 (3.4.9-1) unstable; urgency=medium
* New upstream release.
* Drop patches from upstream now included in release:
- debian/patches/git_support_gtk_frame_extents.patch
- debian/patches/git_window_action_menu_dispose_events.patch
* Use DEB_DH_AUTORECONF_ARGS instead of patching ltmain manually.
- drop debian/patches/99_ltmain_as-needed.patch
* Disable debian/patches/02_moveresize_static_gravity.patch
- No mention of when/why this was introduced in debian/changelog
- Referenced upstream bug report has the original patch author
explain why this patch is not correct.
- Disable this until someone picks up the work upstream and figure
out which problem this is actually solving and making sure
that it doesn't introduce other problems.
- See https://bugzilla.gnome.org/show_bug.cgi?id=638483
2014-08-05 - Martin Pitt <mpitt@debian.org>
libwnck3 (3.4.7-3) unstable; urgency=medium
* Add git_support_gtk_frame_extents.patch: Add support for
_GTK_FRAME_EXTENTS. Patch taken from upstream git.
2014-08-05 - Martin Pitt <mpitt@debian.org>
libwnck3 (3.4.7-2) unstable; urgency=medium
* Build using dh-autoreconf, for supporting newer architectures.
(Closes: #757027)
* Enable Multi-Arch.
* Add debian/patches/git_window_action_menu_dispose_events.patch: Fix
objects to get finalized correctly, making sure the internal idle into
WnckActionMenu gets stopped. Patch taken from upstream git.
(LP: #1191853)
* debian/copyright: Reformat for 1.0 standard.
* Bump to Standards-Version 3.9.5.
2013-08-28 - Michael Biebl <biebl@debian.org>
libwnck3 (3.4.7-1) unstable; urgency=low
* New upstream release.
* Remove debian/patches/01_tasklist_orientation.patch, merged upstream.
* Update symbols file.
* Drop obsolete Replaces: gir-repository-dev (<< 0.6.5-7).
2013-06-05 - Michael Biebl <biebl@debian.org>
libwnck3 (3.4.5-1) unstable; urgency=low
* New upstream release.
* Refresh patches.
* Update symbols file.
* Bump required version of libglib2.0-dev to (>= 2.32) and libgtk-3-dev
to (>= 3.4).
* Bump Standards-Version to 3.9.4. No further changes.
* Add Build-Depends on autotools-dev as lintian was complaining about
outdated config.{guess,sub}.
2012-05-14 - Michael Biebl <biebl@debian.org>
libwnck3 (3.4.2-1) unstable; urgency=low
* New upstream release.
- Fix mouse wheel scrolling with new GTK+ in pager and task selector.
Closes: #669961
* Refresh debian/patches/01_tasklist_orientation.patch.
* Drop explicit Build-Depends on gir packages.
* Bump Standards-Version t 3.9.3.
* Update Vcs-* URLs.
2012-03-28 - Michael Biebl <biebl@debian.org>
libwnck3 (3.4.0-1) unstable; urgency=low
* New upstream release.
* Change section of gir1.2-wnck-3.0 to introspection.
* debian/libwnck-3-0.symbols: Add new symbol.
* debian/rules: Drop clean-la.mk since we don't install any .la files
anymore.
* debian/control.in: Update (Build-)Depends according to configure.ac.
2011-10-19 - Michael Biebl <biebl@debian.org>
libwnck3 (3.2.1-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
libwnck-3-common_3.4.9-3_all.deb Window Navigator Construction Kit - common files
libwnck-3-dev_3.4.9-3_amd64.deb Window Navigator Construction Kit - development files
libwnck-common_2.30.7-2_all.deb Window Navigator Construction Kit - common files
libwnck-dev_2.30.7-2_amd64.deb Window Navigator Construction Kit - development files
libwnck1.0-cil-dev_2.26.0-8_amd64.deb CLI binding for wnck 2.24
libwnck2.20-cil_2.26.0-8_amd64.deb CLI binding for wnck 2.24
libwnck22_2.30.7-2_amd64.deb Window Navigator Construction Kit - runtime files
libwnckmm-1.0-0-dev_0.1.1-1+deb8u1_amd64.deb Development files for the C++ wrapper to libwnck
libwnckmm-1.0-0_0.1.1-1+deb8u1_amd64.deb This package provides a C++ wrapper to libwnck
libwnn-dev_1.1.1~a021+cvs20130302-4_amd64.deb Header files and static libraries for Wnn (FreeWnn jserver)
libwnn0_1.1.1~a021+cvs20130302-4_amd64.deb FreeWnn library for Wnn (FreeWnn jserver)
libwnn6-1_1.0.0-18_amd64.deb Wnn6 client library
libwnn6-dev_1.0.0-18_amd64.deb Header files and static library for Wnn6 client library
libwombatcommon0_2.2.2.1-10_amd64.deb message oriented middleware - Wombat utility libraries
libwombatcommoncpp0_2.2.2.1-10_amd64.deb message oriented middleware - Wombat utility libraries (C++)
Advertisement
Advertisement