libweb-simple-perl_0.030-1_all.deb


Advertisement

Description

libweb-simple-perl - simple web framework

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libweb-simple-perl
Package version 0.030
Package release 1
Package architecture all
Package type deb
Installed size 210 B
Download size 60.63 KB
Official Mirror ftp.br.debian.org
Web::Simple provides a bare minimum system for writing web applications that
don't need a full-fledged web framework.
The philosophy of Web::Simple is to keep to an absolute bare minimum, for
everything. It is not designed to be used for large scale applications; the
Catalyst web framework already works very nicely for that and is a far more
mature, well supported piece of software.
However, if you have an application that only does a couple of things, and
want to not have to think about complexities of deployment, then Web::Simple
might be just the thing for you.

Alternatives

Package Version Architecture Repository
libweb-simple-perl_0.030-1_all.deb 0.030 all Debian Main
libweb-simple-perl - - -

Requires

Name Value
libmoo-perl -
libplack-perl >= 0.9968
libstrictures-perl -
libsyntax-keyword-gather-perl -
libwarnings-illegalproto-perl -
perl -

Download

Type URL
Binary Package libweb-simple-perl_0.030-1_all.deb
Source Package libweb-simple-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libweb-simple-perl deb package:
    # sudo apt-get install libweb-simple-perl

Files

Path
/usr/share/doc/libweb-simple-perl/changelog.Debian.gz
/usr/share/doc/libweb-simple-perl/changelog.gz
/usr/share/doc/libweb-simple-perl/copyright
/usr/share/doc/libweb-simple-perl/examples/bloggery/bloggery.cgi
/usr/share/doc/libweb-simple-perl/examples/bloggery/posts/Another-Post.html
/usr/share/doc/libweb-simple-perl/examples/bloggery/posts/One-Post.html
/usr/share/doc/libweb-simple-perl/examples/bloggery/posts/One-Post.summary.html
/usr/share/doc/libweb-simple-perl/examples/dispatchex/dispatchex.cgi
/usr/share/doc/libweb-simple-perl/examples/golf/golf.cgi
/usr/share/doc/libweb-simple-perl/examples/hello-world/hello-world.cgi
/usr/share/man/man3/Web::Dispatch::HTTPMethods.3pm.gz
/usr/share/man/man3/Web::Simple.3pm.gz
/usr/share/man/man3/Web::Simple::AntiquatedPerl.3pm.gz
/usr/share/man/man3/Web::Simple::Application.3pm.gz
/usr/share/man/man3/Web::Simple::Deployment.3pm.gz
/usr/share/man/man3/Web::Simple::Role.3pm.gz
/usr/share/perl5/CSS/Declare.pm
/usr/share/perl5/HTML/Tags.pm
/usr/share/perl5/Plack/Middleware/Dispatch.pm
/usr/share/perl5/Web/Dispatch.pm
/usr/share/perl5/Web/Simple.pm
/usr/share/perl5/Web/Dispatch/HTTPMethods.pm
/usr/share/perl5/Web/Dispatch/Node.pm
/usr/share/perl5/Web/Dispatch/ParamParser.pm
/usr/share/perl5/Web/Dispatch/Parser.pm
/usr/share/perl5/Web/Dispatch/Predicates.pm
/usr/share/perl5/Web/Dispatch/ToApp.pm
/usr/share/perl5/Web/Dispatch/Upload.pm
/usr/share/perl5/Web/Dispatch/Wrapper.pm
/usr/share/perl5/Web/Simple/AntiquatedPerl.pod
/usr/share/perl5/Web/Simple/Application.pm
/usr/share/perl5/Web/Simple/Deployment.pod
/usr/share/perl5/Web/Simple/HackedPlack.pm
/usr/share/perl5/Web/Simple/Role.pm
/usr/share/perl5/XML/Tags.pm

Changelog

2014-08-12 - gregor herrmann <gregoa@debian.org>
libweb-simple-perl (0.030-1) unstable; urgency=medium
* New upstream releases 0.029, 0.030.
2014-07-12 - gregor herrmann <gregoa@debian.org>
libweb-simple-perl (0.028-1) unstable; urgency=medium
* New upstream release.
* Update (build) dependencies.
2014-07-04 - gregor herrmann <gregoa@debian.org>
libweb-simple-perl (0.024-1) unstable; urgency=medium
* New upstream release.
* Drop pod-whatis.patch, fixed upstream.
2014-05-24 - gregor herrmann <gregoa@debian.org>
libweb-simple-perl (0.023-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream releases 0.021, 0.023.
* Update debian/copyright.
Add new copyright holders, bump years of packaging copyright.
* Replace pod_fragment.patch with an override in debian/rules.
* Add patch to fix POD (missing whatis entry).
* Declare compliance with Debian Policy 3.9.5.
2012-08-07 - Nuno Carvalho <smash@cpan.org>
libweb-simple-perl (0.020-1) unstable; urgency=low
* Team upload.
[ Nuno Carvalho ]
* New upstream release.
[ gregor herrmann ]
* Add new upstream copyright holder.
2012-05-14 - Fabrizio Regalli <fabreg@fabreg.it>
libweb-simple-perl (0.016-1) unstable; urgency=low
* Imported Upstream version 0.016
2012-05-04 - Fabrizio Regalli <fabreg@fabreg.it>
libweb-simple-perl (0.014-1) unstable; urgency=low
* Imported Upstream version 0.014
* debian/copyright: add year 2012 to debian/* files
2012-04-05 - gregor herrmann <gregoa@debian.org>
libweb-simple-perl (0.013-1) unstable; urgency=low
* New upstream release.
* Bump Standards-Version to 3.9.3 (no changes).
* debian/copyright: update to Copyright-Format 1.0.
2012-02-07 - gregor herrmann <gregoa@debian.org>
libweb-simple-perl (0.012-1) unstable; urgency=low
* New upstream release.
* Update list of copyright holders and years.
2011-12-23 - gregor herrmann <gregoa@debian.org>
libweb-simple-perl (0.011-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
libwebauth-dev_4.6.1-1+b1_amd64.deb Development files for WebAuth authentication
libwebauth-perl_4.6.1-1+b1_amd64.deb Perl library for WebAuth authentication
libwebauth11_4.6.1-1+b1_amd64.deb Shared libraries for WebAuth authentication
libwebcam0-dev_0.2.4-1.1_amd64.deb Webcam Library - Development files
libwebcam0_0.2.4-1.1_amd64.deb Webcam Library
libwebinject-perl_1.86-1_all.deb Perl Module for testing web services
libwebkdc-perl_4.6.1-1_all.deb Perl libraries for WebAuth central login server
libwebkit-cil-dev_0.3-6_all.deb CLI binding for the WebKit library - development package
libwebkit-dev_2.4.9-1~deb8u1_all.deb Transitional package for the development files of WebKitGTK+
libwebkit1.1-cil_0.3-6_all.deb CLI binding for the WebKit library
libwebkit2gtk-3.0-25_2.4.9-1~deb8u1_amd64.deb WebKit2 API layer for WebKitGTK+
libwebkit2gtk-3.0-dev_2.4.9-1~deb8u1_amd64.deb WebKit2 API layer for WebKitGTK+ - development files
libwebkit2gtk-4.0-37_2.6.2+dfsg1-4_amd64.deb Web content engine library for GTK+
libwebkit2gtk-4.0-dev_2.6.2+dfsg1-4_amd64.deb Web content engine library for GTK+ - development files
libwebkit2gtk-4.0-doc_2.6.2+dfsg1-4_all.deb Web content engine library for GTK+ - documentation
Advertisement
Advertisement