libwarnings-illegalproto-perl_0.001003-1_all.deb


Advertisement

Description

libwarnings-illegalproto-perl - pragma to disable illegal prototype warnings on old Perls

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libwarnings-illegalproto-perl
Package version 0.001003
Package release 1
Package architecture all
Package type deb
Installed size 47 B
Download size 5.87 KB
Official Mirror ftp.br.debian.org
warnings::illegalproto was implemented so that people can use strictures and
use signatures at the same time. Thanks to mst, in Perl 5.12 and greater this
is trivial, but before that a strange dance had to be done.

Alternatives

Package Version Architecture Repository
libwarnings-illegalproto-perl_0.001003-1_all.deb 0.001003 all Debian Main
libwarnings-illegalproto-perl - - -

Requires

Name Value
libstrictures-perl -
perl -

Download

Type URL
Binary Package libwarnings-illegalproto-perl_0.001003-1_all.deb
Source Package libwarnings-illegalproto-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwarnings-illegalproto-perl deb package:
    # sudo apt-get install libwarnings-illegalproto-perl

Files

Path
/usr/share/doc/libwarnings-illegalproto-perl/changelog.Debian.gz
/usr/share/doc/libwarnings-illegalproto-perl/changelog.gz
/usr/share/doc/libwarnings-illegalproto-perl/copyright
/usr/share/man/man3/warnings::illegalproto.3pm.gz
/usr/share/perl5/warnings/illegalproto.pm

Changelog

2014-07-25 - gregor herrmann <gregoa@debian.org>
libwarnings-illegalproto-perl (0.001003-1) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
* Remove Maximilian Gaß from Uploaders (no more active according to himself)
[ Florian Schlichting ]
* Imported Upstream version 0.001001
* Update year of upstream copyright
* Bump Standards-Version to 3.9.4 (no change)
[ gregor herrmann ]
* New upstream release 0.001003.
* Strip trailing slash from metacpan URLs.
* Update year of upstream copyright.
* Add /me to Uploaders.
* Declare compliance with Debian Policy 3.9.5.
2011-02-25 - Maximilian Gass <mxey@cloudconnected.org>
libwarnings-illegalproto-perl (0.001000-1) unstable; urgency=low
* Initial Release (closes: #615106).

See Also

Package Description
libwavpack-dev_4.70.0-1_amd64.deb audio codec (lossy and lossless) - development files
libwavpack1_4.70.0-1_amd64.deb audio codec (lossy and lossless) - library
libwayland-client0_1.6.0-2_amd64.deb wayland compositor infrastructure - client library
libwayland-cursor0_1.6.0-2_amd64.deb wayland compositor infrastructure - cursor library
libwayland-dev_1.6.0-2_amd64.deb wayland compositor infrastructure - development files
libwayland-egl1-mesa_10.3.2-1+deb8u1_amd64.deb implementation of the Wayland EGL platform -- runtime
libwayland-server0_1.6.0-2_amd64.deb wayland compositor infrastructure - server library
libwbclient-dev_4.2.14+dfsg-0+deb8u9_amd64.deb Samba winbind client library - development files
libwbclient0_4.2.14+dfsg-0+deb8u9_amd64.deb Samba winbind client library
libwbxml2-0_0.10.7-1_amd64.deb WBXML parsing and encoding library
libwbxml2-dev_0.10.7-1_amd64.deb WBXML library development file
libwbxml2-utils_0.10.7-1_amd64.deb Binary XML utilities
libwcat1-dev_1.1-1_amd64.deb Process monitoring library
libwcat1_1.1-1_amd64.deb Process monitoring library
libwcs4_4.24-1_amd64.deb Implementation of the FITS WCS standard
Advertisement
Advertisement