libwant-perl_0.23-1+b1_amd64.deb


Advertisement

Description

libwant-perl - generalisation of wantarray

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libwant-perl
Package version 0.23
Package release 1+b1
Package architecture amd64
Package type deb
Installed size 54 B
Download size 26.84 KB
Official Mirror ftp.br.debian.org
The Want module generalises the mechanism of the wantarray function,
allowing a function to determine in some detail how its return value
is going to be immediately used.

Alternatives

Package Version Architecture Repository
libwant-perl_0.23-1+b1_i386.deb 0.23 i386 Debian Main
libwant-perl - - -

Requires

Name Value
libc6 >= 2.4
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libwant-perl_0.23-1+b1_amd64.deb
Source Package libwant-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwant-perl deb package:
    # sudo apt-get install libwant-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Want.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Want/Want.so
/usr/share/doc/libwant-perl/TODO
/usr/share/doc/libwant-perl/changelog.Debian.amd64.gz
/usr/share/doc/libwant-perl/changelog.Debian.gz
/usr/share/doc/libwant-perl/changelog.gz
/usr/share/doc/libwant-perl/copyright
/usr/share/man/man3/Want.3pm.gz

Changelog

2014-04-11 - Florian Schlichting <fsfs@debian.org>
libwant-perl (0.23-1) unstable; urgency=medium
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Florian Schlichting ]
* Import Upstream version 0.23
2013-12-23 - Florian Schlichting <fsfs@debian.org>
libwant-perl (0.22-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Florian Schlichting ]
* Import Upstream version 0.22
* Email change: Florian Schlichting -> fsfs@debian.org
* Bump years of packaging copyright
* Fix debhelper version needed for Perl hardening support
* Declare compliance with Debian Policy 3.9.5
2012-03-04 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libwant-perl (0.21-1) unstable; urgency=low
* Imported Upstream version 0.21.
* Bumped year of upstream copyright.
* Bumped Standards-Version to 3.9.3 (use copyright-format 1.0).
* Added myself to Uploaders and copyright.
2012-02-11 - gregor herrmann <gregoa@debian.org>
libwant-perl (0.20-1) unstable; urgency=low
[ Ansgar Burchardt ]
* Email change: Ansgar Burchardt -> ansgar@debian.org
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* New upstream release.
* Switch to "3.0 (quilt)" source format.
* debian/copyright: update formatting.
* Remove version from perl build dependency.
* Bump Standards-Version to 3.9.2 (no further changes).
* Switch to debhelper compatibility level 9 to pass CFLAGS to
Makefile.PL/Build.PL.
2009-07-21 - Ansgar Burchardt <ansgar@43-1.org>
libwant-perl (0.18-2) unstable; urgency=low
[ gregor herrmann ]
* Take over for the Debian Perl Group on maintainer's request
(http://lists.debian.org/debian-perl/2008/03/msg00055.html)
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Changed:
Maintainer set to Debian Perl Group <pkg-perl-
maintainers@lists.alioth.debian.org> (was: Florian Weimer
<fw@deneb.enyo.de>)
* Add debian/watch.
* Add /me to Uploaders.
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* Refresh rules for debhelper 7.
* Do no longer install README (excerpt of POD documentation).
* Add myself to Uploaders.
* Bump Standards-Version to 3.8.2.
* Convert debian/copyright to proposed machine-readable format.
2008-02-27 - Florian Weimer <fw@deneb.enyo.de>
libwant-perl (0.18-1) unstable; urgency=low
* New upstream version.
* Support building with MakeMaker from perl5.10.  Closes: #463558.
2005-11-08 - Florian Weimer <fw@deneb.enyo.de>
libwant-perl (0.09-1) unstable; urgency=low
* New upstream version.
2004-12-26 - Florian Weimer <fw@deneb.enyo.de>
libwant-perl (0.08-1) unstable; urgency=low
* New upstream version.
2004-08-05 - Florian Weimer <fw@deneb.enyo.de>
libwant-perl (0.07-2) unstable; urgency=low
* Fix build dependencies.  Closes: #263765.
2004-07-13 - Florian Weimer <fw@deneb.enyo.de>
libwant-perl (0.07-1) unstable; urgency=low
* Initial Release.  Closes: #259153.

See Also

Package Description
libwarnings-illegalproto-perl_0.001003-1_all.deb pragma to disable illegal prototype warnings on old Perls
libwavpack-dev_4.70.0-1_amd64.deb audio codec (lossy and lossless) - development files
libwavpack1_4.70.0-1_amd64.deb audio codec (lossy and lossless) - library
libwayland-client0_1.6.0-2_amd64.deb wayland compositor infrastructure - client library
libwayland-cursor0_1.6.0-2_amd64.deb wayland compositor infrastructure - cursor library
libwayland-dev_1.6.0-2_amd64.deb wayland compositor infrastructure - development files
libwayland-egl1-mesa_10.3.2-1+deb8u1_amd64.deb implementation of the Wayland EGL platform -- runtime
libwayland-server0_1.6.0-2_amd64.deb wayland compositor infrastructure - server library
libwbclient-dev_4.2.14+dfsg-0+deb8u9_amd64.deb Samba winbind client library - development files
libwbclient0_4.2.14+dfsg-0+deb8u9_amd64.deb Samba winbind client library
libwbxml2-0_0.10.7-1_amd64.deb WBXML parsing and encoding library
libwbxml2-dev_0.10.7-1_amd64.deb WBXML library development file
libwbxml2-utils_0.10.7-1_amd64.deb Binary XML utilities
libwcat1-dev_1.1-1_amd64.deb Process monitoring library
libwcat1_1.1-1_amd64.deb Process monitoring library
Advertisement
Advertisement