libvtk5.8-qt4_5.8.0-17.5_amd64.deb


Advertisement

Description

libvtk5.8-qt4 - Visualization Toolkit - A high level 3D visualization library - Qt runtime

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package filename libvtk5.8-qt4_5.8.0-17.5_amd64.deb
Package name libvtk5.8-qt4
Package version 5.8.0
Package release 17.5
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://www.vtk.org/
License -
Maintainer Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Download size 406.83 KB
Installed size 1.54 MB
The Visualization Toolkit (VTK) is an object oriented, high level
library that allows one to easily write C++ programs, Tcl, Python and
Java scripts that do 3D visualization.
This package provides the VTK GUI support for Qt4.

Alternatives

Package Version Architecture Repository
libvtk5.8-qt4_5.8.0-17.5_i386.deb 5.8.0 i386 Debian Main
libvtk5.8-qt4_5.8.0-7+b0~nd70+1_i386.deb 5.8.0 i386 NeuroDebian Main
libvtk5.8-qt4_5.8.0-7+b0~nd70+1_amd64.deb 5.8.0 amd64 NeuroDebian Main
libvtk5.8-qt4 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libqt4-sql >= 4:4.5.3
libqtcore4 >= 4:4.7.0~beta1
libqtgui4 >= 4:4.8.0
libstdc++6 >= 4.4.0
libvtk5.8 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libvtk5.8-qt4_5.8.0-17.5_amd64.deb
Source Package vtk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libvtk5.8-qt4 deb package:
    # sudo apt-get install libvtk5.8-qt4

Files

Path
/usr/lib/libQVTK.so.5.8
/usr/lib/libQVTK.so.5.8.0
/usr/lib/libvtkQtChart.so.5.8
/usr/lib/libvtkQtChart.so.5.8.0
/usr/share/doc/libvtk5.8-qt4/changelog.Debian.gz
/usr/share/doc/libvtk5.8-qt4/copyright
/usr/share/lintian/overrides/libvtk5.8-qt4

Changelog

2014-10-19 - Ondřej Surý <ondrej@debian.org>
vtk (5.8.0-17.5) unstable; urgency=medium
* Non-maintainer upload
* Also define GLX_GLEXT_LEGACY when defining GL_GLEXT_LEGACY (Closes: #765925)
2014-09-13 - Olly Betts <olly@survex.com>
vtk (5.8.0-17.4) unstable; urgency=medium
* Non-maintainer upload.
* Update for wxPython 3.0 (Closes: #761414):
- New patch: wxpython3.0.patch
2014-06-25 - Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
vtk (5.8.0-17.3) unstable; urgency=medium
* Non-maintainer upload.
[ Colin Watson]
* Look for PostgreSQL libraries in multiarch locations (closes: #751130).
2014-05-17 - Sebastian Ramacher <sramacher@debian.org>
vtk (5.8.0-17.2) unstable; urgency=medium
* Non-maintainer upload.
* debian/patches/java15.patch: Remove @Override which is not supported in
Java 1.5 to build on kfreebsd-*. (Closes: #747698)
2014-05-11 - Reinhard Tartler <siretart@tauware.de>
vtk (5.8.0-17.1) unstable; urgency=medium
* Non-maintainer upload.
* Add libav10.patch to allow compilation against libav10 (Closes: #739462)
2014-05-10 - Anton Gladky <gladk@debian.org>
vtk (5.8.0-17) unstable; urgency=medium
[ Jordi Mallach ]
* Team upload.
* allpatches.patch: Force building Java 1.5 bytecode in the Java wrapper
cmakefile, which is what we want in jessie (closes: #731823).
* Add ${shlibs:Depends} to libvtk5-dev, as it contains binaries.
* Let tcl-vtk depend on tcl8.5.
[ Gianfranco Costamagna ]
* Tweak allpatches.patch to fix a missing 1.5 bytecode generation.
2014-05-10 - Anton Gladky <gladk@debian.org>
vtk (5.8.0-16) unstable; urgency=medium
[ Gianfranco Costamagna ]
* Team upload.
* [5e721d4] Change Java target to 1.5 . (Closes: #731823)
[ Anton Gladky ]
2014-04-16 - Jordi Mallach <jordi@debian.org>
vtk (5.8.0-15.1) unstable; urgency=medium
* Non-maintainer upload.
* Look for TCL and TK in the multi-arch triplet dir (closes: #724831).
* Apply patch from Julian Taylor to fix TCL underlinking (closes: #742359).
2013-12-27 - Dominique Belhachemi <domibel@debian.org>
vtk (5.8.0-15) unstable; urgency=low
* Use /usr/share/cmake-2.8/Modules/FindFreetype.cmake (Closes: #732059)
2013-08-23 - Sebastian Ramacher <sramacher@debian.org>
vtk (5.8.0-14.1) unstable; urgency=low
* Non-maintainer upload.
* debian/patches/libav9.patch: Backport patches from upstream to fix
compilation with libav 9. (Closes: #693639)

See Also

Package Description
libvtk5.8_5.8.0-17.5_amd64.deb Visualization Toolkit - A high level 3D visualization library - runtime
libvtk6-dev_6.1.0+dfsg2-6_amd64.deb VTK header files for building C++ code
libvtk6.1_6.1.0+dfsg2-6_amd64.deb Visualization Toolkit - A high level 3D visualization library - runtime
libvtkgdcm-cil_2.4.4-3+deb8u1_amd64.deb Grassroots DICOM VTK CLI bindings
libvtkgdcm-java_2.4.4-3+deb8u1_amd64.deb Grassroots DICOM VTK Java bindings
libvtkgdcm-tools_2.4.4-3+deb8u1_amd64.deb Grassroots DICOM VTK tools and utilities
libvtkgdcm2-dev_2.4.4-3+deb8u1_amd64.deb Grassroots DICOM VTK development libraries and headers
libvtkgdcm2.4_2.4.4-3+deb8u1_amd64.deb Grassroots DICOM VTK runtime libraries
libvuser-google-api-perl_1.0.1-1_all.deb Perl module that implements the Google Apps Provisioning API
libvw-dev_7.3-1.1+b1_amd64.deb fast and scalable online machine learning algorithm - development files
libvw0_7.3-1.1+b1_amd64.deb fast and scalable online machine learning algorithm - dynamic library
libvxl1-dev_1.17.0.dfsg-1+b2_amd64.deb C++ Libraries for Computer Vision Research (development files)
libvxl1.17_1.17.0.dfsg-1+b2_amd64.deb C++ Libraries for Computer Vision Research
libwacom-common_0.8-1_all.deb Wacom model feature query library (common files)
libwacom-dev_0.8-1_amd64.deb Wacom model feature query library (development files)
Advertisement
Advertisement