libversion-next-perl_0.004-1_all.deb


Advertisement

Description

libversion-next-perl - Perl module for simply incrementing Perl module version numbers

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libversion-next-perl
Package version: 0.004
Package release: 1
Package architecture: all
Package type: deb
Installed size: 55 B
Download size: 9.98 KB
Official Mirror: ftp.br.debian.org
Version::Next provides a simple, correct way to increment a Perl module version number. It does not attempt to guess what the original version number author intended, it simply increments in the smallest possible fashion. Decimals are incremented like an odometer. Dotted decimals are incremented piecewise and presented in a standardized way. If more complex version manipulation is necessary, you may wish to consider Perl::Version.

Alternatives

    Download

    Source package: libversion-next-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libversion-next-perl deb package:
      # sudo apt-get install libversion-next-perl

    Files

    • /usr/share/doc/libversion-next-perl/CONTRIBUTING
    • /usr/share/doc/libversion-next-perl/changelog.Debian.gz
    • /usr/share/doc/libversion-next-perl/changelog.gz
    • /usr/share/doc/libversion-next-perl/copyright
    • /usr/share/man/man3/Version::Next.3pm.gz
    • /usr/share/perl5/Version/Next.pm

    Changelog

    2014-03-07 - Florian Schlichting <fsfs@debian.org> libversion-next-perl (0.004-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Alessandro Ghedini ] * Email change: Alessandro Ghedini -> ghedo@debian.org [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg- copyright" [ gregor herrmann ] * Strip trailing slash from metacpan URLs. [ Florian Schlichting ] * Import Upstream version 0.004 * Bump year of upstream copyright * Ship CONTRIBUTING documentation * Bump dh compatibility to level 8 (no changes necessary) * Update stand-alone license paragraphs to commonly used version (not limiting Debian to GNU/Linux) * Declare compliance with Debian Policy 3.9.5 * Add myself to uploaders and copyright

    2011-01-02 - Alessandro Ghedini <al3xbio@gmail.com> libversion-next-perl (0.002-1) unstable; urgency=low * Initial Release. (Closes: #606855)

    Advertisement
    Advertisement