libuv0.10-dev_0.10.28-6_amd64.deb


Advertisement

Description

libuv0.10-dev - asynchronous event notification library - development files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libuv0.10-dev
Package version 0.10.28
Package release 6
Package architecture amd64
Package type deb
Installed size 421 B
Download size 87.11 KB
Official Mirror ftp.br.debian.org
Libuv is the asynchronous library behind Node.js. Very similar to libevent or
libev, it provides the main elements for event driven systems: watching and
waiting for availability in a set of sockets, and some other events like timers
or asynchronous messages. However, libuv also comes with some other extras
like:
* files watchers and asynchronous operations
* a portable TCP and UDP API, as well as asynchronous DNS resolution
* processes and threads management, and a portable inter-process
communications mechanism, with pipes and work queues
* a plugins mechanism for loading libraries dynamically
* interface with external libraries that also need to access the I/O.
Install this package if you wish to develop your own programs using the
libuv engine.

Alternatives

Package Version Architecture Repository
libuv0.10-dev_0.10.28-6_i386.deb 0.10.28 i386 Debian Main
libuv0.10-dev - - -

Requires

Name Value
libuv0.10 = 0.10.28-6

Provides

Name Value
libuv-dev -

Conflicts

Name Value
libuv-dev -

Replaces

Name Value
libuv-dev -

Download

Type URL
Binary Package libuv0.10-dev_0.10.28-6_amd64.deb
Source Package libuv

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libuv0.10-dev deb package:
    # sudo apt-get install libuv0.10-dev

Files

Path
/usr/include/uv.h
/usr/include/uv-private/ngx-queue.h
/usr/include/uv-private/stdint-msvc2008.h
/usr/include/uv-private/tree.h
/usr/include/uv-private/uv-bsd.h
/usr/include/uv-private/uv-darwin.h
/usr/include/uv-private/uv-linux.h
/usr/include/uv-private/uv-sunos.h
/usr/include/uv-private/uv-unix.h
/usr/include/uv-private/uv-win.h
/usr/lib/x86_64-linux-gnu/libuv.a
/usr/lib/x86_64-linux-gnu/libuv.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libuv.pc
/usr/share/doc/libuv0.10-dev/changelog.Debian.gz
/usr/share/doc/libuv0.10-dev/changelog.gz
/usr/share/doc/libuv0.10-dev/copyright

Changelog

2015-02-25 - Luca Bruno <lucab@debian.org>
libuv (0.10.28-6) unstable; urgency=high
* Backported: call setgroups before calling setuid/setgid
(Closes: #779173 - CVE-2015-0278)
2014-09-21 - Luca Bruno <lucab@debian.org>
libuv (0.10.28-5) unstable; urgency=medium
* Too early for versioned provides, reverted
(Closes: #762291, #762300)
2014-09-20 - Luca Bruno <lucab@debian.org>
libuv (0.10.28-4) unstable; urgency=medium
* control: provide versioned virtual package
* Fix arm64 failures due to missing epoll_wait()
2014-08-26 - Luca Bruno <lucab@debian.org>
libuv (0.10.28-3) unstable; urgency=medium
* Rename -dev package, prepare for multiple versions
* Add a libuv0.10-dev binary package
2014-08-19 - Luca Bruno <lucab@debian.org>
libuv (0.10.28-2) unstable; urgency=medium
* Testsuite is fragile on kfreebsd, ignore transient failures there
(Closes: #754756)
2014-08-16 - Luca Bruno <lucab@debian.org>
libuv (0.10.28-1) unstable; urgency=medium
* New upstream release
+ Drop patches applied upstream
2014-06-10 - Luca Bruno <lucab@debian.org>
libuv (0.10.27-2) unstable; urgency=medium
* Fix "spawn_closed_process_io" test failure
(Closes: #750301)
2014-05-10 - Luca Bruno <lucab@debian.org>
libuv (0.10.27-1) unstable; urgency=medium
* Bump Standards-Version
* New upstream release
+ Refreshed quilt patches
2014-03-02 - Luca Bruno <lucab@debian.org>
libuv (0.10.25-1) unstable; urgency=medium
* New upstream release
2014-03-02 - Luca Bruno <lucab@debian.org>
libuv (0.10.24-1) unstable; urgency=medium
* New upstream release

See Also

Package Description
libuv0.10_0.10.28-6_amd64.deb asynchronous event notification library - runtime library
libv-perl_0.13-1_all.deb module for printing the version of specified perl module(s)
libv4l-0_1.6.0-2_amd64.deb Collection of video4linux support libraries
libv4l-dev_1.6.0-2_amd64.deb Collection of video4linux support libraries (development files)
libv4l2rds0_1.6.0-2_amd64.deb Video4Linux Radio Data System (RDS) decoding library
libv4lconvert0_1.6.0-2_amd64.deb Video4linux frame format conversion library
libv8-3.14-dev_3.14.5.8-8.1_amd64.deb V8 JavaScript engine - development files for 3.14 branch
libv8-3.14.5_3.14.5.8-8.1_amd64.deb V8 JavaScript engine - runtime library
libv8-dev_3.14.5.8-8.1_amd64.deb V8 JavaScript engine - development files for latest branch
libva-dev_1.4.1-1_amd64.deb Video Acceleration (VA) API for Linux -- development files
libva-drm1_1.4.1-1_amd64.deb Video Acceleration (VA) API for Linux -- DRM runtime
libva-egl1_1.4.1-1_amd64.deb Video Acceleration (VA) API for Linux -- EGL runtime
libva-glx1_1.4.1-1_amd64.deb Video Acceleration (VA) API for Linux -- GLX runtime
libva-tpi1_1.4.1-1_amd64.deb Video Acceleration (VA) API for Linux -- TPI runtime
libva-wayland1_1.4.1-1_amd64.deb Video Acceleration (VA) API for Linux -- Wayland runtime
Advertisement
Advertisement