libuuid-perl_0.05-1+b1_amd64.deb


Advertisement

Description

libuuid-perl - Perl extension for using UUID interfaces as defined in e2fsprogs

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libuuid-perl
Package version 0.05
Package release 1+b1
Package architecture amd64
Package type deb
Installed size 82 B
Download size 10.16 KB
Official Mirror ftp.br.debian.org
libuuid generates and parses 128-bit universally unique ids (UUIDs).
See RFC 4122 for more information.
This is a Perl interface to libuuid.  It allows generation, parsing,
and unparsing of UUIDs.

Alternatives

Package Version Architecture Repository
libuuid-perl_0.05-1+b1_i386.deb 0.05 i386 Debian Main
libuuid-perl - - -

Requires

Name Value
libc6 >= 2.4
libuuid1 >= 2.16
perl-base >= 5.20.0-4
perlapi-5.20.0 -

Conflicts

Name Value
doc-base << 0.10.3

Download

Type URL
Binary Package libuuid-perl_0.05-1+b1_amd64.deb
Source Package libuuid-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libuuid-perl deb package:
    # sudo apt-get install libuuid-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/UUID.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/UUID/UUID.so
/usr/share/doc/libuuid-perl/changelog.Debian.amd64.gz
/usr/share/doc/libuuid-perl/changelog.Debian.gz
/usr/share/doc/libuuid-perl/changelog.gz
/usr/share/doc/libuuid-perl/copyright
/usr/share/lintian/overrides/libuuid-perl
/usr/share/man/man3/UUID.3pm.gz

Changelog

2013-09-08 - Axel Beckert <abe@debian.org>
libuuid-perl (0.05-1) unstable; urgency=low
[ Ansgar Burchardt ]
* Update my email address.
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* Import new upstream version (no code changes; closes: #676164)
* Rework debian/copyright. Fixes the following lintian warnings:
+ out-of-date-copyright-format-uri
+ obsolete-field-in-dep5-copyright
+ ambiguous-paragraph-in-dep5-copyright
+ copyright-refers-to-symlink-license
* Bump debhelper compatibility to 9
+ Update versioned debhelper build-dependency accordingly
+ Fixes lintian warning hardening-no-relro
* Bump Standards-Version to 3.9.4 (no further changes)
* Add the general description of libuuid from the uuid-dev package to
the long description. Fixes the lintian warning
extended-description-is-probably-too-short.
* Bump debhelper build-dependency to >= 9.20120312 (fixes pkg-perl
specific lintian warning arch-any-package-needs-newer-debhelper)
* Add lintian override for conflicts-with-version since the big hammer
in the previous upload was on purpose.
* Add myself to Uploaders and debian/copyright.
* Apply wrap-and-sort.
2012-10-14 - gregor herrmann <gregoa@debian.org>
libuuid-perl (0.02-5) unstable; urgency=low
* debian/control: conflict on doc-base << 0.10.3 to avoid package
installation failure due to symbol lookup errors when perl 5.14 and
libuuid-perl get unpacked and trigger the old doc-base.
Thanks to Martin Pitt for testing this in Ubuntu, Niko Tyni for the
initial analysis, and Stuart Prescott for further triaging.
(Closes: #652638) (LP: #902553)
2010-07-08 - Ansgar Burchardt <ansgar@43-1.org>
libuuid-perl (0.02-4) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
* debian/control: remove Clint Adams from Uploaders at his request.
* debian/control: change my email address.
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* Use debhelper.
* Depend on perl-base instead of the full perl package. (Closes: #588427)
* debian/control: Make build-dep on perl unversioned.
* Use source format 3.0 (quilt).
* Convert debian/copyright to proposed machine-readable format.
* Bump Standards-Version to 3.9.0.
* Add myself to Uploaders.
2008-02-03 - gregor herrmann <gregor+debian@comodo.priv.at>
libuuid-perl (0.02-3) unstable; urgency=low
* debian/watch: use dist-based URL.
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza).
* debian/rules:
- fix removal of /usr/share/perl5 in debian/rules (closes: #463440)
- install upstream changelog
- move tests to build-stamp target
- let install-stamp depend on build-stamp
* Add /me to Uploaders.
2008-01-31 - Clint Adams <schizo@debian.org>
libuuid-perl (0.02-2) unstable; urgency=low
* Fix FTBFS with perl 5.10 (rules could not cope with a non-broken
MakeMaker).  closes: #463440.
* Bump to Standards-Version 3.7.3.
* Set maintainer to Debian Perl Group.
2007-01-04 - Clint Adams <schizo@debian.org>
libuuid-perl (0.02-1) unstable; urgency=low
* Initial Release.

See Also

Package Description
libuuid-tiny-perl_1.0400-1_all.deb pure Perl module to generate v1, v3, v4, and v5 UUIDs
libuuid1_2.25.2-6_amd64.deb Universally Unique ID library
libuuidm-ocaml-dev_0.9.5-1+b1_amd64.deb Universally unique identifiers for OCaml
libuv0.10-dev_0.10.28-6_amd64.deb asynchronous event notification library - development files
libuv0.10_0.10.28-6_amd64.deb asynchronous event notification library - runtime library
libv-perl_0.13-1_all.deb module for printing the version of specified perl module(s)
libv4l-0_1.6.0-2_amd64.deb Collection of video4linux support libraries
libv4l-dev_1.6.0-2_amd64.deb Collection of video4linux support libraries (development files)
libv4l2rds0_1.6.0-2_amd64.deb Video4Linux Radio Data System (RDS) decoding library
libv4lconvert0_1.6.0-2_amd64.deb Video4linux frame format conversion library
libv8-3.14-dev_3.14.5.8-8.1_amd64.deb V8 JavaScript engine - development files for 3.14 branch
libv8-3.14.5_3.14.5.8-8.1_amd64.deb V8 JavaScript engine - runtime library
libv8-dev_3.14.5.8-8.1_amd64.deb V8 JavaScript engine - development files for latest branch
libva-dev_1.4.1-1_amd64.deb Video Acceleration (VA) API for Linux -- development files
libva-drm1_1.4.1-1_amd64.deb Video Acceleration (VA) API for Linux -- DRM runtime
Advertisement
Advertisement